Apache startet nicht / Installationsfehler bei "php.exe"

Irgendwelche Probleme mit XAMPP für Windows? Dann ist hier genau der richtige Ort um nachzufragen.

Apache startet nicht / Installationsfehler bei "php.exe"

Postby Andreas2000 » 14. February 2017 13:49

Hallo,

hier meldet sich ein blutiger Neuling! :)

Ich habe Xampp 5.6.28 für Windows32 auf einem Windows-XP-Rechner installiert (soweit erfolgreich, direkt auf C:/...).
Beim Start des Controlpanels (Version 3.2.2) ist ja zunächst mal nichts aktiviert.
Ich versuche "Apache" über den "Starten"-Button zu starten, sehe aber nur die Textzeile "Versuche Apache zu starten...".
Weiter geschieht NICHTS.

Nun sind allerdings folgende zwei Fehlermeldungen beim Installieren zu erwähnen:

Erst kam diese Meldung:
C:\xampp\php\php.exe ist keine zulässige Win32-Anwendung.

Dann kam diese Meldung:
Problem running post-install step. Installation may not complete correctly
Installation failed (php.exe). Perhaps you have to install the Microsoft Visual C++ 2008
Redistributable package. After that please execute the setup_xampp.bat in the xampp
folger manually.


Frage 1:
Liegt genau da die Ursache, dass im Control-Panel keine Reaktion kommt wenn ich Apache starten will (gilt übrigens für MySQL ebenso)?

Frage 2:
Über Systemsteuerung/Software sehe ich dass ich DIVERSE Installationen von C++ 2008 drauf habe.
Wie finde ich heraus um WELCHE davon es genau geht?
bzw. wenn ich da noch mal was neu installieren möchte: muss ich EINE BESTIMMTE(?) oder ALLE(?) 2008-Versionen erst deinstallieren?

Ich habe zwar "a bisserle Ahnung" von PC-Sachen, aber in DIESEM Bereich ist für mich alles neu! :-(
Letztlich möchte ich eine Joomla-Seite über Xampp offline überprüfen.

Freue mich über jede Art von Antwort!
Danke schon mal! :-)
Andreas2000
 
Posts: 5
Joined: 14. February 2017 12:21
Location: Bremen
XAMPP version: 5.6.28
Operating System: Windows XP

Re: Apache startet nicht / Installationsfehler bei "php.exe"

Postby Altrea » 14. February 2017 23:47

Hallo Andreas,

Andreas2000 wrote:Frage 1:
Liegt genau da die Ursache, dass im Control-Panel keine Reaktion kommt wenn ich Apache starten will (gilt übrigens für MySQL ebenso)?

Nein. PHP unterstützt Windows XP schon seit geraumer Zeit nicht mehr. Die letzten PHP Versionen die mit Windows XP lauffähig waren sind PHP 5.3.X

mit freundlichen Grüßen,
Altrea
We don't provide any support via personal channels like PM, email, Skype, TeamViewer!

It's like porn for programmers 8)
User avatar
Altrea
AF Moderator
 
Posts: 8728
Joined: 17. August 2009 13:05
XAMPP version: several
Operating System: Windows 10 Pro x64

Re: Apache startet nicht / Installationsfehler bei "php.exe"

Postby Andreas2000 » 15. February 2017 23:09

Danke schon mal für die Antwort, Altrea!

Nun mal eine ganz laienhafte Gegenfrage:
Ich hab mir aus dem PHP-Archiv im Netz einfach mal die Version 5.3.1 runtergeladen.
Mein installiertes Xampp hat die Version 5.6.28, und die mitgelieferte php.exe zeigt die gleiche Versionsnummer.
Wäre es theoretisch möglich, das mit der php-Version 5.3.1 zu überschreiben?
Wäre das ein RIESENAKT mit gefühlten tausend weiteren Eventualitäten?
Oder müsste ich dazu passend dann auch eine entsprechend ältere Version von Xampp installieren?
Oder geht das alles NICHT? Würde dann nur ein Systemupgrade auf wenigstens Windows 7 helfen? Nix anderes?
Ich hinterfrage das so ausführlich, weil ich erstens Null Ahnung von Systemupgrade habe,
und mich zweitens frage, was mir das dann wieder an weiteren Problemen mitbringt
(evtl. geht mir die Funktionsfähigkeit der einen oder anderen Software verloren...).

Hab leider nicht genug Zeit gehabt, selber Weiteres dazu im Netz zu checken,
also irgendein thematisch passender Link wäre auch schon eine Hilfe! :)

Danke + Gruß, Andreas
Andreas2000
 
Posts: 5
Joined: 14. February 2017 12:21
Location: Bremen
XAMPP version: 5.6.28
Operating System: Windows XP

Re: Apache startet nicht / Installationsfehler bei "php.exe"

Postby Nobbie » 15. February 2017 23:25

Probier doch einfach alles aus, so viel Aufwand ist das nicht. Insgesamt wäre es sicherlich das Beste, sich endlich mal vom steinalten XP zu verabschieden, selbst Microsoft hat schon seit Jahren den Support eingestellt. Du tust Dir einen denkbar schlechten Gefallen, immer noch an XP festzuhalten.
Nobbie
 
Posts: 9419
Joined: 09. March 2008 13:04

Re: Apache startet nicht / Installationsfehler bei "php.exe"

Postby Altrea » 15. February 2017 23:29

Andreas2000 wrote:Wäre es theoretisch möglich, das mit der php-Version 5.3.1 zu überschreiben?

Rein theoretisch gesprochen ist es möglich eine beliebige PHP Version mit Apache zu koppeln, nicht unbedingt als Apache Modul, aber mindestens über CGI.

Andreas2000 wrote:Wäre das ein RIESENAKT mit gefühlten tausend weiteren Eventualitäten?

Für einen ausgebildeten Systemadministrator mit Erfahrung im Umgang von Apache und PHP wäre das ein überschaubarer Aufwand.
Für einen Laien wäre dies sicher ein RIESENAKT.
Hypothetisch gesprochen, wenn du die Kenntnisse hättest würdest du XAMPP garnicht mehr verwenden, da du dann durch so ein vorkonfiguriertes Bundle mehr Nachteile als Vorteile hättest.
Denn im Grunde ist der Hauptvorteil von einem Webserver Bundle, dass auch ein Laie einen privaten Webserver lokal laufen lassen kann und sich diese Konfiguriererei spart.

Andreas2000 wrote:Oder müsste ich dazu passend dann auch eine entsprechend ältere Version von Xampp installieren

Das wäre die einfachste aller Möglichkeiten. Mir ist gerade aufgefallen, dass ich mich in meiner Ursprungsantwort vertippt habe. Du kannst PHP bis zur Version 5.4 auf Windows XP zum Laufen bringen.
Mit PHP 5.5.0 wurde der Windows XP und Windows Server 2003 support eingestellt.
Die letzten XAMPP Versionen die PHP 5.4.X enthielten wären also XAMPP 1.8.X

Andreas2000 wrote:Oder geht das alles NICHT? Würde dann nur ein Systemupgrade auf wenigstens Windows 7 helfen? Nix anderes?

Die Alternativen wurden oben genannt. Ein Upgrade auf Windows 7 würde ich natürlich trotzdem empfehlen, allein schon wegen dem ausgelaufenden Support.

Andreas2000 wrote:Ich hinterfrage das so ausführlich, weil ich erstens Null Ahnung von Systemupgrade habe,
und mich zweitens frage, was mir das dann wieder an weiteren Problemen mitbringt
(evtl. geht mir die Funktionsfähigkeit der einen oder anderen Software verloren...).

Das ist nie vollständig auszuschließen.
We don't provide any support via personal channels like PM, email, Skype, TeamViewer!

It's like porn for programmers 8)
User avatar
Altrea
AF Moderator
 
Posts: 8728
Joined: 17. August 2009 13:05
XAMPP version: several
Operating System: Windows 10 Pro x64

Re: Apache startet nicht / Installationsfehler bei "php.exe"

Postby Andreas2000 » 16. February 2017 22:48

Hallo Altrea,

danke für deine detaillierte Antwort! :)

Ich werde versuchen mir Windows 7 auf eine Extra-Partition zu installieren (grad gekauft).
Verschiedene Partitionen sind ja wohl hoffentlich deutlich genug voneinander getrennt,
dass da verschiedene Systeme laufen können ohne sich gegenseitig zu "beißen"... (?)

Dessen ungeachtet noch ne recht simple weitere Frage auf Windows XP - Basis:
"Die letzten XAMPP Versionen die PHP 5.4.X enthielten wären also XAMPP 1.8.X"
Wenn ich Xampp wirklich NUR dafür nutzen möchte um eine Webseite mit Joomla und Kunena-Forum
vorab auf Aussehen und Funktionalität rundherum überprüfen zu können (keine Absicht, dort ne Programmzeile zu schreiben!),
reicht dann Xampp 1.8.X mit PHP 5.4.X ?
Ich habe keine Vorstellung davon, was für Features die neueren Versionen bringen
und ob ein Laie diese für so einfache Dinge wie oben beschrieben überhaupt braucht.
Wäre nett wenn du mir dazu noch "ne Richtung" mit auf den Weg geben könntest!
Danke soweit + Gruß, Andreas :)
Andreas2000
 
Posts: 5
Joined: 14. February 2017 12:21
Location: Bremen
XAMPP version: 5.6.28
Operating System: Windows XP

Re: Apache startet nicht / Installationsfehler bei "php.exe"

Postby Andreas2000 » 16. February 2017 22:52

@Nobbie

Ich hatte halt jahrelang ein "Inseldasein" geführt - komme erst jetzt in gewisse Verlegenheiten!
Aber dank deines Anstoßes kaufe ich mir jetzt wenigstens Windows 7! :wink:
Danke für deine Antwort + Gruß, Andreas
Andreas2000
 
Posts: 5
Joined: 14. February 2017 12:21
Location: Bremen
XAMPP version: 5.6.28
Operating System: Windows XP

Re: Apache startet nicht / Installationsfehler bei "php.exe"

Postby Andreas2000 » 11. April 2017 14:10

Nach Installation von Windows 7 (zugegeben nicht grad das Neueste) läuft es jetzt - und damit ist das Problem gelöst.
Kann man hier einen Fragethread als "gelöst" markieren? (hab ich nicht gefunden).
Andreas2000
 
Posts: 5
Joined: 14. February 2017 12:21
Location: Bremen
XAMPP version: 5.6.28
Operating System: Windows XP


Return to XAMPP für Windows

Who is online

Users browsing this forum: No registered users and 8 guests