Unterschiede von PHP aus Xampp und PHP aus Suse 9

Irgendwelche Probleme mit XAMPP für Linux? Dann ist hier genau der richtige Ort um nachzufragen.

Unterschiede von PHP aus Xampp und PHP aus Suse 9

Postby Flow23 » 20. January 2005 12:31

Hallo zusammen,

nachdem meine Firma seit ca. 1 Jahr ihr Intranet (zentrale interne Webseite, mit PHP programmiert) auf einem Linuxserver mit Xampp 1.4.7 laufen lies, wurde nun ein neuer Server angeschafft und dort SuSe 9 inklusive der Einzelkomponenten Apache Webserver 2, MySQL, PHP 4.3.4 etc... installiert, also weg von Xampp. Nun machte sich aber beim Intranet auf dem neuen Server ohne Xampp bemerkbar, dass PHP aus Xampp wohl einige Unterschiede zum normalen PHP aufweist.
Mir sind bisher aufgefallen:

Altes Intranet mit PHP aus Xampp:
*****************************

- Ein Seitenwechsel per "header(Location: Pfad und Name der Seite);" ist möglich

- Session-Variablen müssen nicht explizit mit dem Zusatz
"$_SESSION['Name der Variable']" aufgerufen werden, es reicht "$Name der Variable"

- Nach dem Abschicken eines Formulars müssen die Formularwerte nicht explizit mit dem Zusatz "$_REQUEST['Name der Variable']" aufgerufen werden, es reicht "$Name der Variable"

- Es ist egal wo session_start() steht, mehrere session_start()-Aufrufe in derselben PHP-Datei werden ignoriert

Neues PHP aus SuSe 9:
********************

- Ein Seitenwechsel per "header(Location: Pfad und Name der Seite);" behindert sich mit session_start(), deswegen muss mit print '<script>window.location="Pfad und Name der Seite"</script>'; ausgewichen werden

- Session-Variablen MÜSSEN zwingend mit dem Zusatz
"$_SESSION['Name der Variable']" aufgerufen werden, sonst wird die Variable nicht gefunden

- Nach dem Abschicken eines Formulars MÜSSEN die Formularwerte zwingend mit dem Zusatz "$_REQUEST['Name der Variable']" aufgerufen werden, sonst wird die Variable nicht gefunden

- Es tauchen Fehler auf, wenn session_start() nicht am Anfang der Seite steht und mehrmals session_start() in einer PHP-Datei vorkommt


Nun meine Fragen:

- Welche Abweichungen gibt es noch??
- Lassen sich diese Abweichungen irgendwie umgehen?? Es wäre nämlich sehr aufwändig den gesamten Quellcode des Intranets zu ändern!

Bitte antwortet mir.

Gruß Flow
Flow23
 
Posts: 10
Joined: 25. November 2004 09:46
Location: Hamburg

Postby Ceelight » 20. January 2005 15:27

Ich glaube, bitte berichtigt mich, wenn ich falsch liege, dass Du den Schalter "register_globals" in der "Suse php.ini" auf on setzen musst. Damit sollte das Variablen-Problem gelöst sein.

Sollte aber nur für den internen Gebrauch, also Intranet so eingestellt werden. Für den Produktivbetrieb im Internet wird aus Sicherheitsgründen mittlerweile "off" empfohlen.
There's no place like 127.0.0.1
User avatar
Ceelight
 
Posts: 295
Joined: 31. January 2004 19:57
Location: Pfälzer im niedersächsischen Exil ;-)

Ich bin Dir sehr dankbar!

Postby Flow23 » 21. January 2005 12:44

Danke, du hast mir echt ne Menge Arbeit ersparrt. War schon dabei den gesamten Quellcode zu ändern, was bestimmt nen halben Monat gebraucht hätte. Aber mit der Umstellung der Variable auf On funzt so gut wie alles. Dieser Unterschied hatte also nix mit Xampp zu tun, denn auf dem alten System war register_globals natürlich von vornherein auf On gestellt.
Nun noch ne andere Frage:

Das Einzige was das alte und das neue Intranet unterscheidet, ist dass beim neuen Intranet eine bestimmte PHP-Datei die folgenden Fehler anzeigt:

Warning: session_start(): Cannot send session cookie - headers already sent by (output started at /srv/www/htdocs/fenthols/modules/projekte/index.php:2) in /srv/www/htdocs/fenthols/modules/userpass/checkuser.php on line 3

Warning: session_start(): Cannot send session cache limiter - headers already sent (output started at /srv/www/htdocs/fenthols/modules/projekte/index.php:2) in /srv/www/htdocs/fenthols/modules/userpass/checkuser.php on line 3

Ansonsten funktioniert die Seite aber. Im alten Intranet taucht dieser Fehler nie auf.

Kann auch dies mit einer Einstellung in der PHP.ini zu tun haben?????

Gruß Flow und nochmals vielen Dank
Flow23
 
Posts: 10
Joined: 25. November 2004 09:46
Location: Hamburg

Postby Wiedmann » 21. January 2005 13:01

Wiedmann
AF Moderator
 
Posts: 17106
Joined: 01. February 2004 12:38
Location: Stuttgart / Germany

So lösen sich all meine Probleme!

Postby Flow23 » 21. January 2005 13:13

Wow so gute Hilfe habe ich lange nicht bekommen!
OK, es waren einfach zwei spezielle Befehle in der PHP.ini, aber auch die muss man erstmal kennen. Vielen Dank!
Flow23
 
Posts: 10
Joined: 25. November 2004 09:46
Location: Hamburg


Return to XAMPP für Linux

Who is online

Users browsing this forum: No registered users and 5 guests