Apache läuft nicht

Irgendwelche Probleme mit XAMPP für Linux? Dann ist hier genau der richtige Ort um nachzufragen.

Apache läuft nicht

Postby KoC » 17. January 2005 17:05

Ich hatte Xampp vor einem Monat auf meinem Server erfolgreich installiert. Aber heute als ich meine Seite betrat, war der Apache down. Ich habe versucht den Apache hochzufahren. Aber es hat nicht funktioniert. Meine Konsole hat beim Start keine Fehler angezeigt. Ich habe Xampp auf Linux (Debian) installiert. Der Server ist ein Vserver.
KoC
 
Posts: 9
Joined: 23. December 2004 14:28

Postby Wiedmann » 17. January 2005 17:09

Ohne Fehlermeldung oder was im Log steht wird dir hier wohl keiner helfen können...
Wiedmann
AF Moderator
 
Posts: 17106
Joined: 01. February 2004 12:38
Location: Stuttgart / Germany

Postby KoC » 17. January 2005 17:12

Wo kann ich die log finden
KoC
 
Posts: 9
Joined: 23. December 2004 14:28

Postby KoC » 17. January 2005 17:18

Entschuldigung für die dumme frage, ich hab sie gefunden. Hier ist sie

[Mon Jan 17 13:16:44 2005] [error] (11)Resource temporarily unavailable: fork: Unable to fork new process
[Mon Jan 17 13:16:56 2005] [error] (11)Resource temporarily unavailable: fork: Unable to fork new process
[Mon Jan 17 13:17:06 2005] [error] (11)Resource temporarily unavailable: fork: Unable to fork new process
[Mon Jan 17 13:17:16 2005] [error] (11)Resource temporarily unavailable: fork: Unable to fork new process
[Mon Jan 17 13:17:26 2005] [error] (11)Resource temporarily unavailable: fork: Unable to fork new process
[Mon Jan 17 13:18:00 2005] [error] (11)Resource temporarily unavailable: fork: Unable to fork new process
[Mon Jan 17 13:18:11 2005] [error] (11)Resource temporarily unavailable: fork: Unable to fork new process
[Mon Jan 17 13:18:21 2005] [error] (11)Resource temporarily unavailable: fork: Unable to fork new process
[Mon Jan 17 13:18:31 2005] [error] (11)Resource temporarily unavailable: fork: Unable to fork new process
[Mon Jan 17 13:18:41 2005] [error] (11)Resource temporarily unavailable: fork: Unable to fork new process
[Mon Jan 17 13:19:24 2005] [error] (11)Resource temporarily unavailable: fork: Unable to fork new process
[Mon Jan 17 13:19:35 2005] [error] (11)Resource temporarily unavailable: fork: Unable to fork new process
[Mon Jan 17 13:19:45 2005] [error] (11)Resource temporarily unavailable: fork: Unable to fork new process
[Mon Jan 17 13:19:56 2005] [error] (11)Resource temporarily unavailable: fork: Unable to fork new process
[Mon Jan 17 13:20:06 2005] [error] (11)Resource temporarily unavailable: fork: Unable to fork new process
[Mon Jan 17 13:20:17 2005] [error] (11)Resource temporarily unavailable: fork: Unable to fork new process
[Mon Jan 17 13:20:17 2005] [error] [client 81.+++.+++.++] (11)Resource temporarily unavailable: couldn't create child process: 11: cgi.cgi
[Mon Jan 17 13:20:17 2005] [error] [client 81.+++.+++.++] (11)Resource temporarily unavailable: couldn't spawn child process: /opt/lampp/htdocs/xampp/cgi.cgi
[Mon Jan 17 13:20:17 2005] [error] [client 81.+++.+++.++] (11)Resource temporarily unavailable: couldn't create child process: 11: perl.pl
[Mon Jan 17 13:20:17 2005] [error] [client 81.+++.+++.++] (11)Resource temporarily unavailable: couldn't spawn child process: /opt/lampp/htdocs/xampp/perl.pl
[Mon Jan 17 13:20:27 2005] [error] (11)Resource temporarily unavailable: fork: Unable to fork new process
[Mon Jan 17 13:24:14 2005] [warn] child process 16065 still did not exit, sending a SIGTERM
[Mon Jan 17 13:24:14 2005] [warn] child process 15711 still did not exit, sending a SIGTERM
[Mon Jan 17 13:24:15 2005] [notice] caught SIGTERM, shutting down
[Mon Jan 17 13:24:31 2005] [notice] suEXEC mechanism enabled (wrapper: /opt/lampp/bin/suexec)
[Mon Jan 17 13:28:08 2005] [notice] suEXEC mechanism enabled (wrapper: /opt/lampp/bin/suexec)
[Mon Jan 17 13:32:14 2005] [notice] suEXEC mechanism enabled (wrapper: /opt/lampp/bin/suexec)
[Mon Jan 17 13:34:19 2005] [notice] suEXEC mechanism enabled (wrapper: /opt/lampp/bin/suexec)
[Mon Jan 17 13:34:47 2005] [notice] suEXEC mechanism enabled (wrapper: /opt/lampp/bin/suexec)
[Mon Jan 17 13:37:09 2005] [notice] suEXEC mechanism enabled (wrapper: /opt/lampp/bin/suexec)
[Mon Jan 17 13:37:41 2005] [notice] suEXEC mechanism enabled (wrapper: /opt/lampp/bin/suexec)
[Mon Jan 17 13:43:23 2005] [notice] suEXEC mechanism enabled (wrapper: /opt/lampp/bin/suexec)
[Mon Jan 17 13:44:11 2005] [notice] suEXEC mechanism enabled (wrapper: /opt/lampp/bin/suexec)
[Mon Jan 17 13:51:20 2005] [notice] suEXEC mechanism enabled (wrapper: /opt/lampp/bin/suexec)
[Mon Jan 17 14:31:34 2005] [notice] suEXEC mechanism enabled (wrapper: /opt/lampp/bin/suexec)
[Mon Jan 17 16:59:13 2005] [notice] suEXEC mechanism enabled (wrapper: /opt/lampp/bin/suexec)
KoC
 
Posts: 9
Joined: 23. December 2004 14:28

Postby deepsurfer » 17. January 2005 17:19

/opt/lampp/logs

chirio
Deep
User avatar
deepsurfer
AF Moderator
 
Posts: 6440
Joined: 23. November 2004 10:44
Location: Cologne
Operating System: Win-XP / Win7 / Linux -Debian

Postby Oswald » 17. January 2005 18:37

Hallo KoC!

Sieht so aus als ob dein Server überlastet ist (Resource temporarily unavailable: fork: Unable to fork new process) und deswegen keine weiteren Prozesse mehr starten kann. Läuft sonst noch was auf dem Server was die Ursache dafür sein könnte?

Liebe Grüße
Oswald
User avatar
Oswald
Apache Friends
 
Posts: 2718
Joined: 26. December 2002 19:51
Location: Berlin, Germany
Operating System: Linux

Postby KoC » 17. January 2005 21:31

Also das alles läuft au dem Server

11298 root 12.0 % /home/webmin-1.170/proc/index_cpu.cgi
7695 root 0.0 % /sbin/syslogd
7709 root 0.0 % /usr/sbin/inetd
7869 root 0.0 % /usr/lib/postfix/master
7872 postfix 0.0 % qmgr -l -t fifo -u -c
7878 root 0.0 % /usr/sbin/sshd
7881 daemon 0.0 % /usr/sbin/atd
7884 root 0.0 % /usr/sbin/cron
16587 root 0.0 % /usr/bin/perl /home/webmin-1.170/miniserv.pl /etc/webmin/miniserv.conf
14450 root 0.0 % /bin/sh /opt/lampp/bin/mysqld_safe --datadir=/opt/lampp/var/mysql --pid-file=/op ...
14482 nobody 0.0 % /opt/lampp/sbin/mysqld --basedir=/opt/lampp --datadir=/opt/lampp/var/mysql --use ...
14484 nobody 0.0 % /opt/lampp/sbin/mysqld --basedir=/opt/lampp --datadir=/opt/lampp/var/mysql --use ...
14485 nobody 0.0 % /opt/lampp/sbin/mysqld --basedir=/opt/lampp --datadir=/opt/lampp/var/mysql --use ...
9788 postfix 0.0 % pickup -l -t fifo -u -c
11261 nobody 0.0 % vsftpd
11263 root 0.0 % vsftpd
1 root 0.0 % init [2]
11302 root 0.0 % sh -c ps --cols 500 -eo user,ruser,group,rgroup,pid,ppid,pgid,pcpu,vsz,nice,etim ...
11303 root 0.0 % ps --cols 500 -eo user,ruser,group,rgroup,pid,ppid,pgid,pcpu,vsz,nice,etime,time ...

sie können mir ja sagen was ich abschalten kann
KoC
 
Posts: 9
Joined: 23. December 2004 14:28

Postby KoC » 17. January 2005 22:51

also ich denke nicht das der server ausgelastet ist, der ist noch tip top, hat auch mein Support gesagt

ich stoppe xampp dann starte ich es wieder ohne Fehlermeldungen. dann wenn ich ist wieder stoppe steht in der Konsole "XAMPP-Apache is not running."

Das muss doch funktionieren. Ich bin ganz durcheinander bitte hilft mir weiter

In die Errorlog hab ich wieder geguckt da steht nur noch

[Mon Jan 17 21:31:18 2005] [notice] suEXEC mechanism enabled (wrapper: /opt/lampp/bin/suexec)
[Mon Jan 17 21:34:34 2005] [notice] suEXEC mechanism enabled (wrapper: /opt/lampp/bin/suexec)
[Mon Jan 17 21:50:10 2005] [notice] suEXEC mechanism enabled (wrapper: /opt/lampp/bin/suexec)
[Mon Jan 17 22:11:40 2005] [notice] suEXEC mechanism enabled (wrapper: /opt/lampp/bin/suexec)
[Mon Jan 17 22:45:32 2005] [notice] suEXEC mechanism enabled (wrapper: /opt/lampp/bin/suexec)
[Mon Jan 17 22:46:25 2005] [notice] suEXEC mechanism enabled (wrapper: /opt/lampp/bin/suexec)
[Mon Jan 17 22:49:29 2005] [notice] suEXEC mechanism enabled (wrapper: /opt/lampp/bin/suexec)
KoC
 
Posts: 9
Joined: 23. December 2004 14:28

Postby glitzi85 » 23. January 2005 19:54

hmm, also das mit dem Apache läuft nicht usw. kommt davon, wenn man den Lampp zu schnell startet, nachdem man es gestoppt hat. Einfach kurz warten (max. 1 min) nach dem starten oder stoppen und danach weitermachen oder einfach gleich reload machen.

Das mit suEXEC sagt, dass bei dir die suexec-Funktion deaktiviert ist. Ich hab noch nie damit gearbeitet, aber was soll bei dir denn über suexec gemacht werden?

mfg glitzi
User avatar
glitzi85
 
Posts: 1920
Joined: 05. March 2004 23:26
Location: Dahoim


Return to XAMPP für Linux

Who is online

Users browsing this forum: No registered users and 2 guests