mysql error 2002 - suse linux 7.2

Irgendwelche Probleme mit XAMPP für Linux? Dann ist hier genau der richtige Ort um nachzufragen.

mysql error 2002 - suse linux 7.2

Postby Steve1712 » 26. December 2004 19:00

Hallo bekomme wenn ich mit myphpadmin den sql server verwalten will den mysql error 2002 irgendwas mit socket.. hab schon die suchfunktion benutz aber das hat mir nix geholfen... bin absoluter linux newbie...

der fehler kommt auch wenn ich phpbb instalieren will!!

bitte helft mir
Steve1712
 
Posts: 10
Joined: 26. December 2004 17:20

Postby DJ DHG » 26. December 2004 21:29

Moin Moin

MySql Manual wrote:Der Fehler (2002) Can't connect to ... bedeutet
normalerweise, dass auf dem System kein MySQL-Server läuft oder dass Sie
eine falsche Socket-Datei oder einen falschen TCP/IP-Port bei der Verbindung
mit dem mysqld-Server benutzen


http://dev.mysql.com/doc/mysql/de/Can_n ... erver.html

mfg DJ DHG
User avatar
DJ DHG
AF Moderator
 
Posts: 2455
Joined: 27. December 2002 13:50
Location: Kiel

Postby Steve1712 » 26. December 2004 21:54

ok also folgendes problem:

hab probiert /opt/lampp/lampp stopmysql

dann kommt xampp-mysql is not running

wenn ich /opt/lammp/lampp startmysql eingebe

dann kommt a mysql deamon is already running...

hmm

help ;)
Steve1712
 
Posts: 10
Joined: 26. December 2004 17:20

Postby Steve1712 » 26. December 2004 22:05

Hallo

problem gelöst!

hab von früheren lamp install versuchen den sql bereits drauf gehabt... und hab jetzt einfach die die start und kill file aus dem runlevel 5 ordner rausgelöscht :)

problem gelöst kann jetzt mit myphpadmin drauf zugreifen kein socket error mehr :)
Steve1712
 
Posts: 10
Joined: 26. December 2004 17:20

Postby DJ DHG » 26. December 2004 22:05

Werfe einen Blick in die Logs?

mfg DJ DHG
User avatar
DJ DHG
AF Moderator
 
Posts: 2455
Joined: 27. December 2002 13:50
Location: Kiel

Postby Steve1712 » 26. December 2004 22:38

hallo ok neues problem :)

habe über myphpadmin das password für mysql geändert...

gut.. .dann habe ich per hand die config.inc.php der mysql angepasst... den vorher is logischerweise eine fehlermeldung gekommen...

allerdings kommt jetzt folgender text... habe schon versucht die mysql security einstellungen mit dem wizard zurück zusetzen das hat auch geklappt aber die fehler meldungen kommen trozdem noch:

Warning: Cannot modify header information - headers already sent by (output started at /opt/lampp/phpmyadmin/config.inc.php:833) in /opt/lampp/phpmyadmin/libraries/auth/cookie.auth.lib.php on line 620

Warning: Cannot modify header information - headers already sent by (output started at /opt/lampp/phpmyadmin/config.inc.php:833) in /opt/lampp/phpmyadmin/libraries/auth/cookie.auth.lib.php on line 628

Warning: Cannot modify header information - headers already sent by (output started at /opt/lampp/phpmyadmin/config.inc.php:833) in /opt/lampp/phpmyadmin/libraries/auth/cookie.auth.lib.php on line 659

woran könnte das jetzt liegen?!
Steve1712
 
Posts: 10
Joined: 26. December 2004 17:20

Postby Steve1712 » 26. December 2004 22:42

aja nochwas.. seit dem ich den wizard verwendet habe kommt auch immer bei myphpadmin so ein login fenster das war früher nicht... da is direkt die oberfläche gekommen...
Steve1712
 
Posts: 10
Joined: 26. December 2004 17:20

Postby DJ DHG » 27. December 2004 00:04

Dir ist schon klar, wofür Wizard gut ist oder?

Das Ding schimpft sich im übrigen phpmyadmin, und nicht myphpadmin!
Was hast du in der config.inc.php geändert?

mfg DJ DHG
User avatar
DJ DHG
AF Moderator
 
Posts: 2455
Joined: 27. December 2002 13:50
Location: Kiel

Postby Steve1712 » 27. December 2004 14:26

hallo nochmal

sorry muß natürlich phpmyadmin heisen hab nicht aufgepasst beim schreiben :)

also wizard mit bluesky ist dafür gut die mysql passwörter zurück zusetzen! das hab ich auch gemacht...

mittlerweile funktioniert es ja auch schon wieder habe folgenden fehler gemacht!

also zuerst hab ich ein paar mal über security die pwd's für pma und root geändert...

dann bin über phpmyadmin nicht mehr rein gekommen dann hab ich mir gedacht ich muß die config.inc.php anpassen im phpmyadmin ordner das hab ich dann auch gemacht allerdings ist nach den änderungen von config auf http immer die fehlermeldung gekommen...

hab das ganze ein paar mal probiert und immer wieder neuinstallieren müssen..

und irgendwann hab ich dann einfahc nur die security änderungen gemacht und plötzlich bin ich ohne config.inc.php änderung auch mit phpmyadmin wieder reingekommen was ich eigentlih ja nicht verstehe aber gut wenns läuft

hab am anfang schon mal drn gedacht das es viel. an der einstellung der errichbarkeit desmysql ausm netz gelegen haben könnte...
Steve1712
 
Posts: 10
Joined: 26. December 2004 17:20


Return to XAMPP für Linux

Who is online

Users browsing this forum: No registered users and 1 guest