XAMPP und Oracle 10g

Irgendwelche Probleme mit XAMPP für Linux? Dann ist hier genau der richtige Ort um nachzufragen.

XAMPP und Oracle 10g

Postby s.rutz » 08. December 2004 10:22

Hi,

ich bräucht mal Fachkundigen Rat :D

Ich habe die aktuellste Version des XAMPP Packetes für Linux installiert und möchte jetzt den oci Support für PHP aktivieren.

Oracle 10g ist installiert und läuft.

Leider ist das Script oci8install immer auf die Nase gefallen, also hab ich anhand des Scriptes die SLinks manuell gesetzt. Leider bekomme ich beim starten des Apachen immer folgende Fehlermeldung

PHP Warning: Unknown(): Unable to load dynamic library '/opt/lampp/lib/php/extensions/no-debug-non-zts-20020429/oci8.so' - /opt/lampp/lib/libclntsh.so.9.0: ELF file data encoding not little-endian in Unknown on line 0
XAMPP: Starting Apache with SSL (and PHP4)...


ich habe keine Ahnung was mir noch fehlt. Müssen die Oracle Umgebungsvariablen auch für root gesetzt werden? Sonst vielleicht jemand eine Idee. Danke.
s.rutz
 
Posts: 5
Joined: 08. December 2004 10:13

Postby deepsurfer » 08. December 2004 10:27

Leider ist das Script oci8install immer auf die Nase gefallen, also hab ich anhand des Scriptes die SLinks manuell gesetzt.


welche SLinks hast du gesetzt, denn laut deiner Fehlermeldung hast du LAMPP intern etwas umgebogen.

Poste mal deine SLinks.

chirio
Deep
User avatar
deepsurfer
AF Moderator
 
Posts: 6440
Joined: 23. November 2004 10:44
Location: Cologne
Operating System: Win-XP / Win7 / Linux -Debian

Postby s.rutz » 08. December 2004 10:31

ln -s /opt/oracle/product/10g/oui/lib/linux/libclntsh.so.9.0 /opt/lampp/lib/libclntsh.so.9.0
ln -s /opt/oracle/product/10g/oui/lib/linux/libwtc9.so /opt/lampp/lib/libwtc9.so


Diese Links habe ich gesetzt. Dank für die schnelle Antwort
s.rutz
 
Posts: 5
Joined: 08. December 2004 10:13

Postby deepsurfer » 08. December 2004 10:49

/opt/lampp/lib/php/extensions/no-debug-non-zts-20020429/oci8.so


schau mal ob die oci9.so bei oracle bei ist, meine theorie geht dahin
das noch einige zusätzliche Libarys zu LAMPP gesetzt werden müssen
- da ein Aufruf über PHP den Oracle anspricht, aber oracle nun die zwei libarys zwar kennt aber PHP um weitere angaben bittet.
PHP kann diese nicht beantworten und gibt stattdessen seinen eigenen ursprungspunkt als fehler aus.

Kann mich aber täuschen, schätze das entweder KriS oder Oswald sich gleich melden würden, sofern sie oracle als solches kennen.

Wäre gut wenn du den link zum oracle installer postest, damit man gegentesten kann (sofern es keine lizenz software ist)

chirio
Deep
User avatar
deepsurfer
AF Moderator
 
Posts: 6440
Joined: 23. November 2004 10:44
Location: Cologne
Operating System: Win-XP / Win7 / Linux -Debian

Postby Oswald » 08. December 2004 10:52

Hallo s.rutz!

Die Links sehen gut so aus. Allerdings macht mir die Meldung ELF file data encoding not little-endian ein bisschen Sorgen. Was für ein System (Distributions und Prozessor) hast Du?

Liebe Grüße
Oswald
User avatar
Oswald
Apache Friends
 
Posts: 2718
Joined: 26. December 2002 19:51
Location: Berlin, Germany
Operating System: Linux

Postby s.rutz » 08. December 2004 11:10

ich bin einen schritt weiter der link ist im zweifel nicht richtig, da er auf libs des oracle universal installers zeigt.

Also habe ich den Link angepasst auf

libclntsh.so.9.0 -> /opt/oracle/product/10g/lib/libclntsh.so.10.1


Jetzt bekomme ich eine andere Fehlermeldung:

PHP Warning: Unknown(): Unable to load dynamic library '/opt/lampp/lib/php/extensions/no-debug-non-zts-20020429/oci8.so' - libclntsh.so.9.0: cannot open shared object file: No such file or directory in Unknown on line 0


Was ich gerade eben natürlich vergessen habe, ist ein Opteron System (64)
s.rutz
 
Posts: 5
Joined: 08. December 2004 10:13

Postby Oswald » 08. December 2004 11:13

Jetzt sieht es so aus als ob der Link ins Leere zeigt. Sind die Pfade wirklich richtig?
User avatar
Oswald
Apache Friends
 
Posts: 2718
Joined: 26. December 2002 19:51
Location: Berlin, Germany
Operating System: Linux

Postby s.rutz » 08. December 2004 11:30

#ll /opt/oracle/product/10g/lib/libclntsh.so*
lrwxrwxrwx 1 oracle oinstall 45 Dec 6 16:05 /opt/oracle/product/10g/lib/libclntsh.so -> /opt/oracle/product/10g/lib/libclntsh.so.10.1
-rwxr-xr-x 1 oracle oinstall 14770073 Dec 6 16:03 /opt/oracle/product/10g/lib/libclntsh.so.10.1


Meiner Meinung nach stimmen die Links (siehe oben)
s.rutz
 
Posts: 5
Joined: 08. December 2004 10:13

Postby Oswald » 08. December 2004 11:44

Hmm.. dann verstehe ich nicht, woher das No such file or directory in der Fehlermeldung kommt.

Startest Du den Apache über /opt/lampp/lampp start oder benutzt Du einen anderen Weg?
User avatar
Oswald
Apache Friends
 
Posts: 2718
Joined: 26. December 2002 19:51
Location: Berlin, Germany
Operating System: Linux

Problem gelöst

Postby s.rutz » 08. December 2004 13:14

Danke für Eure Hilfe habe das Problem gelöst!

Ich habe die ganze Zeit auf 64 bit Libs gelinkt, da XAMPP aber wahrscheinlich 32 bitig compiliert wurde konnte der Apache mit den 64 bit Libs nicht anfangen. Ich hab den Link auf /opt/oracle/product/10g/lib32/libclntsh.so geändert und es rennt.

Danke für die zügige Hilfe.
s.rutz
 
Posts: 5
Joined: 08. December 2004 10:13


Return to XAMPP für Linux

Who is online

Users browsing this forum: No registered users and 1 guest