Unkillbarer Apache Prozess

Irgendwelche Probleme mit XAMPP für Linux? Dann ist hier genau der richtige Ort um nachzufragen.

Unkillbarer Apache Prozess

Postby maoliter » 02. December 2004 22:09

Hallo,

auf meinem Server (P4 3,0 HT von Strato) mit xampp bekomme ich hin und wieder mal einen Apache-Prozess, der 100% Last frisst und nicht killbar ist. Seht selbst, top zeigt mir:
Code: Select all
  7:05pm  up 3 days, 23:08,  1 user,  load average: 4.56, 5.64, 9.15
100 processes: 96 sleeping, 4 running, 0 zombie, 0 stopped
CPU0 states:  0.0% user, 99.4% system,  0.0% nice,  0.1% idle
CPU1 states: 92.3% user,  3.4% system,  0.0% nice,  3.1% idle
Mem:  2060812K av, 1651360K used,  409452K free,       0K shrd,   59536K buff
Swap:  514072K av,    1832K used,  512240K free                 1237628K cached

  PID USER     PRI  NI  SIZE  RSS SHARE STAT %CPU %MEM   TIME COMMAND
28981 wwwrun    18   0 16832  16M  5996 R    99.9  0.8 148:17 httpd
 3892 wwwrun     9   0 18036  17M  9596 S    19.1  0.8   0:01 httpd
 3875 wwwrun    14   0 17928  17M  9608 R    16.9  0.8   0:02 httpd
 3872 wwwrun     9   0 18572  18M  9624 S    15.3  0.9   0:03 httpd
 3865 wwwrun     9   0 17640  17M  9628 S    13.2  0.8   0:02 httpd
 


Habe ein gut besuchtes phpBB laufen, welches aber auch bei 100Usern Online jetzt im Moment noch schnell läuft. Selbst bei einem Load von >10.0. Das phpBB Ist Query-Optimiert.

Gibts es Möglichkeiten herauszufinden woran das liegt?

Z.Zt. reboote ich den Server täglich. Besser wäre aber die Ursache zu finden.

EnableMMAP off in httpd.conf hat nix gebracht.

Edit:
Hier einige Parameter:
my.cnf:
Code: Select all
skip-locking
key_buffer = 128M
max_allowed_packet = 1M
table_cache = 512
sort_buffer_size = 15M
read_buffer_size = 2M
myisam_sort_buffer_size = 64M
thread_cache = 2
query_cache_size = 32M
# Try number of CPU's*2 for thread_concurrency
thread_concurrency = 2

long_query_time = 2
#log-long-format
log-slow-queries = /opt/lampp/var/mysql/slow_queries.log
max_connections = 2500


httpd.conf:
Code: Select all
Timeout 300
KeepAlive Off
KeepAliveTimeout 15
MaxKeepAliveRequests 100

<IfModule prefork.c>
    StartServers         5
    MinSpareServers      5
    MaxSpareServers     10
    MaxClients         150
    #MaxRequestsPerChild  0
    MaxRequestsPerChild  150
</IfModule>
maoliter
 
Posts: 17
Joined: 15. January 2004 20:36

Postby Oswald » 02. December 2004 22:31

Huhu maoliter!

Bist Du sicher, dass Du XAMPP verwendest? In meinen Augen sieht es nicht so aus.

Hast Du mal versucht den Prozess mit kill -9 zu killen? Das sollte in Deinem Fall eigentlich gut funktionieren.

Liebe Grüße
Oswald
User avatar
Oswald
Apache Friends
 
Posts: 2718
Joined: 26. December 2002 19:51
Location: Berlin, Germany
Operating System: Linux

Postby maoliter » 02. December 2004 23:13

Kai 'Oswald' Seidler wrote:Huhu maoliter!

Bist Du sicher, dass Du XAMPP verwendest? In meinen Augen sieht es nicht so aus.

Hast Du mal versucht den Prozess mit kill -9 zu killen? Das sollte in Deinem Fall eigentlich gut funktionieren.

Liebe Grüße
Oswald


Klar verwende ich xampp.
Habe nur die Configs nachträglich etwas angepasst. 8)

Der Prozess kann nicht gekillt werden, auch nicht mit kill -9
maoliter
 
Posts: 17
Joined: 15. January 2004 20:36

Postby deepsurfer » 03. December 2004 17:04

hhmm.... root server bei strato...

schau mal im crontab nach, ob nicht der apache überprüft wird, zumindest kannst du da sehen welche scripte automatisch gestartet werden und diese prüfen.
Weil Strato dir im vertrag eine 99% Laufzeit zusichert.

Startet denn LAMPP ohne fehlermeldung ??


chirio
Deep
(ich frag jetzt lieder nicht warum das lampp drauf geschmissen wurde :shock: )
User avatar
deepsurfer
AF Moderator
 
Posts: 6440
Joined: 23. November 2004 10:44
Location: Cologne
Operating System: Win-XP / Win7 / Linux -Debian


Return to XAMPP für Linux

Who is online

Users browsing this forum: No registered users and 1 guest