Problem mit ODBC von WinXP nach Linux XAMPP

Irgendwelche Probleme mit XAMPP für Linux? Dann ist hier genau der richtige Ort um nachzufragen.

Problem mit ODBC von WinXP nach Linux XAMPP

Postby trance::m » 20. November 2004 13:29

Zunächst mal ein freundliches Hallo an alle hier ! ;)

Gleich zum Problem: (Hoffe das passt hier überhaupt rein)

Ich habe unter Linux den XAMPP 1.4.9a installiert.
MySQL läuft ganz normal.
Über PHPMyAdmin ist eine Datenbank für das Programm OCS Inventory (open source) angelegt.
Nun möchte ich von WinXP über den ODBC Treiber auf die MySQL Datenbank des Linuxrechners zugreifen.
Der ODBC 3.51 Treiber ist auf dem Windows System installiert.
Über Verwaltung/ODBC... habe ich erfolgreich eine Verbindung als Benutzer DNS einrichten können. Sprich, bei einem Klick auf "Test" kommt eine Erfolgsmeldung.

Den OCS Manager kann man nun so umstellen, dass er eine MySQL Datenbank verwendet.
Wenn ich hier nun die Konfiguration öffne, erscheint ein kleines Programm das sich "Datenverknüpfungseigenschaften" nennt.
In diesem Menü kann ich unter Provider den "Mivrosoft OLE DB Provider for ODBC Drivers" wählen. Nach anschliessendem "Weiter" kommt das Verbindungsfenster. Dort kann ich mir die Datenquelle aussuchen, und es erscheint in der Liste der Eintrag den ich im Windows ODBC unter Benutzer-DNS vorher angelegt hatte.
Im Reiter "zu verwendender Anfangskatalog" erscheinen ebenfalls alle unter MySQL auf dem Linuxrechner verfügbaren MySQL Tabellen.
Bis dahin sieht alles so aus, als würde es prima funktionieren.
Wenn ich nun aber meinen gewünschten Anfangskatalog auswähle, erscheint folgende Fehlermeldung:
Code: Select all
Microsoft Datenverknüpfungsfehler
       Fehler beim Testen der Verbindung durch einen Fehler beim Initialisieren des Providers. Schwerwiegender Fehler


Und das wars dann. ?!

Google spuckt mir nicht besonders viel über das Problem aus...:(

Wenn XAMPP auf Windows installiert ist, und auf dem gleichen Rechner diese OCS Software läuft, geht es 1A.

Ich glaube zwar nicht, dass das nun unbedingt an XAMPP liegt, aber ich wusste nicht so Recht wohin mit diesem Problem.

Für Hilfe wäre ich echt dankbar. :wink:
trance::m
 
Posts: 1
Joined: 20. November 2004 13:09

Return to XAMPP für Linux

Who is online

Users browsing this forum: No registered users and 2 guests