Wie kann ich in MySQL für "root" ein Passwort verg

Irgendwelche Probleme mit XAMPP für Linux? Dann ist hier genau der richtige Ort um nachzufragen.

Wie kann ich in MySQL für "root" ein Passwort verg

Postby visionmaster » 18. November 2004 14:50

Hallo zusammen,

Ich habe gerade Probleme auf Kommondozeile mysql als root zu starten:

testserver:~ # /opt/lampp/bin/mysql -u root -p
Enter password:
ERROR 1045: Access denied for user: 'root@localhost' (Using password: YES)
testserver:~ #

Als user 'pma' mit dazugehörigem Kennwort:

testserver:~ # /opt/lampp/bin/mysql -u pma -p
Enter password:
Welcome to the MySQL monitor. Commands end with ; or \g.
Your MySQL connection id is 307 to server version: 4.0.21-log

Type 'help;' or '\h' for help. Type '\c' to clear the buffer.

mysql>


=> Ich bin davon ausgegangen das des kennwort vom root und vom user pma gleich sind, dem ist eben nicht so...

phpMyAdmin zeigt folgendes:
----------------------------------
Willkommen bei phpMyAdmin 2.6.0-pl1
Verbunden mit MySQL 4.0.21-log auf localhost als pma@localhost

=> Und als user pma kann ich keinen neue Datenbank anlegen.

=> Also gibt es irgendwie eine Möglichkeit das root Kennwort neu zu setzen? Ich hoffe es! :-(

Besten Dank!
visionmaster
 
Posts: 36
Joined: 24. June 2004 14:39

Re: Wie kann ich in MySQL für "root" ein Passwort

Postby visionmaster » 19. November 2004 11:28

Um daw root Passwort neu zu setzen muss ich den MySQL-Dämon stoppen und mit der zusätzlichen Option --skip-grant-tables starten.

Siehe auch http://dev.mysql.com/doc/mysql/en/Reset ... sions.html

Ich habe folgendes gemacht:

testserver:~ # /opt/lampp/bin/mysql.server start --skip-grant-tables
testserver:~ # Starting mysqld daemon with databases from /opt/lampp/var/mysql

und dann:

testserver:~ # /opt/lampp/bin/mysqladmin -u root flush-privileges password "test"
/opt/lampp/bin/mysqladmin: connect to server at 'localhost' failed
error: 'Access denied for user: 'root@localhost' (Using password: NO)'
testserver:~ #

==> Anscheinend läuft aber der MySQL-Dämon nicht mit der zusätzlichen Option --skip-grant-tables


===> Was mache ich falsch?

Besten Dank!
visionmaster
 
Posts: 36
Joined: 24. June 2004 14:39


Return to XAMPP für Linux

Who is online

Users browsing this forum: No registered users and 1 guest