Bei SSL geht http nicht mehr

Irgendwelche Probleme mit XAMPP für Linux? Dann ist hier genau der richtige Ort um nachzufragen.

Bei SSL geht http nicht mehr

Postby Deejoy » 15. November 2004 14:07

Hi,
ich wollte mal SSL ausprobieren. Habe mir ein Cert erstellt und alles wie hier im Forum beschrieben ind die ssl.conf eingetragen.
hat auch soweit funktioniert nur erhalte ich dann keinen Zugriff mehr auf die Seite über http. https funktioniert. Kommentiere ist den eintrag aus der ssl.conf wieder aus geht auch http wieder.

Die httpd.conf

Code: Select all
<VirtualHost 192.168.0.1>
ServerName domain.tld
ServerAlias *.domain.tld www.domain.tld
ServerAdmin ich@domain.tld
DocumentRoot /opt/lampp/htdocs/domain/html
ScriptAlias /cgi-bin/ /opt/lampp/htdocs/domain/html/cgi-bin/

<Directory opt/lampp/htdocs/domain/html/cgi-bin/>

Options ExecCGI

</Directory>
ErrorLog /opt/lampp/htdocs/domain/log/error.log
CustomLog /opt/lampp/htdocs/domain/log/access_log common
<Directory opt/lampp/htdocs/domain/html>
Options -Indexes FollowSymLinks MultiViews Includes
</Directory>
</VirtualHost>


meine ssl.conf

Code: Select all
<VirtualHost 192.168.0.1:443>
SSLEngine on
ServerName ssl.domain.tld
ServerAdmin ich@domain.tld
DocumentRoot /opt/lampp/htdocs/domain/html/
SSLCertificateFile /opt/lampp/htdocs/domain/ssl_cert/domain.crt
SSLCertificateKeyFile /opt/lampp/htdocs/domain/ssl_key/domain.key
</VirtualHost>


Ich war der Meinung darüber hier mal was im Forum gesehen zu haben habs aber leider nicht mehr gefunden
Deejoy
 
Posts: 26
Joined: 15. July 2004 21:29

Postby Deejoy » 19. November 2004 23:17

Hat den keinen einen kleinen Tip ?
Hab jetzt schon alles mögliche Probiert aber egal wie es geht entwerder nut https oder http


<Edit>
Ok ich habe den fehler gefunde. Es befand sich noch ein eintrag in der htpd.conf wo kein Port hinterlegt war. ein :80 und seit dem geht beides nur noch nicht so ganz wie es soll.

ich habe in der ssl.conf folgendes eingetragen

Code: Select all
<VirtualHost 192.168.0.1:443>
DocumentRoot /opt/lampp/htdocs/domain1/html/
ServerName ssl.domain1.de
ServerAdmin mail@domain1.de
SSLEngine on
SSLCertificateFile /opt/lampp/htdocs/domain1/ssl_cert/domain1.crt
SSLCertificateKeyFile /opt/lampp/htdocs/domain1/ssl_key/domain1.key
</VirtualHost>


So damit möchte ich halt das SSL über die domain https://ssl.domain1.de erreichbar ist worauf dann später auch das Cert laufen soll.
Aber gebe ich das im browser ein bekomme ich nichts angezeigt.
Gebe ich aber https://www.domain1.de ein geht es oder https://ssl.domain2.de geht auch, alle ssl anfragen werden dann immer in das Documentroot geleitet was ich in der ssl.conf angegeben habe.
Muß ich bei Servername nur domain1.de eintragen oder wie ist es richtig? Soll ja später auch mit dem cert dann laufen und das möchte ich gerne auf ssl.domain1.de registrieren.
Deejoy
 
Posts: 26
Joined: 15. July 2004 21:29


Return to XAMPP für Linux

Who is online

Users browsing this forum: No registered users and 1 guest