Wird zuviel ge-cached! Cookie Problem....

Irgendwelche Probleme mit XAMPP für Linux? Dann ist hier genau der richtige Ort um nachzufragen.

Wird zuviel ge-cached! Cookie Problem....

Postby saibot » 24. October 2004 21:09

Dachte es gäbe bei Php 5.0.2 noch ein Cookie Problem....denke aber eher das liegt an eurem Cache....z.B. sehe ich bei einer bestimmten Seite bei mir immer die Seite, die ausgeloggte User sehen, da die ge-cached wird, auch wenn der User eingeloggt ist. Der Cookie ist noch da und auf anderen Seiten wird auch wieder richtig gelesen.....echt strange.

Ausserdem wird eine Seite nach Skript Änderung weiter gecacht...trotz Client reloads.....gehe ich auf eine andere Seite und wieder zurück, wird aber die neue version angezeigt..
saibot
 
Posts: 33
Joined: 24. October 2004 21:03

Postby Oswald » 24. October 2004 21:27

Hallo saibot!

Du sprichst in Rätzeln. Sorry, aber ich versteh überhaupt nicht, wovon Du sprichst!

Welche Cookies? Welcher Cache? Welche User? Welche Seite?

Liebe Grüße
Oswald
User avatar
Oswald
Apache Friends
 
Posts: 2718
Joined: 26. December 2002 19:51
Location: Berlin, Germany
Operating System: Linux

caching und so...

Postby saibot » 25. October 2004 07:46

Ich verstehe es auch nicht so ganz....ist aber eine sehr komisches Problem, dass sowohl bei PHP4 als auch PHP5 mit XAMPP auftritt.


Bei einer eigenen Seite passiert folgendes: Man kann sich ganz normal einloggen und verschiedene User-only Links besuchen. Geht man auf eine bestimmte andere Seite, wird eine Seite angezeigt, die so aussieht als wäre man nciht eingeloggt....trotz reloads.

Geht man dann wieder auf die anderen User-only Links, ist man aber immer noch eingeloggt (trotz reloads).

Also habe ich als Work-around einen Zufallswert als Parameter mitübergeben.
Dann wird die "Du bist eingeloggt" Seite angezeigt.

Also startseite.php?zufallswert=hallo -> du bist eingeloggt
startseite.php -> du bist ausgeloggt

andereSeiten.php-> du bist eingeloggt.
saibot
 
Posts: 33
Joined: 24. October 2004 21:03

Postby Oswald » 25. October 2004 07:51

Hallo Saibot!

Sieht nach einem Browserproblem aus. Wie hast Du da die Cache-Funktionalität eingestellt? Stell das bitte mal auf "nie cachen" oder so ähnlich.

Liebe Grüße
Oswald
User avatar
Oswald
Apache Friends
 
Posts: 2718
Joined: 26. December 2002 19:51
Location: Berlin, Germany
Operating System: Linux

Leider nicht so einfach....

Postby saibot » 25. October 2004 10:01

Es ist leider kein simples Browser Problem...denn bei der nicht-XAMPP PHP Installation auf einem anderen Server mit genau dem gleichen PHP Source Code der 1:1 umkopiert wurde funktioniert alles, aber auf dem "XAMPP Server" gibt es diese nicht-deterministischeb Cache/Cookie Probleme.


Wie gesagt, selbst mit lampp php4 ist das der geiche Effekt..also liegt es nicht an PHP5 sondern an irgendwelchen zusätzlichen Modulen..in der Standard/aktuellen XAMPP Version ist allerdings Cacheing auskommentiert, daher muss es irgendetwas anderes sein?
saibot
 
Posts: 33
Joined: 24. October 2004 21:03


Return to XAMPP für Linux

Who is online

Users browsing this forum: No registered users and 2 guests