Lampp mit SSL

Irgendwelche Probleme mit XAMPP für Linux? Dann ist hier genau der richtige Ort um nachzufragen.

Postby Herbert » 30. November 2003 12:36

Its easy...
# put in your http.conf

include /opt/lampp/etc/Vhosts.conf

# put this in your Vhosts.conf

NameVirtualHost *:80

<VirtualHost *:80>

ServerName www.yourdomain.com
ServerAlias yourdomain.com
DocumentRoot /home
Options ExecCGI FollowSymLinks Includes IncludesNOEXEC Indexes MultiViews SymLinksIfOwnerMatch
</VirtualHost>

<VirtualHost *:80>
ServerName otherdomain.de
ServerAlias *.otherdomain.de
ServerSignature Email
ServerAdmin info@otherdomain.de
DocumentRoot /home/www/www.otherdomain.de
<Directory /home/www/www.otherdomain.de>
Options ExecCGI FollowSymLinks Includes IncludesNOEXEC Indexes MultiViews SymLinksIfOwnerMatch
</Directory>
</VirtualHost>
-
Its works.. try mainserver:
https://adslnetwerk.com or http://adslnetwerk.com
http://www.webz.be is hosted on the same server.
Herbert
 
Posts: 19
Joined: 16. July 2003 18:04

server.crt/key anpassen?

Postby pcSnoopy » 05. December 2003 09:42

Kai Seidler wrote:Hallo AnRo,

eigentlich brauchst Du nichts mehr im LAMPP einstellen. SSL ist schon aktiviert und konfiguriert. D. h. nach dem Start von LAMPP sollte gleich auch https funktionieren.

Du musst dann letztendlich natürlich noch die server.crt und server.key durch Deine eingenen Verianten ersetzten. Aber an der Apache-Konfiguration musst Du nichts mehr änderen.

Liebe Grüße,
Oswald ;)


bitte um kurze hilfe, wie ich eine eigen variante der zertifikate erstellen kann

danke
so long

pcSnoopy
User avatar
pcSnoopy
 
Posts: 3
Joined: 27. November 2003 12:12

Postby Kristian Marcroft » 05. December 2003 13:03

Hi

ich hab mirn Kleines Script geschrieben:
Code: Select all
# Created by KriS
# Last Change 29.06.03 2:30 AM
#!/bin/sh
/opt/lampp/bin/openssl genrsa 1024 > /opt/lampp/etc/ssl.key/server.key
echo "Common Name = URL"
/opt/lampp/bin/openssl req -new -x509 -key /opt/lampp/etc/ssl.key/server.key -out /opt/lampp/etc/ssl.crt/server.crt
echo "That was it :)"


Zeile 7 gehört noch hinter Zeile 6, sollte also alles in einer Zeile stehen.
Common Name sollte halt deine URL sein.
Versuchs zumindest mal...
Bei mir funzt es...

So long
KriS
User avatar
Kristian Marcroft
AF Moderator
 
Posts: 2962
Joined: 03. January 2003 12:08
Location: Diedorf

Postby Shoukri » 15. December 2003 06:47

jetzt habe ich dazu auch mal ne frage ...

ich habe auf dem aktuellem xampp paket für linux meinen ssl host laut anleitung hier eingerichtet, die pfade und servernamen in der ./etc/ssl.conf geändert udn gestartet, fährt auch ohne weitere fehlemrledung hoch ...

der http port ist erreichbar, der ssl port jedoch nicht ... laut w3m check wird angezeigt:

https://localhost - erreichbar
https://externeadresse - nicht erreichbar ... w3m: Can't load https://blah

der opera zeigt transmission failure an , im log steht
invalid method in request

:-(
wie kann ich das funktionsfähig hinkriegen? :-(
User avatar
Shoukri
 
Posts: 76
Joined: 29. October 2003 00:25

Postby dyingPhoenix » 28. February 2006 13:14

Ich hatte das Problem auch. Nachdem ich dann meinen "normalen" vhosts gesagt habe, dass sie zu Port 80 gehören, funktionierte dann auch ssl:

Code: Select all
NameVirtualHost 10.84.80.99:80
NameVirtualHost 10.84.80.89:80

<VirtualHost 10.84.80.89:80>
    ServerName einname
     Documentroot /opt/lampp/htdocs
    ....
</VirtualHost>
...
<VirtualHost 10.84.80.99:80>
        ServerName einanderer
        ...
</VirtualHost>
...
dyingPhoenix
 
Posts: 19
Joined: 21. December 2004 14:43

Previous

Return to XAMPP für Linux

Who is online

Users browsing this forum: No registered users and 5 guests