OCI8 unter XAMPP

Irgendwelche Probleme mit XAMPP für Linux? Dann ist hier genau der richtige Ort um nachzufragen.

OCI8 unter XAMPP

Postby matrix83 » 28. September 2004 09:21

Hallo zusammen,

ich habe XAMPP 1.4.8 unter SuSe Linux 7 Enterprise Server laufen.
Nun habe ich das "lampp oci" die OCI-Erweiterung installiert. Funktioniert auch wunderbar. Leider ist dies immer nach nem Neustart wieder weg. Was kann man denn dagegen tun. Will die Erweiterung standardmäßig immer mit dabei haben.

Gruss
Matrix
matrix83
 
Posts: 9
Joined: 28. September 2004 09:10

Postby Oswald » 28. September 2004 13:47

Hallo Martix!

Eigentlich ist die Einstellung permanent (es werden Dateien verändert) und muss auch nach dem Neustart noch da sein. Bist Du Dir wirklich sicher? Ich kann es mir überhaupt nicht erklären.

Liebe Grüße
Oswald
User avatar
Oswald
Apache Friends
 
Posts: 2718
Joined: 26. December 2002 19:51
Location: Berlin, Germany
Operating System: Linux

Postby matrix83 » 28. September 2004 13:51

Ja bin mir ganz sicher. Is echt zum kotzen irgendwie.
Achso, ich hab die Skriptdatei abgeändert, weil wir oracle 8 bei uns im Einsatz haben. Hab also in der Datei oci8install die 9er durch 8er ersetzt. Kann es daran liegen?
matrix83
 
Posts: 9
Joined: 28. September 2004 09:10

Postby Oswald » 28. September 2004 14:02

Huhu Matrix!

Nein, daran kann es nicht liegen. Die Änderungen, die Du gemacht hast, sind auch prima so.

Guck bitte mal in die Datei /opt/lampp/etc/php.ini. Dort solltest Du folgende Stelle finden:

;mmcache.shm_max="0"
;mmcache.shm_ttl="0"
;mmcache.shm_prune_period="0"
;mmcache.shm_only="0"
;mmcache.compress="1"

extension=oci8.so

;;;;;;;;;;;;;;;;;;;
; Module Settings ;
;;;;;;;;;;;;;;;;;;;

[Syslog]


Wenn das (extension=oci8.so) in der Datei steht, dann ist die OCI8-Erweiterung aktiviert. Und diese Datei sollte sich durch einen Neustart nicht ändern.

Steht in der /opt/lampp/logs/error_log irgendwas Auffälliges?

Liebe Grüße
Oswald
User avatar
Oswald
Apache Friends
 
Posts: 2718
Joined: 26. December 2002 19:51
Location: Berlin, Germany
Operating System: Linux

Postby matrix83 » 28. September 2004 14:14

Also in der PHP.ini steht des au so drin. Is auch komisch. Wenn ich den XAMPP einfach nur beende und sofort wieder starte dann is die Erweiterung da. Nur wenn er automatisch beim booten gestartet wird gehts nicht. Is doch komisch, oder?
matrix83
 
Posts: 9
Joined: 28. September 2004 09:10


Return to XAMPP für Linux

Who is online

Users browsing this forum: No registered users and 3 guests