xampp unter Linux - shopware startet nicht

Irgendwelche Probleme mit XAMPP für Linux? Dann ist hier genau der richtige Ort um nachzufragen.

xampp unter Linux - shopware startet nicht

Postby Kerstin83 » 10. March 2017 07:57

Liebes Forum :) :)

ich brauche dringend eure Hilfe, weil ich einfach nicht weiterkomme.

Bisher habe ich immer mit Xampp unter Windows gearbeitet und darunter u. a. Shopware laufen gelassen. Jetzt möchte ich Shopware auf xampp unter ubuntu (in VirtualBox auf Windows 7) laufen lassen.

Dazu habe ich die Shopware Installationsdateien in den Ordner sw529 gelegt und diesen mit localhost/sw529 aufgerufen. Es wird aber nur die Liste mit den Dateien in diesem Ordner angezeigt und nicht die Installation gestartet.

Mit einem Klick auf die shopware.php startet dann doch die Installation und wird bis zum Ende ausgeführt.

Aber nach der Installation funktioniert localhost/sw529 auch nicht, sondern es wird wieder die Dateiliste angezeigt.

Wieder durch einen Klick auf shopware.php startet die home-page und diese wird korrekt angezeigt. Weitere Links landen aber wieder auf der Dateiliste.

Mit xampp unter Windows hat das sofort geklappt.

Liebe Grüße

Kerstin
Kerstin83
 
Posts: 30
Joined: 29. August 2016 17:26
XAMPP version: xampp-portable-win32-1.8.3-1
Operating System: Windows 7 Professional

Re: xampp unter Linux - shopware startet nicht

Postby Altrea » 10. March 2017 08:00

Hallo Kerstin,

Ich kann nur mutmaßen, dass das index document von shopware nicht korrekt mitkopiert wurde.

Mit freundlichen Grüßen,
Altrea
We don't provide any support via personal channels like PM, email, Skype, TeamViewer!

It's like porn for programmers 8)
User avatar
Altrea
AF Moderator
 
Posts: 8969
Joined: 17. August 2009 13:05
XAMPP version: several
Operating System: Windows 10 Pro x64

Re: xampp unter Linux - shopware startet nicht

Postby Kerstin83 » 10. March 2017 08:06

ne, es ist alles kopiert worden, das habe ich überprüft. Daran kann es also nicht liegen.
Kerstin83
 
Posts: 30
Joined: 29. August 2016 17:26
XAMPP version: xampp-portable-win32-1.8.3-1
Operating System: Windows 7 Professional

Re: xampp unter Linux - shopware startet nicht

Postby Altrea » 10. March 2017 08:19

In der Standardkonfiguration würde der XAMPP Apache Indexdokumente ausliefern anstatt Index listing betreiben. Wie erklärst du dir das dann?
We don't provide any support via personal channels like PM, email, Skype, TeamViewer!

It's like porn for programmers 8)
User avatar
Altrea
AF Moderator
 
Posts: 8969
Joined: 17. August 2009 13:05
XAMPP version: several
Operating System: Windows 10 Pro x64

Re: xampp unter Linux - shopware startet nicht

Postby Nobbie » 10. March 2017 12:06

Wenn ich mich recht erinnere, habe ich Dir eine komplette VirtualBox Umgebung eingerichtet inkl. vorinstalliertem Ubuntu, Xampp und vorinstalliertem Shopware. Ich habe das Exportfile sogar noch hier letztens auf meinem NAS gesehen, notfalls finde ich hier auch noch den passenden Thread. Noch mehr können wir hier wirklich nicht mehr machen für Dich.

P.S.: Hier ist der Thread dazu viewtopic.php?f=4&t=74612&start=15 und das Image hast Du laut PNs im September 2016 heruntergeladen. Da ist alles fix und fertig eingerichtet, so wie es besprochen war.
Nobbie
 
Posts: 9816
Joined: 09. March 2008 13:04

Re: xampp unter Linux - shopware startet nicht

Postby Kerstin83 » 10. March 2017 16:06

Ich erinnere mich und habe es auch noch. Aber das läuft leider nicht. Und ich möchte es auch selbst aufsetzen können.

Also ich habe eine Ahnung, woran das liegen könnte. Shopware verwendet Mod Rewrite Modul. Das scheint bei Linux nicht richtig zu funktionieren.
Kerstin83
 
Posts: 30
Joined: 29. August 2016 17:26
XAMPP version: xampp-portable-win32-1.8.3-1
Operating System: Windows 7 Professional

Re: xampp unter Linux - shopware startet nicht

Postby Nobbie » 10. March 2017 16:50

Kerstin83 wrote:Ich erinnere mich und habe es auch noch. Aber das läuft leider nicht.


Das läuft mit absoluter Sicherheit.

Kerstin83 wrote:Das scheint bei Linux nicht richtig zu funktionieren.


Auch das ist ganz sicher nicht so. Soll ich es hier installieren und ein Video davon machen, wie es läuft?

P.S.: In den letzten 10 Minuten habe ich dann mal eben Shopware 5.2.20 heruntergeladen, in Xampp installiert, eingerichtet, fertig. Läuft. Unter Linux. Ich habe ein Video gedreht von Anfang bis Ende, es wird gerade gerendert, hoffentlich ist es was geworden, weiß ich leider noch nicht.
Nobbie
 
Posts: 9816
Joined: 09. March 2008 13:04

Re: xampp unter Linux - shopware startet nicht

Postby Kerstin83 » 10. March 2017 17:11

Natürlich denke ich auch, dass man es zum Laufen bringen kann. Aber es ist nicht so einfach wie unter Windows.

Und genau das ist ja auch meine Bitte, mir dabei zu helfen. Ich bin nun seit ziemlich langer Zeit daran und es funktioniert einfach nicht.

In den letzten 10 Minuten habe ich dann mal eben Shopware 5.2.20 heruntergeladen, in Xampp installiert, eingerichtet, fertig. Läuft.

Die Installation von shopware ist ja nicht das Problem (schaffe ich auch in 10 Minuten), habe ich schon mehrfach gemacht und auch schon unter ubuntu, wie ich ja auch geschrieben habe. Das Problem ist mehr das xampp bzw. der Server (wahrscheinlich das Mod Rewrite).
Kerstin83
 
Posts: 30
Joined: 29. August 2016 17:26
XAMPP version: xampp-portable-win32-1.8.3-1
Operating System: Windows 7 Professional

Re: xampp unter Linux - shopware startet nicht

Postby Nobbie » 10. March 2017 17:24

Keine Ahnung, bei mir hakt es nirgends. Es ist genauso einfach zu installieren wie unter WIndows (im Zweifel einfacher), aber es ist schon falsch, wenn Du unter http://localhost/sw529 oder so ein Inhaltsverzeichnis angezeigt bekommst, dann stimmt etwas nicht. Es fällt auf, dass Du eine sehr alte Version installierst, wieso nicht die aktuelle Version 5.2.20? Wo kommt die alte Version jetzt noch her?
Nobbie
 
Posts: 9816
Joined: 09. March 2008 13:04

Re: xampp unter Linux - shopware startet nicht

Postby Kerstin83 » 10. March 2017 17:54

5.2.9 ist meine aktuelle Live-Version. Sehr alt ist absolut übertrieben, sie ist vielleicht 3 Monate alt. Ich mache aber nicht ständig Updates, ist immer auch mit Gefahren verbunden. Und seit 5.2.9 ist nichts richtig Wesentliches passiert, ausser ein paar Sicherheitsupdates, die ich auf andere Weise gemacht habe.

aber es ist schon falsch, wenn Du unter http://localhost/sw529 oder so ein Inhaltsverzeichnis angezeigt bekommst, dann stimmt etwas nicht.

Du installierst es ja auch unter Mint und nicht unter Ubuntu. Vielleicht liegt es ja daran.

Ich denke wie gesagt, dass es irgendwie mit dem Mod Rewrite zu tun hat.

Hat da keiner eine Idee, was da sein könnte ?

Liebe Grüße
Kerstin83
 
Posts: 30
Joined: 29. August 2016 17:26
XAMPP version: xampp-portable-win32-1.8.3-1
Operating System: Windows 7 Professional

Re: xampp unter Linux - shopware startet nicht

Postby Nobbie » 10. March 2017 18:03

Kerstin83 wrote:5.2.9 ist meine aktuelle Live-Version. Sehr alt ist absolut übertrieben, sie ist vielleicht 3 Monate alt.


Vielleicht hast Du aber irgendetwas geändert in der Zwischenzeit und vergessen - und das führt jetzt ggf. dazu, dass es sich so komisch verhält.

Kerstin83 wrote:Du installierst es ja auch unter Mint und nicht unter Ubuntu. Vielleicht liegt es ja daran.


Ne, mit Sicherheit nicht, Mint basiert außerdem auf Ubuntu. Aber ich kann auch gerne Ubuntu noch installieren und da dann Xampp und Shopware, ich wette um eine beliebige Summe, dass das genauso läuft.

Kerstin83 wrote:Ich denke wie gesagt, dass es irgendwie mit dem Mod Rewrite zu tun hat.


Nicht am Rewrite an sich, aber vielleicht hast Du etwas geändert und nur vergessen (s.o.). Deine Beschreibung ist übrigens leider sehr unvollständig, Du nennst nicht einmal vollständige Pfadnamen.
Nobbie
 
Posts: 9816
Joined: 09. March 2008 13:04

Re: xampp unter Linux - shopware startet nicht

Postby Kerstin83 » 10. March 2017 19:16

aber vielleicht hast Du etwas geändert und nur vergessen

Ich habe nichts verändert, sondern es mit einer Neuinstallation aller Komponenten versucht:
Ubuntu neu installiert, dort Xampp neu installiert, Auch Shopware habe ich neu installiert.

Deine Beschreibung ist übrigens leider sehr unvollständig

Sorry, wollte nicht unvollständig sein. Was musst du denn noch wissen ?

Aber ich kann auch gerne Ubuntu noch installieren und da dann Xampp und Shopware, ich wette um eine beliebige Summe, dass das genauso läuft.

Ich denke auch, dass es irgendwie geht. Wenn man bei der Installation von xampp noch etwas beachtet oder etwas nachinstalliert, wird es bestimmt funktionieren. Vielleicht hast du ja auch bei Mint etwas nachinstalliert ?
Aber probier es mal. Ich habe es mehrfach gemacht und bin nicht weitergekommen. Wäre interessant, ob es bei dir klappt.

Ich habe die Mint-Installation von dir noch einmal rausgeholt - und siehe da, sie funktioniert jetzt. Ich habe auch eine neue VM, mit der sich das System scheinbar verträgt.
Aber ich möchte es gerne auch selbst hinbekommen.
Kerstin83
 
Posts: 30
Joined: 29. August 2016 17:26
XAMPP version: xampp-portable-win32-1.8.3-1
Operating System: Windows 7 Professional

Re: xampp unter Linux - shopware startet nicht

Postby Nobbie » 10. March 2017 19:46

Kerstin83 wrote:Sorry, wollte nicht unvollständig sein. Was musst du denn noch wissen ?


Die Angabe "Dazu habe ich die Shopware Installationsdateien in den Ordner sw529 gelegt" ist doch wirklich totaler Müll, so etwas kann man doch nicht wirklich ernst meinen? Was ist denn sw529?? Das ist für mich ein Wort mit 5 Zeichen - sonst nichts. Wo ist dieser Ordner?? Auf F:/Xampp/Hast DU nicht gesehen/was ich sonst alles nicht weiß/sw529 oder wie oder was? Ich muss zugeben, dass das nervig ist.

Kerstin83 wrote:Vielleicht hast du ja auch bei Mint etwas nachinstalliert ?


NEIN. Auch das nervt wirklich langsam, suche den Fehler nicht woanders, suche den Fehler BEI DIR. Du machst irgendetwas falsch, aber noch weiß ich nicht, was Du falsch machst. Ich weiß noch nicht einmal, wo die Installation ist (s.o.!!) und ich weiß auch nicht, welche Dateiberechtigungen es dort gibt (wenn man einfach so nur kopiert, dann kann man das nicht installieren, das muss mit root Rechten kopiert werden, aber das fehlt auch in Deiner Beschreibung, Du nennst das "in den Ordner gelegt" - meine Güte, damit fange ich nichts an).

Wir machen es jetzt anders, so hat das keinen Sinn. Du schickst mir eine ZIP-Datei, die die Installationsdateien enthält, die Du bei Dir "in den Ordner gelegt" hast. Und ich installiere GENAU DAS Paket bei mir. Und NEIN: ich habe nicht irgendetwas "nachinstalliert". Welches Xampp hast Du herunter geladen und installiert? Und ich warte auf diese ZIP Datei, alles andere führt zu nichts.

P.S.: Wir können das ganze abbrechen, ich habe den Fehler gefunden. Du hast beim Kopieren etwas falsch gemacht und hast die .htaccess Datei NICHT mitkopiert. Die fehlt bei Dir im Ordner sw529, das ist das Standardproblem, wenn man beispielsweise mit "cp * ..." oder ähnlich Dateien kopiert. Dann verhält sich die Installation genau so falsch wie bei Dir. Richtig geht es so: den ZIP Ordner in Deinem Homeverzeichnis irgendwo entpacken und dann DEN GANZEN ORDNER nach /opt/lampp/htdocs verschieben (mit "mv ordnername /opt/lampp/htdocs") und danach den Ordner nach Wunsch ggf. umbenennen. Du hast wahrscheinlich den ZIelordner händisch angelegt (was falsch ist) und dann händisch mit "cp" oder so die Dateien kopiert (was auch falsch ist). Möglicherweise hast Du das ganze auch im Nautilus kopiert und dort mit markierten Dateien gearbeitet, aber auch dort hast Du die falschen Einstellungen gewählt, so dass sog. "hidden files" (mit . am Anfang) nicht angezeigt werden und dann werden sie auch nicht kopiert). Auch im Nautilus musst DU einfach den ganzen Ordner verschieben, nicht die einzelnen Dateien.
Nobbie
 
Posts: 9816
Joined: 09. March 2008 13:04

Re: xampp unter Linux - shopware startet nicht

Postby Kerstin83 » 11. March 2017 14:44

ah, danke, jetzt kommen wir der Sache näher *freu

Es stimmt, die .htaccess fehlt. Ich habe es aber so gemacht, wie ich es auch auf dem "richtigen" Linux-Server mache. Die zip-Datei in das Verzeichnis in den Ordner
/opt/lampp/htdocs/sw529
gelegt und dort entpackt. Die versteckten Dateien werden dabei scheinbar nicht mit entpackt.

Wie gesagt auf dem Webserver mache ich das auch so.
Ich habe den Entpacker von Nautilus verwendet. Entpackt der keine versteckten Dateien ?
Muss ich dem einen Parameter mitgeben ?

Viele Grüße

Kerstin

PS. übrigens suche ich den Fehler definitiv nicht bei anderen. Mir ist absolut klar, dass das eigentlich gehen muss und ich etwas falsch mache. Aber um Fehler zu finden muss man ja wissen, was die anderen anders machen.
Kerstin83
 
Posts: 30
Joined: 29. August 2016 17:26
XAMPP version: xampp-portable-win32-1.8.3-1
Operating System: Windows 7 Professional

Re: xampp unter Linux - shopware startet nicht

Postby Kerstin83 » 11. March 2017 15:19

irgendwie scheine ich es geschafft zu haben, eine Installations-zip-datei ohne .htaccess zu bekommen. Ich habe keine Ahnung, wie das passiert sein kann.

Jetzt werde ich es noch mal testen.
Kerstin83
 
Posts: 30
Joined: 29. August 2016 17:26
XAMPP version: xampp-portable-win32-1.8.3-1
Operating System: Windows 7 Professional

Next

Return to XAMPP für Linux

Who is online

Users browsing this forum: No registered users and 6 guests