Problem mit virtuellen hosts

Irgendwelche Probleme mit XAMPP für Linux? Dann ist hier genau der richtige Ort um nachzufragen.

Problem mit virtuellen hosts

Postby Benni-chan » 03. September 2004 14:16

hi

hab zwei probleme mit meinen virtuellen hosts

1. ich möchte für jeden virtuellen host einige php_admin_values setzen.
das klappt soweit auch, der apache startet ohne probleme und läuft. nur wenn ich ihn dann beenden will, kommt eine fehlermeldung und er läuft weiter:
Syntax error on line 24 of /opt/lampp/etc/meinevhosts.conf:
Invalid command 'php_admin_value', perhaps mis-spelled or defined by a module not included in the server configuration

2. als ich zuvor apache alleine verwendet hab (also nicht aus dem lampp packet), konnte ich bei den virtuellen hosts user und group angeben, unter welchen scripte ausgeführt werden.
mit lampp geht das nicht.
gibt es eine möglichkeit, dass ich das wieder aktivieren kann?

danke schonmal
Benni-chan
 
Posts: 1
Joined: 03. September 2004 14:06

Postby edm » 17. September 2004 10:04

Zu 1:
Habe genau das gleiche Problem und kann es z.Z. auch nicht lösen. Habe aber unter http://de3.php.net/manual/de/configuration.changes.php (ganz unten auf der Seite) folgendes gefunden, vielleicht hilft's (werde es am Wochenende ausprobieren):

If PHP is working for you but an 'apachectl configtest' gives you errors such as:
Invalid command 'php_admin_flag', perhaps mis-spelled or defined by a module not included in the server configuration

This may be due to that way the PHP module is loaded in your httpd.conf config file. I noticed this problem on an Apache 1.3.x server which was running mod_ssl - the LoadModule and AddModule directives for PHP had been inserted inside an <IfDefine SSL> block, so PHP worked when the server was started in ssl mode (which was always), but the configtest failed because the SSL flag wasn't set.

The fix for this is to make sure that the LoadModule and AddModule lines for PHP are outside that block - I just moved mine in front of it and now everything is fine.


Zu 2:
Im eBook "Apache Webserver 2.0" von Sebastian Wolfgarten, erschienen bei Addison-Wesley, Seite 198 steht:
Hinweis: Im Vergleich zum Apache 1.3.x ist es im Apache 2.x nicht mehr möglich, die User- oder Group-Anweisung innerhalb eines <VirtualHost>-Containers zu benutzen. Sie müssen daher auf die Verwendung von suEXEC respektive die SuEXECUserGroup-Anweisung oder ein geeignetes Laufzeitmodell (z.B. PerChild) ausweichen.


Wenn's hilft, bitte Bescheid geben!
edm
 
Posts: 7
Joined: 17. September 2004 09:09
Location: Bielefeld

Problem teilweise gelöst

Postby edm » 27. September 2004 18:49

Habe das Problem nun teilweise gelöst, indem ich auf die letzte funktionierende Version (ohne PHP4/PHP5-Wechselmechanismus) umgestiegen bin. Will heißen:
XAMPP 1.4.6 geht bei mir,
XAMPP 1.4.7+ geht nur mit obiger Fehlermeldung.

Sehr seltsam, aber mir egal. Hauptsache es funktioniert. Ich vermute, das die PHP4/PHP5-Module anders geladen werden (falsche Reihenfolge/anderer Kontext) als in der 1.4.6. Das kann ich wegen Zeitmangel aber erst später prüfen.
edm
 
Posts: 7
Joined: 17. September 2004 09:09
Location: Bielefeld

Postby Emu » 01. October 2004 23:38

Mit folgender Änderung im 'xampp' script sollte das stoppen auch wieder tun, wenn man php-direktiven in den virt. Hosts verwendet.

Code: Select all
  "stopapache")
    if test -f /opt/lampp/logs/httpd.pid
    then
      if test -f $lc/startssl
      then
        $de && echo "XAMPP: Stoppe Apache mit SSL..."
        $de || echo "XAMPP: Stopping Apache with SSL..."
      else
        $de && echo "XAMPP: Stoppe Apache..."
        $de || echo "XAMPP: Stopping Apache..."
      fi

        case `$0 phpstatus` in
          5*) xampp_apachedefine="$xampp_apachedefine -D PHP5"
              $de && phpextra="(und PHP5)"
              $de || phpextra="(and PHP5)"
              ;;
          4*) xampp_apachedefine="$xampp_apachedefine -D PHP4"
              $de && phpextra="(und PHP4)"
              $de || phpextra="(and PHP4)"
              ;;
        esac

      echo /opt/lampp/bin/apachectl stop $xampp_apachedefine
      /opt/lampp/bin/apachectl $xampp_apachedefine -k stop > /dev/null
      sleep 2
      #test -f /opt/lampp/logs/httpd.pid && rm /opt/lampp/logs/httpd.pid
    else
      $de && echo "XAMPP: XAMPP-Apache läuft gar nicht."
      $de || echo "XAMPP: XAMPP-Apache is not running."
    fi
    ;;


--
| Emu <ep@IM-NETZ.de>
User avatar
Emu
 
Posts: 6
Joined: 01. October 2004 23:29


Return to XAMPP für Linux

Who is online

Users browsing this forum: No registered users and 5 guests