Apache läuft nicht? PHP läuft nicht?

Irgendwelche Probleme mit XAMPP für Linux? Dann ist hier genau der richtige Ort um nachzufragen.

Apache läuft nicht? PHP läuft nicht?

Postby PeterW » 22. November 2015 02:15

A) Mein System:

Ich benutze LinuxMint 17.1 Cinnamon 64bit und XAMPP 5.6.14-3 in der 32bit Version.
Der Prozessor ist ein AMD Athlon II X2 250 Processor x2. Ich habe 3,6 GiB Speicher.
Die Installation der 64bit Version von XAMPP war schon vor einiger Zeit gescheitert, also habe ich die 32bit Version versucht.


B) Mein Problem

1.) Wenn ich mit XAMPP-Control (manager-linux.run in /opt/lampp) Apache starte, geht der in den Status "Starting" und dann wieder aus. Wenn ich aber im Browser localhost aufrufe, kommt die von mir hinterlegte Datei; also läuft Apache doch, oder? Wie kann ich es bewerkstelligen, dass Apache im Manager ordentlich startet?

2.) Außerdem funktioniert PHP irgendwie nicht. Selbst das einfachste PHP-Skript scheint nicht zu laufen, während die Ausgabe von einfachem Text und HTML-Tags klappt. Da dachte ich, man könnte und müßte irgendwo PHP aktivieren.

Der HTML-Text lautet:

--------------------------
<html><body>
ABC<br>
<?php
echo "Hello";
?>
</body></html>
--------------------------

Wichtige Ergänzung: Meine Datei heißt index.php
PeterW
 
Posts: 7
Joined: 22. November 2015 00:23
Operating System: LinuxMint

Re: Apache läuft nicht? PHP läuft nicht?

Postby Nobbie » 22. November 2015 11:25

PeterW wrote:Die Installation der 64bit Version von XAMPP war schon vor einiger Zeit gescheitert, also habe ich die 32bit Version versucht.


Ich habe fast dieselbe Umgebung hier (Linux Mint 17.1 64bit, 4GB RAM) und habe problemlos die 64bit Xampp Version installiert. Was genau läuft falsch und wie lauten die entsprechenden Meldungen?

PeterW wrote:Wenn ich aber im Browser localhost aufrufe, kommt die von mir hinterlegte Datei;


Welche von Dir hinterlegte Datei?? Da sollte eigentlich zunächst das Xampp Dashboard erscheinen? Welche Datei hast Du wo hinterlegt?

PeterW wrote:2.) Außerdem funktioniert PHP irgendwie nicht. Selbst das einfachste PHP-Skript scheint nicht zu laufen, während die Ausgabe von einfachem Text und HTML-Tags klappt. Da dachte ich, man könnte und müßte irgendwo PHP aktivieren.


Das klingt danach, als wenn Du index.php falsch öffnest. In welchem Ordner liegt die Datei, was gibst Du im Browser ein (oder welche Aktion unternimmst Du), um die index.php anzeigen zu lassen?

P.S.: Was den "manager" betrifft, ich benutze den nicht, stattdessen starte ich Xampp im Terminal in der gewohnten Manier (sudo /opt/lampp/lampp start). Möglicherweise ist Apache schon am Laufen gewesen, bevor Du den manager gestartet hast?! Ich finde aber sowieso die o.g. Lösung besser, mit deren Hilfe kann man den Start auch automatisieren und in den Bootvorgang legen (und den Stop in den Shutdown). Das ist eigentlich mehr "linux-like".
Nobbie
 
Posts: 8777
Joined: 09. March 2008 13:04

Re: Apache läuft nicht? PHP läuft nicht?

Postby PeterW » 22. November 2015 14:10

Also, es kam nach der Installation der 32bit Variante zunächst eine Seite, die Du wohl "Dashboard" nennst: Eine Meldung, dass es funktioniert und ein Hinweis auf Konfigurationsdateien. Dann habe ich in /var/www/html index.html gelöscht und index.php erstellt. Jetzt kommt diese Seite (index.php), wenn ich im Browser localhost eingebe.

OK, ich werde den Manager nicht mehr benutzen, stattdessen die Shell-Programme.
PeterW
 
Posts: 7
Joined: 22. November 2015 00:23
Operating System: LinuxMint

Re: Apache läuft nicht? PHP läuft nicht?

Postby Nobbie » 22. November 2015 16:57

PeterW wrote:Also, es kam nach der Installation der 32bit Variante zunächst eine Seite, die Du wohl "Dashboard" nennst: Eine Meldung, dass es funktioniert und ein Hinweis auf Konfigurationsdateien. Dann habe ich in /var/www/html index.html gelöscht und index.php erstellt. Jetzt kommt diese Seite (index.php), wenn ich im Browser localhost eingebe.


Das klingt ziemlich chaotisch, denn /var/www/html ist NICHT(!) Teil von Xampp, sondern gehört zur Apache Installation von Linux Mint, falls man dort Apache installiert. Xampp befindet sich ausschließlich in /opt/lampp und die HTML und PHP Dateien in /opt/lampp/htdocs. Da nur ein Apache zu einem Zeitpunkt auf einem Port 80 lauschen kann, startest Du anscheinend mal diesen, mal jenen Apache. Chaotisch eben. Ich weiß nicht, was Du da machst, aber es ist durchwachsen. Du solltest erst einmal Ordnung hineinbringen und Dich für EINE Apache Installation entscheiden.
Nobbie
 
Posts: 8777
Joined: 09. March 2008 13:04

Re: Apache läuft nicht? PHP läuft nicht?

Postby PeterW » 22. November 2015 17:22

OK, vielen Dank! Mach ich.
PeterW
 
Posts: 7
Joined: 22. November 2015 00:23
Operating System: LinuxMint


Return to XAMPP für Linux

Who is online

Users browsing this forum: No registered users and 2 guests