XAMPP Update mit der aktuellsten PHP 5 Version?

Irgendwelche Probleme mit XAMPP für Linux? Dann ist hier genau der richtige Ort um nachzufragen.

XAMPP Update mit der aktuellsten PHP 5 Version?

Postby sh » 27. August 2004 21:28

Hi ihr Apachefriends,

wollte fragen wann denn ein neues Update herauskommt, da ab PHP 5.0.1 ja wieder der GIF Support dabei ist. Finde das ist ein sehr nützliches und brauchbares Feature was man nicht ausser Acht lassen sollte. :D

Mit freundlichen Grüßen,

Stefan Heckler
sh
 
Posts: 1
Joined: 27. August 2004 21:15
Location: Darmstadt

Postby Oswald » 31. August 2004 13:10

Hallo Stefan!

Das dauert noch ein Weilchen. Nur wegen einer neuen Version (von Apache, PHP, MySQL, etc.) mach ich in der Regel keine neue XAMPP-Version. Das macht mich und auch alle Benutzer von XAMPP nur irre. Ausnahmen sind Sicherheitsprobleme. Dann gibt es in der Regel sofort eine neue XAMPP-Version.

Also, um Deine Frage zu beantworten: Sobald zum Beispiel auch eine neue Version von MySQL herauskommt, dann wird's auch ein neues XAMPP für Linux geben.

Liebe Grüße
Oswald
User avatar
Oswald
Apache Friends
 
Posts: 2718
Joined: 26. December 2002 19:51
Location: Berlin, Germany
Operating System: Linux

Postby cguenther » 05. September 2004 18:11

Ein Update auf die neue Version von PHP wäre sinnvoll, da

1. GIF-Support dabei wäre
2. Ein Bug im XAMPP (Linux) 1.4.7 behoben werden könnte.

Der Bug äußert sich darin, dass kein Sablotron bzw. XSLT-Prozessor mit an Bord ist. Im Configure Command steht zwar:

Code: Select all
'--enable-xslt' '--with-xslt-sablot=/opt/lampp'


Allerdings scheint beim compilen da was schief gegangen zu sein. Denn in der Liste mit den vorhanden modulen _fehlt_ nach dem Eintrag xml der Eintrag xsl.

Normaler Weise sollte da stehen:

Code: Select all
xsl
XSL  enabled 
libxslt Version  1.0.33 
libxslt compiled against libxml Version  2.5.11 


In sofern gehen auch Funktionsaufruf xslt_create() ins Leere.
cguenther
 
Posts: 1
Joined: 05. September 2004 18:01

fehler inzwischen behoben ?!

Postby griesbaum » 23. September 2004 16:32

hallo,

der fehler mit dem sablotron ist in der version 1.4.8 für linux wohl immernoch vorhanden. jedenfalls fehlt beim konfigurieren von php anscheinend der teil zum einbinden des sablotron parsers
Code: Select all
--with-xslt-sablot=shared,/opt/lampp


denn im dateisystem ist er ja vorhanden.

wann gibt es eine version in der sablotron korrekt funktioniert?
oder kann ich php selbst mit dieser zusatzoption kompilieren?


mfg,
michael
griesbaum
 
Posts: 2
Joined: 23. September 2004 16:22

Postby Kristian Marcroft » 23. September 2004 16:38

Hi,

ich finde deinen Ton hier ziemlich _fordernd_!
XAMPP entsteht in unsere _Freizeit_ beachte das Wort _Frei_!

Natürlich kannst du PHP selbst kompilieren....
Viel Spass dabei.. ;)

So long
KriS
User avatar
Kristian Marcroft
AF Moderator
 
Posts: 2962
Joined: 03. January 2003 12:08
Location: Diedorf

tolle antwort !

Postby griesbaum » 23. September 2004 16:57

da hast du ja ne richtig produktive antwort von dir gegeben :D
hätte ich zuerst schreiben sollen, wie toll ich eure leistung finde ?!

naja, nichts für ungut.
kriege das schon selbst hin.
griesbaum
 
Posts: 2
Joined: 23. September 2004 16:22


Return to XAMPP für Linux

Who is online

Users browsing this forum: No registered users and 5 guests