Lampp und Yoper

Irgendwelche Probleme mit XAMPP für Linux? Dann ist hier genau der richtige Ort um nachzufragen.

Lampp und Yoper

Postby matosale » 24. August 2004 18:22

Hola alle!

Ich bekomme diese fehlermeldung:
Code: Select all
# /opt/lampp/lampp start
Starting XAMPP for Linux 1.4.7...
head: la opción `-1' está obsoleta; utilice `-n 1'
Pruebe `head --help' para más información.
XAMPP: Starting Apache with SSL ...
XAMPP: Error 1! Couldn't start Apache!
XAMPP: Starting diagnose...
tail: la opción `-3' está obsoleta; utilice `-n 3'
Pruebe `tail --help' para más información.
XAMPP: Sorry, I've no idea what's going wrong.
XAMPP: Please contact our forum http://community.apachefriends.org/f/
XAMPP: XAMPP-MySQL is already running.
XAMPP: Starting ProFTPD...
XAMPP:  - getaddrinfo 'yos' error: Name or service not known
 - error: unable to determine IP address of 'yos'
 - error: no valid servers configured
 - Fatal: error processing configuration file '/opt/lampp/etc/proftpd.conf'
XAMPP: Error 1! Couln't start ProFTPD!
XAMPP for Linux started.


Hat jemand eine ahnung worum es geht? :(
Danke!
User avatar
matosale
 
Posts: 11
Joined: 09. July 2004 21:02

Postby Kristian Marcroft » 24. August 2004 18:41

Hi,

es würde helfen wenn die Fehlermeldungen zumindest in DEutsch oder Englisch wären...

Ich tippe zunmindest beim 2. Fehler den ich sehe darauf, das folgendes den 2. Fehler behebt:

echo 127.0.0.1 `hostname` >> /etc/hosts


Beim 1. Fehler recherchiere ich grade selbst... ;)

So long
KriS
User avatar
Kristian Marcroft
AF Moderator
 
Posts: 2962
Joined: 03. January 2003 12:08
Location: Diedorf

Re: Lampp und Yoper

Postby Kristian Marcroft » 24. August 2004 18:52

matosale wrote:Hola alle!

Ich bekomme diese fehlermeldung:
Code: Select all
# /opt/lampp/lampp start
Starting XAMPP for Linux 1.4.7...
head: la opción `-1' está obsoleta; utilice `-n 1'
Pruebe `head --help' para más información.


Hi nochmal,

um diesen Fehler zu beheben, musst du erstmal nach /opt/lampp/share/lampp dort findest du eine Datei namens "phpstatus"

Dort befindet sich in Zeile 4 folgendes:
/opt/lampp/bin/php -v | head -1 | awk '{print $2}'

das änderst du ab in:
/opt/lampp/bin/php -v | head -n 1 | awk '{print $2}'


So long
KriS
User avatar
Kristian Marcroft
AF Moderator
 
Posts: 2962
Joined: 03. January 2003 12:08
Location: Diedorf

Re: Lampp und Yoper

Postby Kristian Marcroft » 24. August 2004 18:57

matosale wrote:Ich bekomme diese fehlermeldung:
Code: Select all
# /opt/lampp/lampp start
Starting XAMPP for Linux 1.4.7...
XAMPP: Starting diagnose...
tail: la opción `-3' está obsoleta; utilice `-n 3'
Pruebe `tail --help' para más información.


Hi nochmal,

obigen Fehler bekommst du weg in dem du unter /opt/lampp/share/lampp
die Datei "diagnose" diese öffnen und folgende Zeile editieren:

Code: Select all
reason=`tail -3 /opt/lampp/logs/error_log /opt/lampp/logs/apachestart.log | $awk '/Configuration Failed/{print "hosts"}/Unable to create scoreboard/{print "scoreboard"}/check User and/||/bad group/{print "group"}'`

ändern in:
Code: Select all
reason=`tail -n 3 /opt/lampp/logs/error_log /opt/lampp/logs/apachestart.log | $awk '/Configuration Failed/{print "hosts"}/Unable to create scoreboard/{print "scoreboard"}/check User and/||/bad group/{print "group"}'`


So long
KriS
User avatar
Kristian Marcroft
AF Moderator
 
Posts: 2962
Joined: 03. January 2003 12:08
Location: Diedorf

Postby matosale » 25. August 2004 02:09

hab gerade die zwei dateien geändert und noch

echo 127.0.0.1 `hostname` >> /etc/hosts

und jetzt alles klapt :)

Danke!!!
User avatar
matosale
 
Posts: 11
Joined: 09. July 2004 21:02

Postby matosale » 25. August 2004 02:24

:evil:

Code: Select all
# sh xampp-backup-09-08-04.sh
xampp-backup-09-08-04.sh: line 41: test: too many arguments
Something went wrong.
Can you call me in a different way?


Jetzt habe ich keine ahnug was lost ist :(

Danke im voraus!!!!
User avatar
matosale
 
Posts: 11
Joined: 09. July 2004 21:02

Postby Oswald » 25. August 2004 13:14

Kannst Du bitte mal

ls -l /bin/sh

aufrufen? Was wird ausgegeben?

Liebe Grüße
Oswald
User avatar
Oswald
Apache Friends
 
Posts: 2718
Joined: 26. December 2002 19:51
Location: Berlin, Germany
Operating System: Linux

Postby matosale » 26. August 2004 07:10

Das ist was ich bekommen habe...

Code: Select all
# ls -l /bin/sh
lrwxrwxrwx  1 root root 4 2004-08-25 06:56 /bin/sh -> bash

Code: Select all
Line 41: if test -e $this



Vielen dank!
User avatar
matosale
 
Posts: 11
Joined: 09. July 2004 21:02

Postby matosale » 26. August 2004 17:23

ich hab die 43 kommentiert aber passiert es noch was:

Code: Select all
sh xampp-backup-09-08-04.sh
tail: can't open «+151» to read: No such file or directory
Checking integrity of files...
grep: md5sums: No such file or directory
md5sum: *: No such file or directory
Restoring configuration, log and htdocs files...
tar: data.tar.gz: Cannot open: No such file or directory
tar: The error is not recupreble: quit now
tar: Child returned status 2
tar: Exit with error delayed from previous errors
Checking versions...
cat: VERSION: No such file or directory
Installed:   XAMPP 1.4.7
Backup from: XAMPP
The backup sofware is not able to handle different XAMPP versions.
Your backuped configuration from  may not work with 1.4.7 and may need manually corrections.
XAMPP: Do you want to continue [no] y
Let's try...
Restoring MySQL databases...
xampp-backup-09-08-04.sh: line 129: *.sql: No such file or directory
* FAILED: cat: output: No such file or directory
Restoring MySQL user databases...
xampp-backup-09-08-04.sh: line 138: mysql.sql: No such file or directory
MySQL user FAILED: cat: output: No such file or directory
Backup complete. Have fun!
You may need to restart XAMPP to complete the restore.
User avatar
matosale
 
Posts: 11
Joined: 09. July 2004 21:02

Postby matosale » 08. September 2004 00:16

matosale wrote::evil:

Code: Select all
# sh xampp-backup-09-08-04.sh
xampp-backup-09-08-04.sh: line 41: test: too many arguments
Something went wrong.
Can you call me in a different way?
Danke im voraus!!!!


Hat jemanden schon eine lösung dafür? :cry:
User avatar
matosale
 
Posts: 11
Joined: 09. July 2004 21:02

Postby Oswald » 08. September 2004 07:00

Hallo matosale!

Danke für die Erinnerung. Sorry, hatte das Problem total vergessen. :oops:

Kannst Du an der Stelle wo Du sh xampp-backup-09-08-04.sh aufrufst bitte mal pwd aufrufen? Also erst einmal sh usw... aufrufen. So daß die Fehlermeldung kommt und danach pwd.

Liebe Grüße
Oswald

Nachtrag: Wenn in dem Vezeichnispfad, den pwd ausgibt, ein Leerzeichen ist, dann kopier die Backup-Datei einfach mal in ein Verzeichnis ohne Leerzeichen (z. B. /tmp) und probier es da noch mal.
User avatar
Oswald
Apache Friends
 
Posts: 2718
Joined: 26. December 2002 19:51
Location: Berlin, Germany
Operating System: Linux


Return to XAMPP für Linux

Who is online

Users browsing this forum: No registered users and 3 guests