ProFTP - Connect geht verloren

Irgendwelche Probleme mit XAMPP für Linux? Dann ist hier genau der richtige Ort um nachzufragen.

ProFTP - Connect geht verloren

Postby sugusmuc » 19. August 2004 17:01

Hallo,

wir haben ProFTP auf SuSe 9.0 ohne Firewall in der XAMPP-1.4.6-Distribution laufen.
Compiled-in modules:
mod_core.c
mod_xfer.c
mod_auth_unix.c
mod_auth_file.c
mod_auth.c
mod_ls.c
mod_log.c
mod_site.c
mod_sql.c
mod_sql_mysql.c
mod_cap.c

Folgendes Problem: Wir kommen mit Windows-FTP problemlos drauf und können listen und downloaden, wie wir wollen. Ebenso mit einem Uraltlinux, nicht aber mit ftp von Linux-Rechnern >= SuSe 7.0.
Damit können wir uns zwar connecten, aber dann bricht er meistens schon bei einem "ls" ab (bei fünf Dateien im Verzeichnis), manchmal schafft er es noch, eine Datei zu übertragen, aber dann kommt definitiv keine Rückmeldung mehr, sondern ein Timeout:

Titel: 421 Service not available, remote server timed out. Connection closed.


Das heißt, unser automatisierter Datenimport steht derzeit.

Weitere Angaben:

Der Server steht in der entmilitarisierten Zone, dazwischen ist eine Firewall zu unserem internen Netz, von dem aus wir connecten wollen. All das ist unverändert und lief bisher, nur der Webserver draußen wurde ausgetauscht (selbe IP-Adresse).
Wir haben bereits sämliche Logs und Debug-Optionen aktiviert, ohne etwas zu finden, was uns weiterhelfen könnte.
Passive on oder off spielt ebenfalls keine Rolle.

Wir sind am Ende unseres Lateins, und müde jetzt außerdem, weil wir heute schon bei Sonnenaufgang den Server umgestellt haben.
Wenn wir keine Lösung finden, müssen wir am Ende wieder auf den alten Server umstellen (((

Also: Hilfe wäre äußerst willkommen, vielen Dank schonmal!

mfg, sugus
sugusmuc
 
Posts: 64
Joined: 19. August 2004 16:57
Operating System: Linux Suse 64-bit 11 SP 2

Postby Wiedmann » 19. August 2004 17:16

Passive on oder off spielt ebenfalls keine Rolle.

Wo ist "Passive" an oder aus?

Damit können wir uns zwar connecten, aber dann bricht er meistens schon bei einem "ls" ab

Das passiert i.d.R. eigentlich dann, wenn auf dem Client nicht der passive FTP-Modus gewählt wurde, sondern der avtive FTP-Modus, und der Passive erforderlich ist (muß dann natürlich auf dem Server auch zugelassen sein).
Wiedmann
AF Moderator
 
Posts: 17106
Joined: 01. February 2004 12:38
Location: Stuttgart / Germany

Postby sugusmuc » 19. August 2004 17:23

Wir haben beides versucht, "auto" auch noch, es geht leider nicht :-(((

Ich wollte gerade mal sehen, was wir bei Windows verwendet haben, aber da gibt es die Option "passive" gar nicht ... ????

Wo muß das "auf dem Server zugelassen sein"?

Bin dankbar für jede Hilfe!

Grüße, sugus
sugusmuc
 
Posts: 64
Joined: 19. August 2004 16:57
Operating System: Linux Suse 64-bit 11 SP 2

Wiederumgstellt auf WU-FTP

Postby sugusmuc » 20. August 2004 16:16

Tja, wir haben's aufgegeben.

Grüße, sugus
sugusmuc
 
Posts: 64
Joined: 19. August 2004 16:57
Operating System: Linux Suse 64-bit 11 SP 2


Return to XAMPP für Linux

Who is online

Users browsing this forum: No registered users and 2 guests