Joomla Homepage mit xampp

Irgendwelche Probleme mit XAMPP für Linux? Dann ist hier genau der richtige Ort um nachzufragen.

Joomla Homepage mit xampp

Postby sv6451 » 18. October 2014 15:40

Hallo,

ich weiß, dass das Thema nicht direkt xampp betrifft, aber ich stelle meine Frage trotzdem in der Hoffnung Hilfe zu bekommen.

Auf meinem Linux (elementary os) läuft xampp 1.8.3-5. Ich bin in ein Projekt mit eingestiegen, für das eine Homepage, die shops etc. beinhaltet,
die mit joomla 2.5.x erstellt wurden.
Ich würde diese Homepage gern offline testen. Daher habe ich mir einfach alle Dateien vom Webserver heruntergeladen, xampp installiert, die MySQL-Datenbanken
installiert (auf diese kann ich auch zugreifen).
Rufe ich nun die index.php, lande ich auch auf der Startseite des Projekts.

Versuche ich nun ein Link aufzurufen (er verweist auf http://localhost/bastel/test), bekomme ich jeweils die Fehlermeldung, dass das objekt nicht gefunden wurde.
Gebe ich den link allerdings direkt ein und setze zusätzlich noch ein index.php an die richtige Stelle (http://localhost/bastel/index.php/test) funktioniert die ganze Sache.

Kann das an dieser Datei (web.config.txt die ich nicht verstehe) liegen:
Code: Select all
<?xml version="1.0" encoding="UTF-8"?>
<configuration>
   <system.webServer>
       <rewrite>
           <rules>
               <rule name="Joomla! Rule 1" stopProcessing="true">
                   <match url="^(.*)$" ignoreCase="false" />
                   <conditions logicalGrouping="MatchAny">
                       <add input="{QUERY_STRING}" pattern="base64_encode[^(]*\([^)]*\)" ignoreCase="false" />
                       <add input="{QUERY_STRING}" pattern="(&gt;|%3C)([^s]*s)+cript.*(&lt;|%3E)" />
                       <add input="{QUERY_STRING}" pattern="GLOBALS(=|\[|\%[0-9A-Z]{0,2})" ignoreCase="false" />
                       <add input="{QUERY_STRING}" pattern="_REQUEST(=|\[|\%[0-9A-Z]{0,2})" ignoreCase="false" />
                   </conditions>
                   <action type="CustomResponse" url="index.php" statusCode="403" statusReason="Forbidden" statusDescription="Forbidden" />
               </rule>
               <rule name="Joomla! Rule 2">
                   <match url="(.*)" ignoreCase="false" />
                   <conditions logicalGrouping="MatchAll">
                     <add input="{URL}" pattern="^/index.php" ignoreCase="true" negate="true" />
                     <add input="{URL}" pattern="/component/|(/[^.]*|\.(php|html?|feed|pdf|vcf|raw))$" />
                     <add input="{REQUEST_FILENAME}" matchType="IsFile" ignoreCase="false" negate="true" />
                     <add input="{REQUEST_FILENAME}" matchType="IsDirectory" ignoreCase="false" negate="true" />
                   </conditions>
                   <action type="Rewrite" url="index.php" />
               </rule>
           </rules>
       </rewrite>
   </system.webServer>
</configuration>




Vielleicht noch wichtig: Ich habe kein JOOMLA auf meinem Rechner installiert.
sv6451
 
Posts: 1
Joined: 18. October 2014 15:22
Operating System: elementary os (3.2.0-69)

Re: Joomla Homepage mit xampp

Postby Markus » 31. December 2014 00:28

Hi sv6451,

hm... sehr wahrscheinlich ist es jetzt viel zu spät, aber - so klar wird es aus deiner Beschreibung nicht - es könnte an einer beim Kopiervorgang nicht "mitgenommenen" .htaccess liegen, in der die REWRITE Regeln stehen. Es kann gut sein, dass der Unterordner "/bastel" auch zu Schwierigkeiten führt, im Idealfall sollte die Struktur wie auch auf dem Produktivserver sein.

Grüße,
Markus
Markus
 
Posts: 15
Joined: 05. January 2003 22:24
Location: So um Düsseldorf
Operating System: Linux


Return to XAMPP für Linux

Who is online

Users browsing this forum: No registered users and 1 guest