htdocs Pfad geändert - außer PHP und HTML streikt alles

Irgendwelche Probleme mit XAMPP für Linux? Dann ist hier genau der richtige Ort um nachzufragen.

htdocs Pfad geändert - außer PHP und HTML streikt alles

Postby ACU » 14. August 2004 21:12

Hallo!
Ich habe heute den Pfad von htdocs geändert (auf eine andere Festplatte).
Ich habe den Pfad in der Apache config geändert. Aber bis auf html und php funktioniert nichts mehr (Perl, SSI usw.). Außerdem kann ich den Ordner nichtmehr über das Security Programm mit einem Passwort schützen lassen (das ist sicher das kleinste Problem, weil man das ja auch manuell mit htacess machen kann).
In welchen Dateien muß ich noch die Pfade ändern, damit alles wieder läuft?
Tut mir Leid, wenn die Frage im Forum oder in der FAQ schon beantwortet wurde, aber ich habe nichts gefunden.

MfG ACU
ACU
 
Posts: 12
Joined: 14. August 2004 21:03

Postby ACU » 16. August 2004 11:26

Kann mir den keiner helfen?
Finde ich eigentlich schade, dass man den htdocs Ordner nicht auf eine andere Partition legen kann :(.
Ohne Perl und SSI nützt mir lampp nichts.
ACU
 
Posts: 12
Joined: 14. August 2004 21:03

Postby Kristian Marcroft » 16. August 2004 11:54

Hi,

bitte zeige uns mal genau was du in der httpd.conf geändert hast.
Bitte nur diese Ausschnitte pasten.

So long
KriS
User avatar
Kristian Marcroft
AF Moderator
 
Posts: 2962
Joined: 03. January 2003 12:08
Location: Diedorf

Postby ACU » 16. August 2004 12:47

Von
DocumentRoot "/opt/lampp/htdocs"

zu
DocumentRoot "/mnt/hdd1/htdocs"

Sollte eigentlich richtig sein. HTML und PHP funktioniert ja auch ohne Probleme
ACU
 
Posts: 12
Joined: 14. August 2004 21:03

Postby Kristian Marcroft » 16. August 2004 13:15

Hi,

hab ich mir fast gedacht ;)

Schau mal etwas weiter unten in deiner httpd.conf, dort findest du folgendes:
# This should be changed to whatever you set DocumentRoot to.
#
<Directory "/opt/lampp/htdocs">


Dort solltest du ebenfalls den Pfad zu deinem DocumentRoot ändern.

Anschliessend speichern, apache neustarten und schon geht alles wie gewünscht ;)

So long
KriS
User avatar
Kristian Marcroft
AF Moderator
 
Posts: 2962
Joined: 03. January 2003 12:08
Location: Diedorf

THX

Postby ACU » 16. August 2004 15:40

Danke für die Hilfe.
Jetzt funktioniert wieder alles einwandfrei.
Bin echt nicht darauf gekommen, dass ich noch einen Pfad ändern muß :oops: .

MfG ACU
ACU
 
Posts: 12
Joined: 14. August 2004 21:03


Return to XAMPP für Linux

Who is online

Users browsing this forum: No registered users and 1 guest