Fehlermeldung bei Installation

Irgendwelche Probleme mit XAMPP für Linux? Dann ist hier genau der richtige Ort um nachzufragen.

Fehlermeldung bei Installation

Postby barbara2 » 20. August 2014 13:34

Hallo!

Ich bekomme beim Versuch, xampp zu laden, folgende Fehlermeldung:

barbara@probook:~/Downloads$ sudo ./xampp-linux-x64-1.8.3-4-installer.run
./xampp-linux-x64-1.8.3-4-installer.run: 2: ./xampp-linux-x64-1.8.3-4-installer.run: Syntax error: Unterminated quoted string
barbara@probook:~/Downloads$

Bitte um Info!
Danke,
lg Barbara
barbara2
 
Posts: 1
Joined: 20. August 2014 13:27
Operating System: linux

Re: Fehlermeldung bei Installation

Postby Nobbie » 20. August 2014 15:33

Exakt dieselbe Fehlermeldung wurde in dem Thread eins tiefer schon besprochen - so wie es aussieht, versuchst Du die Xampp 64Bit Version auf einem 32bit Linux zu installieren, das geht natürlich nicht.

Du musst ein anderes Xampp Paket herunterladen, wenn Du ein 32Bit Linux betreibst.
Nobbie
 
Posts: 8765
Joined: 09. March 2008 13:04

Re: Fehlermeldung bei Installation

Postby lksteam » 10. May 2016 12:58

Hallo zusammen,

ich muß diesen Thread nochmal aktivieren.

Ich versuche Xampp 7.0.5 64Bit zu installieren bekomme aber auch die oben genannte Fehlermeldung.

Ich bin mir sicher, dass ich eine 64Bit Linuxversion installiert habe.
Zumindest zeigt es mit "lscpu" an. Daher gehe ich davon aus, dass es auch stimmt.

Habe auch schon mehrfach die Datei neu runtergeladen aber ihne Erfolg.

Was kann es noch sein?
lksteam
 
Posts: 4
Joined: 10. May 2016 12:47
XAMPP version: 7.0.5
Operating System: Linux Ubuntu 64 Bit

Re: Fehlermeldung bei Installation

Postby lksteam » 10. May 2016 19:40

Anbei die Ausgabe von uname -a.
Es ist definitiv eine 64Bit Linuxversion.
4.2.0-35-generic #40~14.04.1-Ubuntu SMP Fri Mar 18 16:37:35 UTC 2016 x86_64 x86_64 x86_64 GNU/Linux


Allerdings habe ich jetzt mal eine andere 64Bit Xamppversion runtergeladen und bekomme dort die identische Fehlermeldung. Finde ich etwas merkwürdig.
lksteam
 
Posts: 4
Joined: 10. May 2016 12:47
XAMPP version: 7.0.5
Operating System: Linux Ubuntu 64 Bit

Re: Fehlermeldung bei Installation

Postby Nobbie » 10. May 2016 20:54

lksteam wrote:Was kann es noch sein?


Irgendetwas anderes?
Leider verschweigst Du, was Du genau unternimmst. "Ich versuche" sagt mir leider überhaupt nichts. Was heißt das?
Nobbie
 
Posts: 8765
Joined: 09. March 2008 13:04

Re: Fehlermeldung bei Installation

Postby lksteam » 11. May 2016 06:40

Morgen Nobbie,

was soll ich viel schreiben zu der Frage, was ich versuche?

Ich habe Xampp mehrfach (unterschiedliche Versionen) runter geladen und versucht nach dem üblichen Weg zu installieren:

Code: Select all
chmod 755 xampp-linux-VERSION-installer.run
sudo sh ./xampp-linux-VERSION-installer.run


Wenn ich das alles gemacht habe erscheint die Fehlermeldung:

1: ./xampp-linux-x64-VERSION-installer.run: Syntax error: Unterminated quoted string


Dann habe ich etwas gesucht und immer gefunden, dass es wohl an einer installierten 32Bit Linuxveriosn liegt und ich versuche eine 64Bit Xampp zuinstallieren, was ja nicht funktionieren kann.

Also mal System gecheckt mit

Code: Select all
uname -a


Und siehe da, es ist, wie ich gedacht habe eine 64 Bit Linuxversion:

4.2.0-35-generic #40~14.04.1-Ubuntu SMP Fri Mar 18 16:37:35 UTC 2016 x86_64 x86_64 x86_64 GNU/Linux


Also kann es daran nicht liegen. Und da bin ich mit meinem Latein am Ende.

Mehr habe ich nicht gemacht.

P.S. "VERSION" wird natürlich durch die XAMPP Version ersetzt im Aufruf.
lksteam
 
Posts: 4
Joined: 10. May 2016 12:47
XAMPP version: 7.0.5
Operating System: Linux Ubuntu 64 Bit

Re: Fehlermeldung bei Installation

Postby Nobbie » 11. May 2016 11:09

lksteam wrote:
Code: Select all
chmod 755 xampp-linux-VERSION-installer.run
sudo sh ./xampp-linux-VERSION-installer.run


Genau das ist auch falsch (steht auch so nicht in der Doku), das *.run Modul ist KEIN(!) Shellscript und muss ohne "sh" ausgeführt werden:

Code: Select all
chmod 755 xampp-linux-VERSION-installer.run
sudo ./xampp-linux-VERSION-installer.run


Ist übrigens ein bereits bekannter und dokumentierter Anwenderfehler, siehe https://community.bitnami.com/t/run-ins ... rror/41289
Nobbie
 
Posts: 8765
Joined: 09. March 2008 13:04

Re: Fehlermeldung bei Installation

Postby lksteam » 11. May 2016 11:35

Hallo Nobbie,

danke für die Info.

Werde es nachher mal ausprobieren. Habe das echt beim Suchen nicht gefunden gehabt.
Danke Dir nochmal. :wink:
lksteam
 
Posts: 4
Joined: 10. May 2016 12:47
XAMPP version: 7.0.5
Operating System: Linux Ubuntu 64 Bit


Return to XAMPP für Linux

Who is online

Users browsing this forum: No registered users and 4 guests