libgcc_s.so.1: version 'GCC_4.2.0' not found

Irgendwelche Probleme mit XAMPP für Linux? Dann ist hier genau der richtige Ort um nachzufragen.

libgcc_s.so.1: version 'GCC_4.2.0' not found

Postby irokese » 16. July 2014 17:51

Hallo,
beim Versuch, Xampp-1.8.3-4 mit dem Bitnami-Installer auf meinen Linux Rechner zu installieren, erhalte ich folgende Fehlermeldung:
Starting Apache Web Server...
Exit code: 8
Stdout:
apache config test fails, aborting
Stderr:
httpd: Syntax error on line 522 of /opt/lampp/etc/httpd.conf: Syntax error on line 10 of /opt/lampp/etc/extra/httpd-xampp.conf: Cannot load modules/libphp5.so into server: /opt/lampp/lib/libgcc_s.so.1: version `GCC_4.2.0' not found (required by /opt/lampp/lib/libstdc++.so.6)
Starting Apache Web Server...
Exit code: 8
Stdout:
apache config test fails, aborting
Stderr:
httpd: Syntax error on line 522 of /opt/lampp/etc/httpd.conf: Syntax error on line 10 of /opt/lampp/etc/extra/httpd-xampp.conf: Cannot load modules/libphp5.so into server: /opt/lampp/lib/libgcc_s.so.1: version `GCC_4.2.0' not found (required by /opt/lampp/lib/libstdc++.so.6)

Vermutlich ist auch noch eine ältere Xampp Version installiert.
Wie kann ich die libgcc_s.so.1 version 'GCC_4.2.0' installieren?
Ich vermute, dass dieses Problem auch bei anderen Usern auftaucht. Habe in den Foren keine passenden Antworten gefunden.
Danke für Eure Hilfe!
Kalle
irokese
 
Posts: 4
Joined: 16. July 2014 17:37
Operating System: Linux

Re: libgcc_s.so.1: version 'GCC_4.2.0' not found

Postby Nobbie » 17. July 2014 20:40

Normalerweise musst Du gcc installieren (der dann hoffentlich die richtige Version hat). Leider beschreibst Du Dein Linux nicht weiter, deswegen sind weiterführende Tipps nicht möglich.
Nobbie
 
Posts: 8768
Joined: 09. March 2008 13:04

Re: libgcc_s.so.1: version 'GCC_4.2.0' not found

Postby irokese » 17. July 2014 22:50

Danke, nobbie, für die Rückmeldung.
Ich wechsele in mein Downloadverzeichnis und starte das Xampp Setup Wizzard mit sudo ./xampp-linux-1.8.3-4-installer.run.
Der Wizzard öffnet sich, ich klicke Xampp Core Files und Xampp Developer Files an und klicke diverse Male auf next. Kurz vor Abschluss der Installation kommt dann meine gestern (oben) beschriebene Warnmeldung. Der Wizzard schließt dennoch ab. Die Seite "It works!" öffnet sich. Das Panel wird gestartet. Wenn ich dort unter 'Manage Servers' auf 'Restart All' klicke bricht die Installation ab, ohne dass sich Xampp geöffnet hat. Und im Log finde ich wieder die gestern beschriebenen Error-Hinweise.
Auf dem PC ist GNU C installiert, aber mit der Version 4:4.6.3-1ubuntu1.
Ich denke, das Problem wäre lösbar, wenn ich wüßte, wie ich dien Verweis auf GCC_4.2.0 Version löschen/entfernen kann.
Gebe ich den Konsolenbefehl ps -e im Verzeichnis /opt/lampp/ ein, erhalte ich fünf Einträge für apache2. Der Befehl lampp start / lampp stop funktioniert auf der Konsole nicht.
Vielleicht gibt es ja auch einen Linux Update bzw Upgrade Befehl für GNU C (gcc).
Mir fehlt häufig noch das Wissen zum Umgang mit der Konsole. Zum Beispiel weiß ich nicht wie ich Xampp über die Konsole deinstallieren kann. Das würde ja vielleicht auch weiterhelfen, es einfach noch mal neu zu installieren.
Ich hoffe auf weiteren Rat.
Liebe Grüße
Kalle
irokese
 
Posts: 4
Joined: 16. July 2014 17:37
Operating System: Linux

Re: libgcc_s.so.1: version 'GCC_4.2.0' not found

Postby Nobbie » 18. July 2014 14:18

irokese wrote:Gebe ich den Konsolenbefehl ps -e im Verzeichnis /opt/lampp/ ein, erhalte ich fünf Einträge für apache2.


In welchem Verzeichnis man ps -fe eingibt (gib mal auch das f ein), spielt keinerlei Rolle. Aber insgesamt bedeutet das, dass Du schon Apache installiert und laufen hast (ohne Xampp, das ist von Deiner Distribution, die Du leider immer noch nicht genannt hast).

irokese wrote:Der Befehl lampp start / lampp stop funktioniert auf der Konsole nicht.


"Funktioniert nicht" ist nichts, womit irgendjemand etwas anfangen kann.

Das spielt aber alles keine Rolle, Du hast offensichtlich schon Apache installiert, da würde Xampp sowieso mit kollidieren, das kannst Du also getrost abbrechen und benutzt stattdessen die vorinstallierte Version.
Nobbie
 
Posts: 8768
Joined: 09. March 2008 13:04

Re: libgcc_s.so.1: version 'GCC_4.2.0' not found

Postby irokese » 18. July 2014 16:18

Der magische und sehr hilfreiche Befehl ps -fe ergab auf der Konole nur 'Command not found', im Verzeichnis /opt/lampp/ hingegen erhielt ich folgende Hinweise:
root 2046 1 0 14:46 ? 00:00:00 /usr/sbin/apache2 -k start
root 2052 2046 0 14:46 ? 00:00:00 /usr/sbin/apache2 -k start
root 2053 2046 0 14:46 ? 00:00:00 /usr/sbin/apache2 -k start
root 2054 2046 0 14:46 ? 00:00:00 /usr/sbin/apache2 -k start
root 2055 2046 0 14:46 ? 00:00:00 /usr/sbin/apache2 -k start
root 2056 2046 0 14:46 ? 00:00:00 /usr/sbin/apache2 -k start
Damit weiß ich jetzt wenigistens, wo der Apache2 liegt.
Die Eingabe apache2 -k start ergibt den Hinweis 'bad user name ${APACHE_RUN_USER}'. Die Eingabe von lamp start bzw xampp start errgibt 'command not found'. Im Browser ist unter localhost wieder 'It work's' zu sehen.
Den Hinweis/ die Frage nach der Distribution (ubuntu?) verstehe ich nicht. Der unter /sbin installierte Apache2 hat die Versionsnummer 2.2.22.
Am Ziel neben Xampp Wordpress zu installieren bin ich noch nicht angekommen.
Wäre es jetzt sinnvoll, xampp (und später dann wordpress) unter /usr/sbin zu installieren?
[Über die Paketverwaltung ist MySql und Wordpress installiert.]
Ich bin dankbar für die bisherige und auch für weitere Hilfe.
Kalle
irokese
 
Posts: 4
Joined: 16. July 2014 17:37
Operating System: Linux


Return to XAMPP für Linux

Who is online

Users browsing this forum: No registered users and 2 guests