xammp mit SUSE 9.1 + PHP extensions via pear

Irgendwelche Probleme mit XAMPP für Linux? Dann ist hier genau der richtige Ort um nachzufragen.

xammp mit SUSE 9.1 + PHP extensions via pear

Postby struzzo » 12. August 2004 15:04

Hallo,

wollte eine zusätzlich extension (xmlreader) für das PHP installieren. Xampp läuft unter Suse 9.1 aktueller Pachstand.
Leider endet die Installation via Netz oder Download immer mit folgender Fehlermeldung.

gashiri:/opt/lampp # pear install xmlreader
downloading xmlreader-1.0.tgz ...
Starting to download xmlreader-1.0.tgz (-1 bytes)
.....done: 11,396 bytes
4 source files, building
running: phpize
Configuring for:
PHP Api Version: 20031224
Zend Module Api No: 20040412
Zend Extension Api No: 220040412
configure.in:9: warning: underquoted definition of PHP_WITH_PHP_CONFIG
run info '(automake)Extending aclocal'
or see http://sources.redhat.com/automake/auto ... %20aclocal
configure.in:32: warning: underquoted definition of PHP_EXT_BUILDDIR
configure.in:33: warning: underquoted definition of PHP_EXT_DIR
configure.in:34: warning: underquoted definition of PHP_EXT_SRCDIR
configure.in:35: warning: underquoted definition of PHP_ALWAYS_SHARED
acinclude.m4:19: warning: underquoted definition of PHP_PROG_RE2C
acinclude.m4:1903: warning: underquoted definition of PHP_TEST_BUILD
`phpize' failed

Ander Extensions lassen sich ohne Probleme installieren.
Bin dankbar für jeden Lösungsvorschlag.
Ok, wenns unbeding sein muss.............
struzzo
 
Posts: 2
Joined: 12. August 2004 14:28
Location: Zürich

Postby Oswald » 12. August 2004 18:20

Hallo Struzzo!

Sieht schlecht aus. Ich hab mir mal das .tar.gz runtergeladen und es von Hand versucht. Aber auch da kommt man nicht wirklich weiter. Dabei ist mir dann auch aufgefallen, dass xmlreader noch als EXPERIMENTAL eingestuft ist. Vielleicht liegt es daran.

Grundsätzlich kann ich Dir jedenfalls auch nur raten, das tar.gz runterzuladen und es von Hand zu probieren. Damit kommt man schon mal ein bisschen weiter. Aber eigentlich kann ich Dir das auch nicht wirklich raten, weil: viel helfen tut's auch nicht.

Vielleicht wendest Du Dich am besten an die Autoren von xmlreader.

Liebe Grüße
Oswald
User avatar
Oswald
Apache Friends
 
Posts: 2718
Joined: 26. December 2002 19:51
Location: Berlin, Germany
Operating System: Linux

Postby struzzo » 12. August 2004 18:38

Vielen Dank für die rasche Antwort. Das mit dem seperaten dowloaden der Pakete und installieren haben wir im Vorfeld ebenfalls durchgespielt. Was uns zum gleichen Ergebniss gebracht hat.

Werden uns wohl nach einem Ersatzprodukt für das xmlread Packet umschauen müssen.
Ok, wenns unbeding sein muss.............
struzzo
 
Posts: 2
Joined: 12. August 2004 14:28
Location: Zürich


Return to XAMPP für Linux

Who is online

Users browsing this forum: No registered users and 2 guests