phpmyadmin per cookie nur über localhost

Irgendwelche Probleme mit XAMPP für Linux? Dann ist hier genau der richtige Ort um nachzufragen.

phpmyadmin per cookie nur über localhost

Postby Alpi » 04. August 2004 10:05

hi liebe Apachefriends,

ich hab gestern eine Neuinstallation, des Systems sowie von
Lampp durchgeführt, nach "lampp security" funktioniert phpmyadmin nur noch per localhost, das einzige was ich verändert habe ist das der Rechner jetz in der DMZ steht.
Ich habs schon mit "any host" versucht aber immer wieder das gleiche,
sobald ich z.b. root und das passwort eingebe und mich einloggen will, wird das phpmyadmin-login-Fenster neugeladen und es passiert nichts.

Hat jemand vielleicht einen Tip was das sein könnte?
weil mit lynx ist phpmyadmin echt *würg* :oops:
Alpi
 
Posts: 3
Joined: 17. July 2004 18:02
Location: Köln

Postby Oswald » 04. August 2004 10:15

Huhu Alpi!

Oh Gott: phpMyAdmin mit lynx ist echt die Hölle!!! ;)

Leider kann ich Dein Problem bei mir nicht nachvollziehen. Welchen Browser benutzt Du? Hast Du irgendwelche Cookie-Einstellungen, die da was verbieten könnten?

Ansonsten, versuch mal folgendes:

In der /opt/lampp/phpmyadmin/config.inc.php bei $cfg['PmaAbsoluteUri'] = '' die URL einzutragen mit der Du Dein phpMyAdmin erreichst.

Wenn das nicht hilft, dann schalte einfach von Cookie-basierter auf HTTP-basierter Authentifizierung um. Gleiche Datei an der Stelle $cfg['Servers'][$i]['auth_type'] = 'cookie'; aus cookie einfach http machen. Damit geht's dann definitiv.

Viel Erfolg und liebe Grüße
Oswald
User avatar
Oswald
Apache Friends
 
Posts: 2718
Joined: 26. December 2002 19:51
Location: Berlin, Germany
Operating System: Linux

Postby Alpi » 04. August 2004 10:37

Hallo Oswald,

es klappt, wenn ich $cfg['PmaAbsoluteUri'] eintragen, funtioniert login mit cookies problemlos. Ich meine ich hätte gestern Nacht auch das ausprobiert, muss wohl was Falsch gemacht haben.

Ich hab gerade nochmal per 'http' ausprobiert, da will es nach Eingabe der root-Daten, die xampp-Daten, dann springt wieder root ins Name-Fenster und dann "authorization denied", komisch.

Aber es funktioniert ja, von daher danke dir.

Grüße aus Köln
Alpi
Alpi
 
Posts: 3
Joined: 17. July 2004 18:02
Location: Köln


Return to XAMPP für Linux

Who is online

Users browsing this forum: No registered users and 1 guest