phpmyadmin leere Seite

Irgendwelche Probleme mit XAMPP für Linux? Dann ist hier genau der richtige Ort um nachzufragen.

phpmyadmin leere Seite

Postby roland4099 » 15. January 2014 11:28

Hallo zusammen,

seit einigen Tagen kann wird mir die phpmyadmin-Oberfläche nicht mehr angezeigt.

Ich habe in der Datei php.ini "display_errors" auf "ON" gesetzt und erhalte folgenden Fehler.

Fatal error: Call to undefined function __() in /opt/lampp/phpmyadmin/libraries/Config.class.php on line 755

Folgender Code steht ab Zeile 745 bis 759
Code: Select all
    function checkPermissions()
    {
        // Check for permissions (on platforms that support it):
        if ($this->get('CheckConfigurationPermissions')) {
            $perms = @fileperms($this->getSource());
            if (!($perms === false) && ($perms & 2)) {
                // This check is normally done after loading configuration
                $this->checkWebServerOs();
                if ($this->get('PMA_IS_WINDOWS') == 0) {
                    $this->source_mtime = 0;
                  die(__('Wrong permissions on configuration file, should not be world writable!'));   (Das ist die Zeile 755)
                }
            }
        }
    }


Die php_error_log-Datei zeigt ebenfalls den o.g. Fehler an.

Ich habe schon vieles ausprobiert Nun weiß ich nicht mehr weiter.
Hat vielleicht von euch eine Idee?
Für die Unterstützung bedanke ich mich.
LG
Roland

Debian 7
Xampp 1.8.0
roland4099
 
Posts: 2
Joined: 15. January 2014 11:13
Operating System: Debian 7.0

Re: phpmyadmin leere Seite

Postby Nobbie » 15. January 2014 16:13

Wenn Du einfach die(__('Wrong permissions on configuration file in Google eingegeben hättest, dann hättest Du (so wie ich) schon 1 Minute später die Lösung gewusst! Das ist ein Bug in PhpMyAdmin:

http://sourceforge.net/p/phpmyadmin/bugs/3646/

Lösung: einfach die Unterstriche wegmachen in Zeile 755.

Was hast Du "ausprobiert" und wieso nicht diese mit Abstand naheliegendste Idee?? Ich würde IMMER (IMMER UND AUSNAHMSLOS!) sowohl die Fehlerzeile selbst und/oder die Meldung in Google eingeben. Das führt in 99,9% aller Fälle auf die Lösung (und wenn ich ehrlich bin: was anderes würde mir wiederum nicht einfallen - was soll man denn sonst "ausprobieren"??).
Nobbie
 
Posts: 8767
Joined: 09. March 2008 13:04

Re: phpmyadmin leere Seite

Postby roland4099 » 15. January 2014 20:21

Vielen Dank für die Lehrstunde.
Aber leider lag die Ursache noch an anderer Stelle.

Ich lass mich gerne mal belehren. Aber mich als dummen Junge darstellen braucht keiner.

Nochmals vielen Dank für die Belehrstunde.

Vielleicht ein kleiner Tipp.

Helfen heißt nicht belehren.

Viel Spaß noch in diesem Forum.
roland4099
 
Posts: 2
Joined: 15. January 2014 11:13
Operating System: Debian 7.0

Re: phpmyadmin leere Seite

Postby Nobbie » 15. January 2014 22:08

roland4099 wrote:Vielen Dank für die Lehrstunde.
Aber leider lag die Ursache noch an anderer Stelle.


Natürlich, die grundsätzliche Ursache liegt darin, dass Deine Konfiguration aus Sicht von PhpMyAdmin unsicher ist. Aber der Versuch, Dir das mitzuteilen, scheitert eben an diesem Bug.

roland4099 wrote:Ich lass mich gerne mal belehren. Aber mich als dummen Junge darstellen braucht keiner.


Genau aus diesem Grund habe ich Dir ja die Hintertüre offen gelassen, was Du unter "vieles probiert" genau verstehst und was genau Du unternommen hast. Da Du das erneut nicht näher spezifizierst, gibt es keine andere Interpretation als die, die Du selbst annimmst (und dann auch auf beleidigt machst).

Solche Belehrungen wirken Wunder. Auch wenn es für den Belehrten unangenehm sein mag. Aber das ist mir wirklich vollkommen egal, Du hast gefragt, Du hast eine qualifizierte Antwort bekommen und Du hast eine sehr dünne Vorgabe geliefert, was Du denn wirklich unternommen hast. Im Zweifel gar nichts, denn sonst hättest Du es ja spätestens an dieser Stelle ausgesprochen.
Last edited by Nobbie on 15. January 2014 22:11, edited 2 times in total.
Nobbie
 
Posts: 8767
Joined: 09. March 2008 13:04

Re: phpmyadmin leere Seite

Postby Altrea » 15. January 2014 22:10

roland4099 wrote:Ich lass mich gerne mal belehren.

Dann gebe ich auch mal meine bescheidene Meinung dazu.

Du erwartest hier im Forum Wissen von freiwilligen Helfern anzuzapfen. Soweit nichts verwerfliches, dafür ist dieses Forum ja da.
Selbst hast du für dein Problem eine weitere Ursache ermitteln können, dir also einen Informationsgewinn verschafft.
Diese neuen Informationen teilst du in deinem Beitrag aber nicht mit der Community.
Hilfesuchende mit dem gleichen Problem können jetzt hier zwar nachlesen, dass es eine identifizierbare Ursache gibt, aber nicht wie diese aussieht.

Das ist meiner Meinung nach ein sehr unsoziales Verhalten einer Community gegenüber, von der du kostenlose Hilfe erwartest.
Solch eine Community kann nur funktionieren, wenn Informationen in beide Richtungen fließen.
We don't provide any support via personal channels like PM, email, Skype, TeamViewer!

It's like porn for programmers 8)
User avatar
Altrea
AF Moderator
 
Posts: 8290
Joined: 17. August 2009 13:05
XAMPP version: several
Operating System: Windows 10 Pro x64

Re: phpmyadmin leere Seite

Postby Nobbie » 15. January 2014 22:28

Altrea wrote:Selbst hast du für dein Problem eine weitere Ursache ermitteln können


Geht so - s.o. Ich habe ja gleich den ganzen Bug Report durchgearbeitet.
Nobbie
 
Posts: 8767
Joined: 09. March 2008 13:04


Return to XAMPP für Linux

Who is online

Users browsing this forum: No registered users and 2 guests