CGI Probleme

Irgendwelche Probleme mit XAMPP für Linux? Dann ist hier genau der richtige Ort um nachzufragen.

CGI Probleme

Postby morphes » 03. August 2004 10:57

Hallo leuts,

ich kann meine .cgi/.pl skripte leider nicht aufrufen.

print "Content-Type: text/html\n\n"';
ist vorhanden

CHMOD auf die Datei hab ich auch versucht.
Es besteht weiterhin Fehler 500 Internal Server Error

Bin mir auch nicht sicher, in welchem Ordner ich die Skripte speichern muss!?
1. /opt/lampp/cgi-bins
2. /opt/lampp/htdocs/cgi-bins
3. /opt/lampp/htdocs/xampp/cgi-bins ??

Ist sicher ein üblicher Anfängerfehler.. hehe :roll:

Greets Clemens
morphes
 
Posts: 3
Joined: 03. August 2004 10:21

Postby shevegen » 03. August 2004 11:26

"Bin mir auch nicht sicher, in welchem Ordner ich die Skripte speichern muss!? "

Bin zwar selbst noch immer Anfänger, aber du kannst über die "zentrale"
Konfigurationsdatei ziemlich viel einstellen.
Bei mir is sie
/opt/lampp/etc/httpd.conf
ich denke das is der default dir beim installieren von lamp


-->Möchtest du Verzeichnisse in den Webserver einbinden die sich ausserhalb dieses Pfades befinden, dann kannst du dies mit den Directiven Alias und Directory machen.

Ich zB habe meinen DOCUMENT_ROOT wo anders definiert (in meinem backup Ordner wo auch alle PHP und CGI sachen reinkommen)
Sprich ich hab meine custom CGI scripts in anderen Ordnern. Damit das geht, muss man ein bisserl rumändern, schauf auf die httpd.conf Datei.

/opt/lampp/etc/httpd.conf -> dort den Eintrag für # ScriptAlias: finden und einen Link zu deinen cgi Skripten setzen. Ich bin mir nicht sicher, ob das so alles okay is, aber es funktioniert, und damit bin ich zufrieden :)
<Directory "/DA_GIB_DEINEN/PFAD_ZU_DEN_CGI_SCRIPTEN_AN/cgi-bin/">
AllowOverride None
Options None
Order allow,deny
Allow from all
Options ExecCGI
</Directory>


"Bin mir auch nicht sicher, in welchem Ordner ich die Skripte speichern muss!?"
Gute Frage, ich nutze den default /opt ... cgi-bin Ordner nit wirklich, aber ich schätze die logischste Variante ist
/opt/lampp/cgi-bin

hmm hab reingeschaut, da sind bei mir 2 skripte drinnen... printenv und test-cgi hmm

Links die dir noch vielleicht helfen könnten:

http://httpd.apache.org/docs-2.0/mod/mo ... html#alias http://httpd.apache.org/docs-2.0/mod/co ... #directory
http://httpd.apache.org/docs-2.0/mod/core.html#options
User avatar
shevegen
 
Posts: 107
Joined: 08. June 2004 04:52

leider löst das mein Problem noch nicht...

Postby morphes » 03. August 2004 12:03

der Fehler 500 besteht weiterhin.

Ich ändere den Ordner, ändere die Zugriffsrechte und et klappt no imme net.. dammi :?
morphes
 
Posts: 3
Joined: 03. August 2004 10:21

Postby shevegen » 03. August 2004 15:24

hmm

mein mini script lesson2.cgi hat die Rechte -rwxr-xr-x und diesen header
#!/opt/lampp/bin/perl -w
### LESSON 2
print "Content-Type:text/html\n\n";

über http://localhost kann ich es auch aufrufen. Übrigens damals ging mein script nit weil ich ein paar Zeilenumbrüche "falsch" gesetzt habe... hab herumgespielt bis es dann auf einmal ging, nach dem header sollte auch ne leerzeile folgen, und ich glaube auch ganz am schluss des scripts auch nochmal eine
User avatar
shevegen
 
Posts: 107
Joined: 08. June 2004 04:52

Problem behoben

Postby morphes » 03. August 2004 15:58

Herje,

jep genau diese kleinsten Fehler in der Schreibweise...
diesmal wars ein einfaches -> ' nach dem "
das kann man ja fast nicht sehen uah

Thanx und Gruss
Clemens :lol:
morphes
 
Posts: 3
Joined: 03. August 2004 10:21

Postby shevegen » 04. August 2004 09:58

cool :)
User avatar
shevegen
 
Posts: 107
Joined: 08. June 2004 04:52


Return to XAMPP für Linux

Who is online

Users browsing this forum: No registered users and 1 guest