--with-oci8

Irgendwelche Probleme mit XAMPP für Linux? Dann ist hier genau der richtige Ort um nachzufragen.

--with-oci8

Postby gast » 31. March 2003 10:02

Moin, moin aus Hamburg.
ich möchte in LAMPP für eine Dipl.-Arbeit 'oci8' einbinden.
Eine lauffähige 8i-Datenbank ist auf dem Server installiert.
Da ich LAMPP bereits nutze, soll es jetzt auch oci8 können.
Ich habe allerdings Probleme aus dem Developer-Paket
ein lauffähiges LAMPP zu bekommen: ich weiß nicht wie ich
das machen soll :-(
Der Apache braucht noch LIBS=-lpthread, PHP zusätzlich --with-oci8!
Meine Kenntnisse reichen nur für 'configure, make, make install'.
Aber irgendwie scheint das beim LAMPP-Develop anders zu gehen.
Irgendein Hinweis, eine Kurzanleitung?
Danke für mögliche Antworten bereits im voraus.
Gruß
Michael
gast
 

--with-oci8

Postby pio_youth » 31. March 2003 10:44

So, Schluß mit dem Versteckspiel:
Ich bin der 'Gast' bei der obigen Anfrage!!!
Wenn ich schon ein Problem habe, dann will ich wenigstens
richtig Flagge zeigen (hoffentlich nicht zu spät).
:oops:
LINUX: sounds like music
pio_youth
 
Posts: 34
Joined: 31. March 2003 10:28
Location: Hamburg

Postby Oswald » 31. March 2003 13:10

Huhu Pio!

Ich werde heute oder morgen abend mal die Configure-Optionen fürs PHP zusammensuchen und sie hier posten. Das sollte Dir die Arbeite erheblich erleichtern. Du kannst es aber auch schon mal selbst probieren: Das wichtigste dürfte die Option --prefix=/opt/lampp beim PHP sein.

Den Apache brauchst Du aber meines Erachtens nicht neu zu übersetzten.

Liebe Grüße,
Oswald
User avatar
Oswald
Apache Friends
 
Posts: 2718
Joined: 26. December 2002 19:51
Location: Berlin, Germany
Operating System: Linux

Postby pio_youth » 31. March 2003 13:46

Juppi, erstmal mein Dank im voraus.
Allerdings habe ich die Site nicht mehr parat, wonach der Apache für php
mit oci8 gegen pthread configuriert/kompiliert sein soll.
Und was die Configure-Optionen anbelangt:
selebst wenn ich die Optionen einbaue weiß ich nicht, wie man
überhaupt ein lauffähiges LAMPP aus dem Developer-Pkt strickt :?:

Also, es gibt auch ein generelles Problem.
But we see further ;-)
LINUX: sounds like music
pio_youth
 
Posts: 34
Joined: 31. March 2003 10:28
Location: Hamburg

Postby Oswald » 31. March 2003 14:08

Huhu Pio!

Der LAMPP-Apache benutzt libpthread. Damit muss da also schon mal nichts geändert werden.

PHP sähe dann so aus: configure, make, make install und das war's dann auch schon. Da musst Du dann eigentlich recht wenig machen um "Dein" PHP ins LAMPP zu kriegen.

Gruß.
Oswald
User avatar
Oswald
Apache Friends
 
Posts: 2718
Joined: 26. December 2002 19:51
Location: Berlin, Germany
Operating System: Linux

Postby Oswald » 01. April 2003 21:10

Huhu Michael!

Hier nun wie versprochen meine configure-Parameter. Du benötigst:

1. Den PHP-Source-Code von www.php.net
2. Das LAMPP-Entwicklungspaket
3. Oracle 8i

Du musst nun eigentlich nur noch PHP nach Deinen Wünschen (--with-oci8) neu übersetzen und installieren (make install).

Hier die Kommandozeile mit der ich configure für's PHP im LAMPP aufrufe:

Code: Select all
env CFLAGS="-O6 -I/opt/lampp/include/libpng -I/opt/lampp/include/ncurses -I/opt/lampp/include -L/opt/lampp/lib" ./configure --prefix=/opt/lampp --with-apxs2=/opt/lampp/bin/apxs --with-config-file-path=/opt/lampp/etc --with-mysql=/opt/lampp --disable-debug --enable-bcmath --enable-calendar --enable-ctype --enable-dbase --enable-discard-path --enable-exif --enable-filepro --enable-force-cgi-redirect --enable-ftp --enable-gd-imgstrttf --enable-gd-native-ttf --with-ttf --enable-magic-quotes --enable-memory-limit --enable-safe-mode --enable-shmop --enable-sigchild --enable-sysvsem --enable-sysvshm --enable-track-vars --enable-trans-sid --enable-versioning --enable-wddx --enable-yp --with-ftp --with-gdbm=/opt/lampp --with-jpeg-dir=/opt/lampp --with-png-dir=/opt/lampp --with-tiff-dir=/opt/lampp --with-freetype-dir=/opt/lampp --without-xpm --with-zlib=yes --with-zlib-dir=/opt/lampp --with-openssl=/opt/lampp --with-expat-dir=/opt/lampp --enable-xslt --with-xslt-sablot=/opt/lampp -with-ming=/opt/lampp --with-dom=/opt/lampp --with-ldap=/opt/lampp --with-ncurses=/opt/lampp --with-gd --with-imap-dir=/opt/lampp --with-imap-ssl --with-imap=/opt/lampp --with-gettext=/opt/lampp  --with-mssql=/opt/lampp


Alles in einer Zeile!

Da muss jetzt eigentlich nur noch das --with-oci8 hinzu.

Liebe Grüße und viel Erfolg,
Oswald ;)
User avatar
Oswald
Apache Friends
 
Posts: 2718
Joined: 26. December 2002 19:51
Location: Berlin, Germany
Operating System: Linux

Postby pio_youth » 02. April 2003 17:04

Moin, moin Kai!
Aaalsoooo:
1. Ich habe LAMPP0.9.9a installiert:
alles läuft auf meine Lx-Büchse bestens, auch GD+Freetype und MING.

2. Ich habe LAMPP-DEVEL-0.9.9.a installiert (gleiches Verzeichnis)
Ergebnis wie 1.

3. Ich habe mir PHP-4.3.1 gezogen und entpackt, habe die 'configure'-
Zeile und den 'env'-Aufruf in eine Scriptdatei 'phpconfig.sh' einge-
fügt und am Ende durch '--with-oci8' ergänzt.
Leider musste ich das 'ldap'- und 'imap'-Geraffel heraus nehmen, da
es zu Fehlern führte. Warum? Weiß ich nicht. Auch zeigt das Config-Log
Fehler beim GD an.
4. Nach 'make' und 'make install' und restart von LAMPP sieht's gut aus:
Die Datenbankverbindung scheint zu klappen :D

Aber ein kleiner Makel: GD+Freetype zeigt mir meinen Biorhythmus
_nicht_ an :? . Gleiches gilt für InstantArt. Der asiatische Kollege MING
funktioniert.
Eine Idee? An OCI8 kann es eigentlich nicht liegen. :?:
(Ein ganzes Stück weiter bin ich aber schon mit OCI8)
Gruß
michel
LINUX: sounds like music
pio_youth
 
Posts: 34
Joined: 31. March 2003 10:28
Location: Hamburg

Postby Oswald » 02. April 2003 18:01

Moin Michael!

Das ist doch schon mal eine positive Nachricht! :)

Das Bio und InstantArt nicht funktionieren wird daran liegen, dass irgendwas mit GD schief gegangen ist. Kannst Du noch mal herausfinden, was das genau für Fehlermeldungen bzgl. GD waren? (Nebenbei würd mich auch die Fehlermeldung zu IMAP interessieren...)

Liebe Grüße,
Oswald ;)
User avatar
Oswald
Apache Friends
 
Posts: 2718
Joined: 26. December 2002 19:51
Location: Berlin, Germany
Operating System: Linux

Postby pio_youth » 02. April 2003 19:18

Mmh,
du verlangst vielleicht Sachen... (*scherz*)

Erstmal muß ich wieder etwas zurück rudern.
Ich habe das gesamte Prozedere auf einem anderen, neueren SuSE-
System (8.1 gegenüber 8.0) frisch durchgezogen:
kein Abbruch, diverse Warnungen
(z.B. diese:/opt/lampp/lib/libc-client.a(osdep.o): In function
`ssl_onceonlyinit':
/home/lampp/imap/imap-2002b/c-client/osdep.c:267: the use of `tmpnam' is dangerous, better use `mkstemp')
Ansonsten müßte ich die 'config.log' schicken, da ich selbst damit
nichts anfangen kann, und da sind einige Hinweise(?). Welche Datei
wäre sonst noch interessant?
Ansonsten kann ich erstmal damit leben so wie es ist :oops:
Also: Wenn's interessiert?

Aber: GD+FREETYPE funktionobelt :roll:

Jetzt frage aber besser nicht, was jetzt alles anders ist :?:

Und OCI8: läuft auch hier :shock:
LINUX: sounds like music
pio_youth
 
Posts: 34
Joined: 31. March 2003 10:28
Location: Hamburg

Postby Oswald » 03. April 2003 09:33

Naaaja.. mal ist es so, mal ist es so. Nehmen wir's jetzt einfach mal als gegeben hin. Letztendlich funktioniert's ja. ;)

Die tmpnam-Warnung ist übrigens "normal".

Liebe Grüße,
Oswald
User avatar
Oswald
Apache Friends
 
Posts: 2718
Joined: 26. December 2002 19:51
Location: Berlin, Germany
Operating System: Linux

Postby pio_youth » 03. April 2003 19:25

Na wenn das so ist :wink:

Nochmals vielen Dank, und sollte es was neues geben:
ich weiß ja wie ich das Forum erreiche :idea:

Gruß
michel
LINUX: sounds like music
pio_youth
 
Posts: 34
Joined: 31. March 2003 10:28
Location: Hamburg


Return to XAMPP für Linux

Who is online

Users browsing this forum: No registered users and 3 guests