Fehlermeldung: PHP Startup: Unable to load dynamic library

Irgendwelche Probleme mit XAMPP für Linux? Dann ist hier genau der richtige Ort um nachzufragen.

Fehlermeldung: PHP Startup: Unable to load dynamic library

Postby RainbowSailorZ » 27. July 2004 11:34

Hallo zusammen,

folgende Fehlermeldung erhalte ich beim Start von Xampp:

Code: Select all
[root@linux1 lampp]# ./lampp start
Starte XAMPP f�r Linux 1.4.7...
PHP Warning:  PHP Startup: Unable to load dynamic library '/opt/lampp/lib/php/extensions/no-debug-non-zts-20020429/sqlite.so' - /opt/lampp/lib/php/extensions/no-debug-non-zts-20020429/sqlite.so: undefined symbol: OnUpdateInt in Unknown on line 0
PHP Warning:  PHP Startup: x�oU��nU: Unable to initialize module
Module compiled with module API=20020429, debug=0, thread-safety=0
PHP    compiled with module API=20040412, debug=0, thread-safety=0
These options need to match
 in Unknown on line 0
XAMPP: Starte Apache mit SSL (und PHP5)...
XAMPP: Starte MySQL...
XAMPP f�r Linux gestartet.


Xampp läuft sonst aber normal. Jedenfalls kann ich keine Schwierigkeiten bei PHP-Skripten feststellen.

Fedora Core 2
Xampp 1.4.7
PHP 5.0.0

Bei Wechsel auf PHP 4.3.8 erscheint obige Fehlermeldung nicht.

Gruß
RainbowSailorZ

PS: Die deutschen Umlaute werden in den Meldungen, die Xampp ausgibt, nicht auf der Konsole angezeigt.

Code: Select all
[root@linux1 lampp]# env | grep LANG
LANG=de_DE.UTF-8
RainbowSailorZ
 
Posts: 3
Joined: 27. July 2004 10:43

Postby wingman » 01. August 2004 17:18

Hallo

Kannst du mir mal deine hosts Datei reinposten. Die liegt unter etc/

Ich habe auch Fedora Core 2 . Und will wiesen wie du die Configurit hast

Vielen Dank

Gruss Dave
wingman
 
Posts: 13
Joined: 03. July 2004 14:19

Postby Oswald » 02. August 2004 09:14

Hallihallo!

Der Pfad /opt/lampp/lib/php/extensions/no-debug-non-zts-20020429 gilt nur für PHP4. Für PHP5 sollte eigentlich am Ende 20040412 stehen.

Kannst Du mal schauen ob in der /opt/lampp/etc/php.ini irgendwo der falsche Pfad drin steht? Bei extension_dir =. Wenn ja, einfach die Zeile auskommentieren (ein ; davor setzen).

Liebe Grüße
Oswald
User avatar
Oswald
Apache Friends
 
Posts: 2718
Joined: 26. December 2002 19:51
Location: Berlin, Germany
Operating System: Linux

Postby RainbowSailorZ » 02. August 2004 12:36

wingman wrote:Hallo

Kannst du mir mal deine hosts Datei reinposten. Die liegt unter etc/

Ich habe auch Fedora Core 2 . Und will wiesen wie du die Configurit hast

Vielen Dank

Gruss Dave


Hallo,

in der hosts steht nicht allzuviel drin (standardmäßig localhost und paar interne Adressen):

Code: Select all
# Do not remove the following line, or various programs
# that require network functionality will fail.
127.0.0.1   localhost.localdomain   localhost
xxx.xxx.x.xx   bli   bla
xxx.xxx.x.xx   blub   bli
xxx.xxx.x.xx   bla   blub


Grüße
RainbowSailorZ
RainbowSailorZ
 
Posts: 3
Joined: 27. July 2004 10:43

Postby RainbowSailorZ » 02. August 2004 12:43

Kai Seidler wrote:Hallihallo!

Der Pfad /opt/lampp/lib/php/extensions/no-debug-non-zts-20020429 gilt nur für PHP4. Für PHP5 sollte eigentlich am Ende 20040412 stehen.

Kannst Du mal schauen ob in der /opt/lampp/etc/php.ini irgendwo der falsche Pfad drin steht? Bei extension_dir =. Wenn ja, einfach die Zeile auskommentieren (ein ; davor setzen).

Liebe Grüße
Oswald


Hallo,

du hast recht, daran lag es. Ich hab den Pfad in ...-20040412 geändert und nach einem Neustart von Xampp kam die Fehlermeldung nicht mehr.

Danke und Gruß
RainbowSailorZ
RainbowSailorZ
 
Posts: 3
Joined: 27. July 2004 10:43


Return to XAMPP für Linux

Who is online

Users browsing this forum: No registered users and 8 guests