1.8.3: Install OK, aber alles deaktiviert,kein Control Panel

Irgendwelche Probleme mit XAMPP für Linux? Dann ist hier genau der richtige Ort um nachzufragen.

1.8.3: Install OK, aber alles deaktiviert,kein Control Panel

Postby typo » 23. August 2013 21:31

Hallo Leute, das ist mein erster Post hier.


Kurz, ich bin XAMPP-Neuling, habe gleich mal die neueste Version ausprobiert (XAMPP 1.8.3 PHP 5) und bin nach (( url=http://www.apachefriends.org/de/xampp-linux.html#54)) Anleitung ((/url)) vorgegangen (bloß eben als "XAMPP 1.8.3" statt 1.8.2). Klappte eigentlich erstmal alles, neue Passwörter sind gesetzt, alles ist "Sicher".

Mein System ist Arch Linux/i686 (= 32 Bit), neuester Kernel (3.10.7-1) Der Start vom Terminal aus sieht erstmal problemlos aus:
Code: Select all
root # /opt/lampp/xampp start
Starting XAMPP for Linux 1.8.3-0...
XAMPP: Starting Apache...ok.
XAMPP: Starting MySQL...ok.
XAMPP: Starting ProFTPD...ok.
root #



Aber dann:

(1) im Browser unter http://localhost/xampp/|Status sind alle Komponenten deaktiviert!

(2) Und: Dauernd lese ich was von einem "Control Panel" -- sowas hab ich auch nicht! Oder gibt's das nur für Windows?
Scheint aber eher ein Fehler zu sein, denn manuell gestartet erscheint lediglich diese Optionenliste:
Code: Select all
root # /opt/lampp/xampp panel                                 
Usage: xampp <action>

   start         Start XAMPP (Apache, MySQL and eventually others)
   startapache   Start only Apache
.
.
.
   oci8          Enable the oci8 extenssion

   panel         Starts graphical XAMPP control panel
root #

bzw.
Code: Select all
root # /opt/lampp/lampp panel
Usage: lampp <action>

   start         Start XAMPP (Apache, MySQL and eventually others)
   startapache   Start only Apache
.
.
.
   oci8          Enable the oci8 extenssion

   panel         Starts graphical XAMPP control panel

root #


Wie folgt gestartet gibt es folgende Fehlermeldung:
Code: Select all
root # /opt/lampp/share/xampp-control-panel/xampp-control-panel
  File "xampp-control-panel.py", line 203
    print "Preferences clicked"
                              ^
SyntaxError: invalid syntax
root #
Pygtk ist aber installiert...

Tja, also kann ich deswegen wohl nichts aktivieren. Vorschläge?


(3) Dazu noch ne andere grundlegende Frage: Ist das eigentlich egal, ob man z. B. so schreibt (localhost|Sicherheitscheck):
Code: Select all
root # /opt/lampp/[b]x[/b]ampp security
oder so (Lies mich // http://www.apachefriends.org/de/xampp-linux.html#54)?
Code: Select all
root # /opt/lampp/[b]l[/b]ampp security


Edit: Ich vergaß zu erwähnen, dass sich auch nach mehreren Starts, Reboots und einem Un- und Re-Install nichts geändert hatte.


Vielen Dank


PS: Spricht man jetzt hier Deutsch und/oder Englisch??
PPS: Wie kann man den url-BBCode aktivieren?
PPS: Und BBCode verschachteln (innerhalb von "code") geht auch nicht?
typo
 
Posts: 4
Joined: 23. August 2013 17:51
XAMPP Version: 5.6.3
Operating System: Arch Linux w/ XAMPP 1.8.3

Re: 1.8.3: Install OK, aber alles deaktiviert,kein Control P

Postby typo » 24. August 2013 10:07

Kleines Update bei unveränderter Situation:

Auszug aus /opt/lampp/logs/error_log (abgesehen von denen für falsche Passwörter):
Code: Select all
...
cat: /opt/lampp/var/mysql/<MEINLOCALHOST>.pid: Keine Berechtigung
cat: /opt/lampp/var/mysql/<MEINLOCALHOST>.pid: Keine Berechtigung
...
Dieses Doppel kommt einige Male vor, ich denke bei jedem XAMPP-Start.

Also ein Rechte-Problem? Wenn ich aber (nur mal testweise natürlich) als root nen Browser starte und mich dann bei localhost einlogge, bleibt aber trotzdem alles deaktviert. :P

Das sind nun die Rechte des betreffenden Vezeichnisses:
Code: Select all
root  # la  /opt/lampp/var/mysql
insgesamt 28732
drwxrwxr-x 7 mysql mysql     4096 24. Aug 10:48 ./
drwxr-xr-x 6 root  root      4096 24. Aug 10:48 ../
-rw-rw---- 1 mysql mysql       56 23. Aug 15:28 auto.cnf
drwx------ 2 mysql mysql     4096 23. Aug 14:18 cdcol/
-rw-rw---- 1 mysql mysql 18874368 24. Aug 10:48 ibdata1
-rw-rw---- 1 mysql mysql  5242880 24. Aug 10:48 ib_logfile0
-rw-rw---- 1 mysql mysql  5242880 23. Aug 15:28 ib_logfile1
-rw-r----- 1 mysql root     19717 24. Aug 10:48 <MEINLOCALHOST>.err
-rw-rw---- 1 mysql mysql        6 24. Aug 10:48 <MEINLOCALHOST>.pid
drwx------ 2 mysql mysql     4096 23. Aug 14:18 mysql/
srwxrwxrwx 1 mysql mysql        0 24. Aug 10:48 mysql.sock=
-rw-r--r-- 1 mysql mysql        6 27. Jun 16:26 mysql_upgrade_info
drwx------ 2 mysql mysql     4096 23. Aug 14:18 performance_schema/
drwx------ 2 mysql mysql     4096 23. Aug 14:18 phpmyadmin/
drwx------ 2 mysql mysql     4096 23. Aug 14:18 test/

Ausgabe von /opt/lampp/var/mysql/<MEINLOCALHOST>.err vom Start gerade eben:
Code: Select all
2013-08-24 10:48:35 25173 mysqld_safe Starting mysqld daemon with databases from /opt/lampp/var/mysql
2013-08-24 10:48:37 0 [Warning] TIMESTAMP with implicit DEFAULT value is deprecated. Please use --explicit_defaults_for_timestamp server option (see documentation for more details).
2013-08-24 10:48:37 25693 [Note] Plugin 'FEDERATED' is disabled.
2013-08-24 10:48:37 25693 [Note] InnoDB: The InnoDB memory heap is disabled
2013-08-24 10:48:37 25693 [Note] InnoDB: Mutexes and rw_locks use InnoDB's own implementation
2013-08-24 10:48:37 25693 [Note] InnoDB: Compressed tables use zlib 1.2.8
2013-08-24 10:48:37 25693 [Note] InnoDB: Not using CPU crc32 instructions
2013-08-24 10:48:37 25693 [Note] InnoDB: Initializing buffer pool, size = 16.0M
2013-08-24 10:48:37 25693 [Note] InnoDB: Completed initialization of buffer pool
2013-08-24 10:48:38 25693 [Note] InnoDB: Highest supported file format is Barracuda.
2013-08-24 10:48:38 25693 [Note] InnoDB: 128 rollback segment(s) are active.
2013-08-24 10:48:38 25693 [Note] InnoDB: Waiting for purge to start
2013-08-24 10:48:38 25693 [Note] InnoDB: 5.6.12 started; log sequence number 1625150
2013-08-24 10:48:38 25693 [Note] RSA private key file not found: /opt/lampp/var/mysql//private_key.pem. Some authentication plugins will not work.
2013-08-24 10:48:38 25693 [Note] RSA public key file not found: /opt/lampp/var/mysql//public_key.pem. Some authentication plugins will not work.
2013-08-24 10:48:39 25693 [Note] Event Scheduler: Loaded 0 events
2013-08-24 10:48:39 25693 [Note] /opt/lampp/sbin/mysqld: ready for connections.
Version: '5.6.12'  socket: '/opt/lampp/var/mysql/mysql.sock'  port: 0  Source distribution
Kann jemand was damit anfangen?


Edit: Inzwischen hab ich mir auch einen daemon eingerichtet (s. https://bbs.archlinux.org/viewtopic.php?pid=1259719#p1259719). Der läuft, aber das Problem gibts natürlich weiterhin.
typo
 
Posts: 4
Joined: 23. August 2013 17:51
XAMPP Version: 5.6.3
Operating System: Arch Linux w/ XAMPP 1.8.3

Re: 1.8.3: Install OK, aber alles deaktiviert,kein Control P

Postby typo » 25. August 2013 20:17

So -- Vorsicht, User! ;)

v1.8.3-0beta
habe ich noch 2-mal neu (re-)installiert, (1) auf der Textkonsole und (2) in X, Ergebnisse wie folgt:

(1) Konsole

Code: Select all
% su
Passwort:
root # chmod 755 xampp-linux-1.*-installer.run && ./xampp-linux-1.*-installer.run

Da hier
Code: Select all
START /sbin/dwb "http://localhost.localdomain"
(dwb ist der Browser) nicht wie unter X ausgeführt wird, habe ich den Initialstart daher explizit ausgeführt:
Code: Select all
# links -g http://localhost

Die XAMPP-Seite erscheint, natürlich noch ohne explizites Einloggen. (Also gehe ich davon aus, dass XAMPP ordnungsgemäß gestartet ist, genauso, wie wenn ich explizit aufrufen würde -- genauso wie bei den vielen früheren Versuchen.)
--> Alles bis auf MySQL und die beiden letzen Komponenten sind aktiviert; unsichere Einstellungen.

Passwörter ändern bzw. setzen:
Code: Select all
# /opt/lampp/lampp security                                                 
XAMPP:  Quick security check...
XAMPP:  Your XAMPP pages are NOT secured by a password.
XAMPP: Do you want to set a password? [ja]
XAMPP: Password:
XAMPP: Password (again):
XAMPP:  Password protection active. Please use 'xampp' as user name!
XAMPP:  MySQL is accessable via network.
XAMPP: Normaly that's not recommended. Do you want me to turn it off? [ja]
XAMPP:  Turned off.
XAMPP:  MySQL has to run before I can check the security.
XAMPP:  MySQL has to run before I can check the security.
XAMPP:  MySQL has a root passwort set. Fine! :)
XAMPP:  The FTP password for user 'daemon' is still set to 'xampp'.
XAMPP: Do you want to change the password? [ja]
XAMPP: Password:
XAMPP: Password (again):
XAMPP: Reload ProFTPD...not running.
XAMPP:  Done.
--> Danach ist bei "Status" alles deaktivert! -- Und seltsam ist dann diese Ausgabe:
Code: Select all
XAMPP: Reload ProFTPD...not running.
XAMPP:  Done.
Was soll die (mit oder ohne "Done") aussagen?

Alles dann gestoppt, deinstalliert, rebootet, nächster Versuch:


(2) X und X Terminal

Code: Select all
% su
Passwort:
root # chmod 755 xampp-linux-1.*-installer.run && ./xampp-linux-1.*-installer.run

Am Ende der Installation "Launch XAMPP" bestätigt (bin also weiterhin User "root"), d. h.
Code: Select all
START /sbin/dwb "http://localhost.localdomain"
wird ausgeführt, also das automatische Script der BitNami-API.
--> Siehe oben: Alles bis auf MySQL und die beiden letzen Komponenten sind aktiviert; unsichere Einstellungen.

Code: Select all
# /opt/lampp/lampp security                                                 
XAMPP:  Quick security check...
XAMPP:  Your XAMPP pages are NOT secured by a password.
XAMPP: Do you want to set a password? [ja]
XAMPP: Password:
XAMPP: Password (again):
XAMPP:  Password protection active. Please use 'xampp' as user name!
XAMPP:  MySQL is accessable via network.
XAMPP: Normaly that's not recommended. Do you want me to turn it off? [ja]
XAMPP:  Turned off.
XAMPP:  MySQL has to run before I can check the security.
XAMPP:  MySQL has to run before I can check the security.
XAMPP:  MySQL has a root passwort set. Fine! :)
XAMPP:  The FTP password for user 'daemon' is still set to 'xampp'.
XAMPP: Do you want to change the password? [ja]
XAMPP: Password:
XAMPP: Password (again):
XAMPP: Reload ProFTPD...not running.
XAMPP:  Done.
Dann als User "root" eingeloggt.
--> Alles deaktiviert.

Das bleibt auch nach einem Stoppen, Rebooten, Starten und Einloggen so!


-------------------------------------------------------------------------------

Um auszuschließen, dass es sich um ein Problem der Beta-Version handeln könnte, habe ich v1.8.3 gestoppt und runtergeschmissen, und dann alles nochmal mit XAMPP 1.8.2-1 durchexerziert (nur unter X getestet). Dafür habe ich nun einige nette Screenshots gemacht -- aber auch nur um letztendlich zu zeigen, dass sich nichts geändert hat! :P
Da sich die Oberflächen gleichen, kann man die Bildchen auch für 1.8.3-0 nehmen. Tja, leider Pech -- Bildchen posten scheint hier auch nicht zu gehen~

v1.8.2-1

Nun der Reihe nach.
Nach dem Initialstart am Ende der Installation (denn der Installer bietet es ja an), d .h. vor Passwort-Setzung bzw. Änderung:
--> Nur PHP, Perl, CGI und SSI sind aktiviert.

Diese dann gesetzt bzw. geändert:
Code: Select all
# /opt/lampp/lampp security
XAMPP:  Quick security check...
XAMPP:  Your XAMPP pages are NOT secured by a password.
XAMPP: Do you want to set a password? [ja]
XAMPP: Password:
XAMPP: Password (again):
XAMPP:  Passwords doen't match. Please try again.
XAMPP: Password:
XAMPP: Password (again):
XAMPP:  Password protection active. Please use 'xampp' as user name!
XAMPP:  MySQL is accessable via network.
XAMPP: Normaly that's not recommended. Do you want me to turn it off? [ja]
XAMPP:  Turned off.
XAMPP:  MySQL has to run before I can check the security.
XAMPP:  MySQL has to run before I can check the security.
XAMPP:  MySQL has a root passwort set. Fine! :)
XAMPP:  The FTP password for user 'daemon' is still set to 'xampp'.
XAMPP: Do you want to change the password? [ja]
XAMPP: Password:
XAMPP: Password (again):
XAMPP: Reload ProFTPD...not running.
XAMPP:  Done.
XAMPP-Reload im Browser, muss mich einloggen:
--> "Status": wieder ALLES deaktiviert!
--> "Sicherheit": "pma" und "phpMyadmin" haben kein Passwort.

Wenn ich dann aber wie gefordert
Code: Select all
"Zum Schließen dieser Sicherheitslücken einfach als root den folgenden Befehl aufrufen:

/opt/lampp/xampp security

Dadurch wird ein dialoggeführtes Programm gestartet, welches alle diese Sicherheitslücken schließen kann."
besagtes Programm ausführe, kommt aber nur das bei raus:
Code: Select all
# /opt/lampp/xampp security
XAMPP:  Quick security check...
XAMPP:  Your XAMPP pages are secured by a password.
XAMPP: Do you want to change the password anyway? [nein]
XAMPP:  MySQL is not accessable via network. Good.
XAMPP:  MySQL has to run before I can check the security.
XAMPP:  MySQL has to run before I can check the security.
XAMPP:  MySQL has a root passwort set. Fine! :)
XAMPP:  ProFTPD has a new FTP password. Great!
XAMPP: Do you want to change the password anyway? [nein]
XAMPP:  Done.
Was soll denn das?

Btw., Feature-Request 1: Und wenn schon ein GUI, dann sollte es auch unter "Sicherheit" Buttons dafür geben, um die einzelnen Sicherheitseinstellungen direkt zu ändern! Feature-Request 2: Ich finde eigentlich auch, dass es eine Auslog-Funktion geben sollte, anstatt nur das Fenster schließen oder den Browser killen zu können, wenn man XAMPP nicht mehr braucht.

Danach jedenfalls
Code: Select all
# /opt/lampp/xampp stop   
Stopping XAMPP for Linux 1.8.2-1...
XAMPP: Stopping Apache...ok.
XAMPP: Stopping MySQL...not running.
XAMPP: Stopping ProFTPD...not running.
und rebootet.

Danach unter X XAMPP gestartet (ob als xampp oder lampp, scheint egal zu sein, ist aber verwirrend):
Code: Select all
# /opt/lampp/xampp start 
Starting XAMPP for Linux 1.8.2-1...
XAMPP: Starting Apache...ok.
XAMPP: Starting MySQL...ok.
XAMPP: Starting ProFTPD...ok.
und im Browser http://localhost eingegeben:
--> alles deaktiviert, egal, ob ich den browser als normaler User oder als "root" starte (was ja egal sein soll).

Dann als User "root" ausgeführt:
Code: Select all
# /opt/lampp/xampp security
XAMPP:  Quick security check...
XAMPP:  Your XAMPP pages are secured by a password.
XAMPP: Do you want to change the password anyway? [nein]
XAMPP:  MySQL is not accessable via network. Good.
XAMPP:  MySQL has to run before I can check the security.
XAMPP:  The MySQL/phpMyAdmin user pma has no password set!!!
XAMPP: Do you want to set a password? [ja]
XAMPP: Password:
XAMPP: Password (again):
XAMPP:  Setting new MySQL pma password.
XAMPP:  Setting phpMyAdmin's pma password to the new one.
XAMPP:  MySQL has to run before I can check the security.
XAMPP:  MySQL has no root passwort set!!!
XAMPP: Do you want to set a password? [ja]
XAMPP:  Write the password somewhere down to make sure you won't forget it!!!
XAMPP: Password:
XAMPP: Password (again):
XAMPP:  Setting new MySQL root password.
XAMPP:  Change phpMyAdmin's authentication method.
XAMPP:  ProFTPD has a new FTP password. Great!
XAMPP: Do you want to change the password anyway? [nein]
XAMPP:  Done.
--> Alles bleibt deaktiviert, weiterhin haben "pma" und "phpmyadmin" kein Passwort.

Daher ausgeführt
Code: Select all
# /opt/lampp/xampp restart
Restarting XAMPP for Linux 1.8.2-1...
XAMPP: Stopping Apache...ok.
XAMPP: Stopping MySQL...not running.
XAMPP: Stopping ProFTPD...ok.
XAMPP: Starting Apache...ok.
XAMPP: Starting MySQL...ok.
XAMPP: Starting ProFTPD...ok.
/opt/lampp/xampp restart  4,97s user 0,59s system 42% cpu 13,035 total

--> Weiterhin alles deaktiviert und "pma" und "phpmyadmin" kein Passwort. -- Dann XAMPP gestoppt, Systemneustart, XAMPP gestartet:
Code: Select all
# /opt/lampp/xampp start
Starting XAMPP for Linux 1.8.2-1...
XAMPP: Starting Apache...ok.
XAMPP: Starting MySQL...ok.
XAMPP: Starting ProFTPD...ok.

Dann Firefox gestartet, in http://localhost eingeloggt:
--> "Status": alles deaktiviert, aber bei "Sicherheitscheck" jetzt immerhin alles sicher.

Das heißt: DIESELBE SITUATION wie zu Beginn des Threads!


Bezüglich "Control Panel"

Damit ist dann doch wohl http://localhost/xampp im Browser als solches gemeint, und etwa keine besondere Unterseite, wo man die Komponenten bei "Status" ändern kann, wie erst dachte, oder? Das von Windows sieht aber ganz anders aus, darum dachte ich, das gäbe es bei der Linux-Version auch... Um Verwirrung zu vermeiden, bin ich grundsätzlich dafür, dass es explizite Screenshots bei der Online-Anleitung nicht nur für Windows, sondern für alle XAMPP-Versionen gibt!

Jedenfalls funktioniert im X Terminal das
Code: Select all
# /opt/lampp/xampp panel
Usage: xampp <action>

   start         Start XAMPP (Apache, MySQL and eventually others)
   startapache   Start only Apache
   startmysql    Start only MySQL
   startftp      Start only ProFTPD

   stop          Stop XAMPP (Apache, MySQL and eventually others)
   stopapache    Stop only Apache
   stopmysql     Stop only MySQL
   stopftp       Stop only ProFTPD

   reload        Reload XAMPP (Apache, MySQL and eventually others)
   reloadapache  Reload only Apache
   reloadmysql   Reload only MySQL
   reloadftp     Reload only ProFTPD

   restart       Stop and start XAMPP
   security      Check XAMPP's security

   enablessl     Enable SSL support for Apache
   disablessl    Disable SSL support for Apache

   backup        Make backup file of your XAMPP config, log and data files

   oci8          Enable the oci8 extenssion

   panel         Starts graphical XAMPP control panel
immer noch nicht :P

Komisch ist aber auch diese Fehlermeldung bei der Demo "CD-Verwaltung", siehe unten:
Code: Select all
Warning: mysql_connect(): Access denied for user 'root'@'localhost' (using password: NO) in /opt/lampp/htdocs/xampp/cds.php on line 64
Kann die Datenbank nicht erreichen!
Läuft MySQL oder wurde das Passwort geändert?
[attachment=][/attachment]


Ja, aber MySQL läuft doch, s.o., und der Browser mit http://localhost wurde erst gestartet, nachdem während der vorigen Linux-Sitzung neue Passwörter angelegt wurden. Also ist diese Fehlermeldung/Warnung Blödsinn!


Tut mir leid, aber ich blick da überhaupt nicht durch!! Fehlen da noch irgendwelche Arbeitsschritte oder
Nachkonfigurationen? Fehlen noch Abhängigkeiten? (Falls das wichtig sein sollte: python3 (v3.3.2-1) und pygtk
(v2.24.0-3) sind installiert.) Das Fazit jedenfalls ist: weder XAMPP 1.8.2 noch 1.8.3 wollen (bei mir) nicht laufen, scheint ein systematischer Fehler zu sein! Ganz so einfach wie nach Anleitung vorzugehen ist es dann wohl doch nicht.

Vielleicht lässt sich XAMPP ja auf nem Windows-Rechner reibungsloser installieren, hab's noch nicht probiert und auch gerade keinen zur Hand.

Damit ist jetzt auch mal Ende mit dieser Odyssee. Nachdem jetzt hier aber meine Geduld langsam zuende ist, werde ich mich wohl für Linux mal nach ner anderen Lösung umsehen müssen, denn ich brauch jetzt echt dringend mal eine funktionierende Webserver-Umgebung!

Falls jemandem zu meinem XAMPP bald noch was einfällt und ich die Muße dazu habe, kann ich es ja nochmal testen.


Edit:// NB: Erst stand bei meiner XAMPP-Version (eigtl. 1.8.3-0beta) "1.8.1", dann "Beta", und jetzt wieder "1.8.1" ...
typo
 
Posts: 4
Joined: 23. August 2013 17:51
XAMPP Version: 5.6.3
Operating System: Arch Linux w/ XAMPP 1.8.3

Re: 1.8.3: Install OK, aber alles deaktiviert,kein Control P

Postby Nobbie » 25. August 2013 22:59

typo wrote: werde ich mich wohl für Linux mal nach ner anderen Lösung umsehen müssen, denn ich brauch jetzt echt dringend mal eine funktionierende Webserver-Umgebung!


Das ist genau das, was ich seit Jahren empfehle. Unter WIndows mag es ja für viele schwierig sein, einen Webserver einzurichten, aber unter Linux hat (aus meiner Sicht) Xampp keine Daseinsberechtigung. Jede vernünftige Distribution bringt die notwendigen Tools mit und ist im Zweifel fehlerfreier und so oder so besser in die Distribution eingebettet als Xampp.

Von daher verstehe ich schon lange nicht mehr, wieso jemand Xampp unter Linux benutzt.
Nobbie
 
Posts: 6799
Joined: 09. March 2008 13:04

Re: 1.8.3: Install OK, aber alles deaktiviert,kein Control P

Postby typo » 26. August 2013 09:39

Hi!

Danke für die Antwort und dafür, dass sich hier mal jemand regt, denn wozu poste ich das alles. :)


Mittlerweile weiß ich, dass für dieses "Control Panel" python2 gebraucht wird, und dass ich dafür das Bash-Script, das das startet, editieren musste. -- Das Ergebnis war trotzdem ernüchternd: Dieses Bash-Script lässt sich dann zwar explizit starten, herauskommt aber nur ein bescheidenes Fensterchen mit Buttons für die Startfunktionen, wie man sie auch im Terminal eingibt. Daneben lässt sich die Option "panel" im Terminal aber immer noch nicht starten.

Eine Datei /opt/lampp/logs/error.log musste ich auch selber anlegen, da es nur eine error_log gab. Es gibt außerdem weitere Fehlerausgaben:
Code: Select all
/opt/lampp/lampp: Zeile 491: printf: Schreibfehler: Datenübergabe unterbrochen (broken pipe).
/opt/lampp/lampp: Zeile 98: printf: Schreibfehler: Datenübergabe unterbrochen (broken pipe).
/opt/lampp/share/xampp/diagnose: Zeile 35: echo: Schreibfehler: Datenübergabe unterbrochen (broken pipe).
/opt/lampp/share/xampp/diagnose: Zeile 54: echo: Schreibfehler: Datenübergabe unterbrochen (broken pipe).
/opt/lampp/share/xampp/diagnose: Zeile 55: echo: Schreibfehler: Datenübergabe unterbrochen (broken pipe).
/opt/lampp/share/xampp/diagnose: Zeile 57: printf: Schreibfehler: Datenübergabe unterbrochen (broken pipe).
tail: Schreibfehler: Datenübergabe unterbrochen (broken pipe)
/opt/lampp/lampp: Zeile 148: printf: Schreibfehler: Datenübergabe unterbrochen (broken pipe).
/opt/lampp/lampp: Zeile 182: printf: Schreibfehler: Datenübergabe unterbrochen (broken pipe).

K. A. ob das jetzt damit zu tun hat, dass alle Komponenten deaktiviert bleiben -- was letztlich das KO-Kriterium ist.


Tja, da bin ich wohl als blutiger Webmaster-Anfänger dem Schein aufgesessen, das LAMP, LAMPP, XAMPP oder wie auch immer BS-übergreifend als Quasi-Standard angepriesen wird.

Inzwischen habe ich auch mitgekriegt, dass es wesentlich leichtgewichtigere Alternativen gibt, die dazu nicht so schwierig einzurichten sind. Aber hinterher ist man ja immer klüger. -- Wenigstens habe ich XAMMP/Linux eine Chance gegeben.
typo
 
Posts: 4
Joined: 23. August 2013 17:51
XAMPP Version: 5.6.3
Operating System: Arch Linux w/ XAMPP 1.8.3


Return to XAMPP für Linux

Who is online

Users browsing this forum: No registered users and 3 guests