Fehlermeldung beim Start von XAMPP-1.4.7

Irgendwelche Probleme mit XAMPP für Linux? Dann ist hier genau der richtige Ort um nachzufragen.

Fehlermeldung beim Start von XAMPP-1.4.7

Postby pir187 » 21. July 2004 10:01

Hab` gerade Version 1.4.7 entpackt und bekomme beim Start folgende Meldung:
Code: Select all
Starte XAMPP für Linux 1.4.7...
head: `-1' option is obsolete; use `-n 1' since this will be removed in the future
XAMPP: Starte Apache mit SSL (und PHP5)...
XAMPP: Starte MySQL...
XAMPP für Linux gestartet.


Hat jemand eine Idee, wie ich das abstellen kann bzw. wo der Fehler ist?


MfG, pir187
pir187
 
Posts: 76
Joined: 13. August 2003 00:15
Location: Struppen / Sachsen

Postby Oswald » 21. July 2004 12:53

Huhu pir187.

Was? Das fass ich ja nicht. "head -1" ist ein super Unix-Kommando und nun machen die Linux-Jungs es obsolet. *kopfschüttel* Damit wird die Kompatibilität und Stabilität von Linux sicher nicht gefördert. *ärger*

Egal: Du findest den Befehl in /opt/lampp/share/lampp/phpstatus.

Und trotz meines persönlichen Ärgerns: Danke für den Hinweis!! :)

Liebe Grüße
Oswald

PS: Welche Linux-Distribution benutzt Du?
User avatar
Oswald
Apache Friends
 
Posts: 2718
Joined: 26. December 2002 19:51
Location: Berlin, Germany
Operating System: Linux

Postby pir187 » 21. July 2004 14:02

Hallo Kai,

zuerst einmal: hallo Namensvetter! Ich bin auch einer, der auf diesen wohlklingenden Namen hört (oder dies tun sollte).

Aber nun zum Thema: ich werde das Kommando gleich mal ändern, dann melde ich mich wieder. So wie ich das verstanden habe, ist nur die Syntax, nicht gleich das ganze Kommando "obsolete". Man soll "-n l" nutzen, oder versteh ich da was falsch?

Zu deiner anderen Frage: mein Server läuft unter Gentoo Linux 1.4 - aber diese Versionsnummer hat ja nicht wirklich etwas Aussagekräftiges in sich, da das Sys ja stets mit emerge ... aktuell gehalten werden kann!

Du könntest XAMPP für Linux auch als "Gentoo-prooven" angeben, da gibt es doch irgendwo auf den XAMPP-Seiten eine Aufzählung von Distris, auf denen XAMPP erfolgreich getestet wurde, oder?


Liebe Grüße, pir187
pir187
 
Posts: 76
Joined: 13. August 2003 00:15
Location: Struppen / Sachsen

Postby Oswald » 21. July 2004 14:25

Huhu Kai! ;)

Ja, Du musst lediglich aus head -1 ein head -n 1 machen. Das ist alles.

Danke für die Info mit Gentoo. Dann nehm ich das gleich mal mit in die Liste der funktionierenden Distributionen auf.

Liebe Grüße
Kai ;)
User avatar
Oswald
Apache Friends
 
Posts: 2718
Joined: 26. December 2002 19:51
Location: Berlin, Germany
Operating System: Linux

Postby pir187 » 21. July 2004 14:33

Nach der Änderung funktioniert der Start (natürlich) wieder einwandfrei :D !


Danke, pir187
pir187
 
Posts: 76
Joined: 13. August 2003 00:15
Location: Struppen / Sachsen


Return to XAMPP für Linux

Who is online

Users browsing this forum: No registered users and 2 guests