Virtueller Host

Irgendwelche Probleme mit XAMPP für Linux? Dann ist hier genau der richtige Ort um nachzufragen.

Virtueller Host

Postby mente1982 » 14. July 2004 12:49

Hallo zusammen!


Ich wollte gerade ein paar virtuelle Server einrichten, habe aber ein Problem:

Auszug aus /opt/lampp/etc/http.conf

Code: Select all

ServerName localhost
NameVirtualHost *

<VirtualHost *>
   Servername vdb.mn.org
   DocumentRoot /int/datenbanken/videodb
</VirtualHost>



DNS Config.

Code: Select all

vdb    IN A 192.168.123.100



Wenn ich dann auf vdb.mn.org gehe, wird die Videodatenbank auch brav geladen, aber

wenn ich auf www.mn.org gehe, wird die vdb _AUCH_ geladen.
Die index.php liegt aber unter /opt/lampp/htdocs und nicht unter /int/datenbanken/videodb

Was habe ich da übersehen?

TIA & HAND

CleSch
Vita non optanda, optanda sunt vivanda
mente1982
 
Posts: 5
Joined: 17. March 2004 00:42

Postby Wiedmann » 14. July 2004 12:57

a) Von "www.mn.org" steht in deiner conf aber nichts... (wobei das wohl auch zu vernachlässigen ist, siehe b)

b) Der erste VHost ist dein Standardserver, der sich alles greift, was nicht durch andere Vhosts bearbeitet wird. Sprich, du musst an erster Stelle für deinen bishergen Hauptserver ebenfalls einen VHost einrichten.
Wiedmann
AF Moderator
 
Posts: 17106
Joined: 01. February 2004 12:38
Location: Stuttgart / Germany

Postby mente1982 » 14. July 2004 13:50

Hallo Wiedmann!

Danke für Deine äussert rasche Antwort, jetzt funktioniert es:

Aber, ich habe einen VHost namens intranet erstellt.
Im BaseDir habe ich eine .htaccess und eine .htpasswd.

Wenn ich intranet.mn.org aufmachen will, kommt eine Fehlermeldung:

Code: Select all

Zugriff verweigert!


Der Zugriff auf das angeforderte Verzeichnis ist nicht möglich. Entweder ist kein Index-Dokument vorhanden oder das Verzeichnis ist zugriffsgeschützt.


Sofern Sie dies für eine Fehlfunktion des Servers halten, informieren Sie bitte den Webmaster hierüber.


Error 403



In der .htaccess steht:

Code: Select all

AuthType Basic
AuthName "Zugriff auf INTRANET eingeschränkt"
AuthUserFile /int/.htpasswd
require valid-user



index.htm oder index.php ist keine vorhanden, ich habe immer das DirListing gehabt und möchte es gerne weiterhin haben

HAND und nochmals TIA

CleSch
Vita non optanda, optanda sunt vivanda
mente1982
 
Posts: 5
Joined: 17. March 2004 00:42

Postby Wiedmann » 14. July 2004 13:56

Wenn du eine index.html in das Verzeichnis legst würde es funktionieren?
--> Passwortabfrage und dann wird die Datei angezeigt

Wenn ja, mach noch:
Options +Indexes
in die .htaccess
Wiedmann
AF Moderator
 
Posts: 17106
Joined: 01. February 2004 12:38
Location: Stuttgart / Germany

Postby DaHipster » 07. August 2004 12:08

Deine .htaccess sieht nicht so gut aus.

Mach´s mal so:
AuthUserFile "/int/.htpasswd"
AuthName "Da könnte ja jeder kommen!"
AuthType Basic

<Limit GET POST>
order deny,allow
require valid-user
</Limit>
DaHipster
 
Posts: 9
Joined: 07. August 2004 11:06


Return to XAMPP für Linux

Who is online

Users browsing this forum: No registered users and 2 guests