Environment variable MAIL_ROOT not found

Irgendwelche Probleme mit XAMPP für Linux? Dann ist hier genau der richtige Ort um nachzufragen.

Environment variable MAIL_ROOT not found

Postby ddorf » 06. July 2004 18:33

Elo Leute!

Vielleicht kann mir einer helfen? Ich habe das Xampp für Linux auf Suse 8.2 Pro installiert, fuktioniert super! Danach habe ich das Xmail addon installiert, geht auch Klasse. Nur wenn ich die mail() funktion benutzen will geht es leider nicht. Xmail läuft den über WebMail kann man sich einlogen um mails zu sehen oder neuer zu schreiben, geht alles wunderbar.

Bei php.ini habe ich alles so wie es sein sollte. Hier gibts aber ein Problem und zwar wenn ich nur "sendmail -t" da stehen hab und ich die test.php in kommandozeile ausführe sagt er mir das er diesen commando nicht gefunden hatt. Wenn ich aber "sendmail.xmail -t" eintrage sagt er eben das es wohl MAIL_ROOT nicht gibt. Wenn ich allerdings export MAIL_ROOT= /opt/lampp/var/MailRoot schreibe geht dieser dann auf einmal und verschickt auch diese test mail, leider aber nur von kommandozeile nicht über den Browser, wenn ich mich als anderer benutzer anmelde geht es auch nicht, wenn ich dem Rechner neustarte geht es auch nicht. Also ich habe diese Fehlermeldung in xmail forum gefunden nur leider geht es bei mir trotzdem nicht. Es ist auch schwer den hier ist das ein addon zum lampp und kein Xmail alleine.

Was muss ich den machen damit die mail() funktion ohne das ich jedes mal diesen export schreibe funktioniert? Ich habe auch in /etc/inet.d/xmail nachgeschaut, dort steht aber :

XMail_Root=/opt/lampp/var/MailRoot

und weiter unten

Mail_Root = XMail_Root
export Mail_Root

also es scheint als er diese "exportiert".

Hatt einer ne Lösung?..................Danke.
ddorf
 
Posts: 2
Joined: 06. July 2004 18:14

Postby ddorf » 07. July 2004 10:16

Hallo,

hat sich schon erledigt, hab etwas rumgespielt und jetzt funktioniert es :D. Nur eins noch, wieso schick er jetzt 4 mails auf ein mal? Und alle die selben? :D Komisch, jetzt geht sogar 4 fach ;) na ja, probieren geht über studieren ;)

Apropos: Xampp find ich sehr gut! Klar gibts manchmal probleme mit installation, wenn man aber bisschen in forum liest sind auf fast alle probleme die lösungen zu finden :) also XAMPP TEAM - weiter so ! :)

MfG

@ddorf
ddorf
 
Posts: 2
Joined: 06. July 2004 18:14


Return to XAMPP für Linux

Who is online

Users browsing this forum: No registered users and 1 guest