Turbo für XAMPP: mod_gzip -> Wer hat Erfahrung?

Irgendwelche Probleme mit XAMPP für Linux? Dann ist hier genau der richtige Ort um nachzufragen.

Turbo für XAMPP: mod_gzip -> Wer hat Erfahrung?

Postby Carlos Devera » 04. July 2004 10:30

Liebe Freunde,

mod_gzip ist ein Modul, das Webseiten zur Auslieferung komprimiert- das spart Zeit und Transferkosten. Die Geschwindikeit bei der Auslieferung von Webseiten erhöht sich nicht selten um 200 -300% (!). So verwendet z.B. der renommierte Heise-Verlag (c't, IX, etc.) mod_gzip zur Beschleunigung seiner extrem schnellen Webseite.

Nun erstaunt es mich zum Einen, dass mod_gzip (noch?) nicht in der aktuellen XAMPP-Distribution enthalten ist (zumindest kann ich es nirgends finden).

Füge ich in die httpd.conf die Zeile

mod_gzip_on YES

ein, so meldet mir Apache beim Start, dass das Modul nicht gefunden werden kann.

Daraufhin habe ich mir auf der Seite [url](http://www.schroepl.net/projekte/mod_gz ... m#download)[/url] das ganze Installationsprozedere angesehen und strecke nun vorübergehend die Waffen, da mien KnowHow noch nicht ganz dafür ausreicht.

Frage an die Gemeinde: Hat jemand von euch mod_gzip erfolgreich im Einsatz, bzw. ist es erforderlich, dieses Modul in den (statische oder dynamische erzeugten??) XAMPP-Apache "von Entwicklerseite" einzubauen? Vielleicht sogar als ein AddOn?

Freue mich auf eure Antworten!

Herzliche Grüße,

Carlos
Carlos Devera
 
Posts: 50
Joined: 06. April 2004 18:26

Postby DJ DHG » 04. July 2004 10:58

User avatar
DJ DHG
AF Moderator
 
Posts: 2455
Joined: 27. December 2002 13:50
Location: Kiel

Postby Wiedmann » 04. July 2004 11:03

mod_gzip ist ein Modul für den Apache 1.3.x

Beim aktuellen Apachen 2.0.x, ist dafür das mitgelieferte mod_deflate zuständig.
Wiedmann
AF Moderator
 
Posts: 17106
Joined: 01. February 2004 12:38
Location: Stuttgart / Germany

Postby Carlos Devera » 04. July 2004 11:05

Moin Moin Dieter,

ein sehr guter Bericht- Danke für den Link. Allerdings bleiben meine Fragen bestehen, da die XAMPP-Integration von der darin beschriebenen Vorgehensweise sicherlich abweicht.

Herzliche Grüße,

Carlos
Carlos Devera
 
Posts: 50
Joined: 06. April 2004 18:26

Postby Carlos Devera » 04. July 2004 17:45

Hallo,

Danke für die mod_deflate Info für Apache 2.

Frage: Wie kann ich testen, ob mod_deflate auch korrekt arbeitet?

Herzliche Grüße,

Carlos
Carlos Devera
 
Posts: 50
Joined: 06. April 2004 18:26

Postby Wiedmann » 04. July 2004 19:31

Frage: Wie kann ich testen, ob mod_deflate auch korrekt arbeitet?

httpd.conf
Code: Select all
DeflateFilterNote Input instream
DeflateFilterNote Output outstream
DeflateFilterNote Ratio ratio
LogFormat '"%r" %{outstream}n/%{instream}n (%{ratio}n%%)' deflate
CustomLog logs/deflate.log deflate

z.B.
Wiedmann
AF Moderator
 
Posts: 17106
Joined: 01. February 2004 12:38
Location: Stuttgart / Germany

Postby Carlos Devera » 04. July 2004 20:37

Hallo,

Danke für den Tipp!

Ich habe mir daraufhin das deflate.log einmal angesehen, und bekomme folgende Einträge (Auszug):


deflate.log
"GET /medianet_icon.gif HTTP/1.1" -/- (-%)
"GET /prefs_error_log_form HTTP/1.1" 7322/50242 (14%)
"GET /ploneNS4.css HTTP/1.1" -/- (-%)
"GET /cpsskins_css/common.css HTTP/1.1" -/- (-%)
"GET /cpsskins_css/common-css2.css HTTP/1.1" -/- (-%)
"GET /plone_javascripts.js HTTP/1.1" -/- (-%)
"GET /site_icon.gif HTTP/1.1" -/- (-%)
"GET /search_icon.gif HTTP/1.1" -/- (-%)
"GET /folder_icon.gif HTTP/1.1" -/- (-%)
"GET /newsitem_icon.gif HTTP/1.1" -/- (-%)
"GET /linkTransparent.gif HTTP/1.1" -/- (-%)
"GET /linkOpaque.gif HTTP/1.1" -/- (-%)
"GET /arrowUp.gif HTTP/1.1" -/- (-%)
"GET /plone_control_panel HTTP/1.1" 7149/51028 (14%)
"GET /cpsskins_css/common.css HTTP/1.1" -/- (-%)
"GET /ploneNS4.css HTTP/1.1" -/- (-%)
"GET /cpsskins_css/common-css2.css HTTP/1.1" -/- (-%)
"GET /plone_javascripts.js HTTP/1.1" -/- (-%)
"GET /site_icon.gif HTTP/1.1" -/- (-%)
"GET /folder_icon.gif HTTP/1.1" -/- (-%)
"GET /search_icon.gif HTTP/1.1" -/- (-%)
"GET /newsitem_icon.gif HTTP/1.1" -/- (-%)
"GET /mail_icon.gif HTTP/1.1" -/- (-%)
"GET / HTTP/1.1" 7823/53707 (14%)
"GET /ploneNS4.css HTTP/1.1" -/- (-%)
"GET /cpsskins_css/common.css HTTP/1.1" -/- (-%)
"GET /cpsskins_css/common-css2.css HTTP/1.1" -/- (-%)
"GET /plone_javascripts.js HTTP/1.1" -/- (-%)
"GET /site_icon.gif HTTP/1.1" -/- (-%)
"GET /folder_icon.gif HTTP/1.1" -/- (-%)
"GET /newsitem_icon.gif HTTP/1.1" -/- (-%)
"GET /search_icon.gif HTTP/1.1" -/- (-%)
"GET /mail_icon.gif HTTP/1.1" -/- (-%)
"GET /print_icon.gif HTTP/1.1" -/- (-%)
"GET /banner/ HTTP/1.1" 6925/51500 (13%)
"GET /cpsskins_css/common.css HTTP/1.1" -/- (-%)
"GET /ploneNS4.css HTTP/1.1" -/- (-%)
"GET /cpsskins_css/common-css2.css HTTP/1.1" -/- (-%)
"GET /plone_javascripts.js HTTP/1.1" -/- (-%)
"GET /site_icon.gif HTTP/1.1" -/- (-%)
"GET /search_icon.gif HTTP/1.1" -/- (-%)
"GET /folder_icon.gif HTTP/1.1" -/- (-%)
"GET /newsitem_icon.gif HTTP/1.1" -/- (-%)
"GET /banner/messmerreisen/view HTTP/1.1" 7329/52881 (13%)
"GET /cpsskins_css/common.css HTTP/1.1" -/- (-%)
"GET /ploneNS4.css HTTP/1.1" -/- (-%)
"GET /cpsskins_css/common-css2.css HTTP/1.1" -/- (-%)
"GET /plone_javascripts.js HTTP/1.1" -/- (-%)
"GET /site_icon.gif HTTP/1.1" -/- (-%)
"GET /folder_icon.gif HTTP/1.1" -/- (-%)
"GET /search_icon.gif HTTP/1.1" -/- (-%)
"GET /mail_icon.gif HTTP/1.1" -/- (-%)
"GET /newsitem_icon.gif HTTP/1.1" -/- (-%)
"GET /print_icon.gif HTTP/1.1" -/- (-%)
"GET /banner/messmerreisen/image_view_fullscreen HTTP/1.1" 472/895 (52%)


Und das ist meine Konfiguration:

httpd.conf
(...)
<IfModule mod_proxy.c>
ProxyVia On

# prevent the webserver from beeing used as proxy
<LocationMatch "^[^/]">
Deny from all
</LocationMatch>
</IfModule>

# caching (disabled)
# this caches every file with the correct caching informations starting at /
<IfModule mod_disk_cache.c>
CacheEnable disk /
</IfModule>

# compression (disabled)
<IfModule mod_deflate.c>
SetOutputFilter DEFLATE
</IfModule>

<IfModule mod_deflate.c>
DeflateCompressionLevel 3

DeflateFilterNote Input instream
DeflateFilterNote Output outstream
DeflateFilterNote Ratio ratio

LogFormat '"%r" %{outstream}n/%{instream}n (%{ratio}n%%)' deflate
CustomLog /opt/lampp/logs/deflate.log deflate

# Netscape 4.x has some problems...
BrowserMatch ^Mozilla/4 gzip-only-text/html

# Netscape 4.06-4.08 have some more problems
BrowserMatch ^Mozilla/4\.0[678] no-gzip

# MSIE masquerades as Netscape, but it is fine
#BrowserMatch \bMSIE !no-gzip !gzip-only-text/html

# NOTE: Due to a bug in mod_setenvif up to Apache 2.0.48
# the above regex won't work. You can use the following
# workaround to get the desired effect:
BrowserMatch \bMSI[E] !no-gzip !gzip-only-text/html

# Don't compress images, java scripts and style sheets
SetEnvIfNoCase Request_URI \
\.(?:gif|jpe?g|png|js|css)$ no-gzip dont-vary

# Make sure proxies don't deliver the wrong content
# this needs mod_headers but it's very important
# so I don't add a IfModule around it
Header append Vary User-Agent env=!dont-vary

</IfModule>
(...)

Ich würde mich über Deine Meinung hierzu freuen.

Herzliche Grüße,

Carlos
Carlos Devera
 
Posts: 50
Joined: 06. April 2004 18:26


Return to XAMPP für Linux

Who is online

Users browsing this forum: No registered users and 3 guests