[Portforwarding] Im Netzwerk gehts, aber im Internet? :|

Irgendwelche Probleme mit XAMPP für Linux? Dann ist hier genau der richtige Ort um nachzufragen.

[Portforwarding] Im Netzwerk gehts, aber im Internet? :|

Postby fgli » 27. June 2004 14:19

Hallo.
Ich habe auf dem Server (feste IP: 192.168.0.50) XAMPP laufen. Wenn ich von einem Windows Rechner (dyn. IP: 192.168.0.4) im Netzwerk draufgehe, geht alles perfekt.
Wenn ich aber per Portforwarding von aussen zugreifen will, findet er den Server nicht. Port 80 ist im Router (IP: 192.168.0.1) durchgelassen.
Das komische ist aber: wenn ich auf dem Windows-Rechner XAMPP starte und die IP im Router eintrage, funzt alles perfekt.
Woran koennte das liegen? Server Linux ist SuSE 9.0 mit XAMPP 1.4.5.
Danke schonmal

edit: mir ist gerade aufgefallen, das der Server generell nicht ins Internet kommt. YaST Online-Update geht nicht. Habe grade Router-IP als Gateway eingestellt, geht trotzdem nicht. Warum? Kenne mich mit SuSE nicht so aus :(
fgli
 
Posts: 2
Joined: 27. June 2004 14:13

Postby DJ DHG » 27. June 2004 23:01

User avatar
DJ DHG
AF Moderator
 
Posts: 2455
Joined: 27. December 2002 13:50
Location: Kiel

Re: [Portforwarding] Im Netzwerk gehts, aber im Internet? :|

Postby Kristian Marcroft » 28. June 2004 14:34

fgli wrote:edit: mir ist gerade aufgefallen, das der Server generell nicht ins Internet kommt. YaST Online-Update geht nicht. Habe grade Router-IP als Gateway eingestellt, geht trotzdem nicht. Warum? Kenne mich mit SuSE nicht so aus :(

Hey,

mach mal ein "ifconfig"
Wird dir da eine richtig konfigurierte eth0 Schnittstelle angezeigt?
Wenn ja, kannst du ins Netzwerk pingen?
Wenn ja, kannst du ins inet pingen? ggf. auf IP ebene?

Testen und berichten :)

So long
KriS
User avatar
Kristian Marcroft
AF Moderator
 
Posts: 2962
Joined: 03. January 2003 12:08
Location: Diedorf

Re: [Portforwarding] Im Netzwerk gehts, aber im Internet? :|

Postby fgli » 28. June 2004 15:18

zu antwort 1: schon klar, habe das von einem freund testen lassen.

KriS wrote:Hey,

mach mal ein "ifconfig"
Wird dir da eine richtig konfigurierte eth0 Schnittstelle angezeigt?
Wenn ja, kannst du ins Netzwerk pingen?
Wenn ja, kannst du ins inet pingen? ggf. auf IP ebene?

Testen und berichten :)

So long
KriS


bei ifconfig ist alles ok. ping zum router geht auch. netzwerk zugriff von anderen rechnern aus auch. ping (auch auf ip ebene) ins inet geht nicht.
danke
fgli
 
Posts: 2
Joined: 27. June 2004 14:13


Return to XAMPP für Linux

Who is online

Users browsing this forum: No registered users and 3 guests