Fehler beim Starten von Lampp unter RedHat 8.1

Irgendwelche Probleme mit XAMPP für Linux? Dann ist hier genau der richtige Ort um nachzufragen.

Fehler beim Starten von Lampp unter RedHat 8.1

Postby andreas49124 » 21. March 2003 13:53

hallo,

also, zunächst mal: Ich bin ein absoluter Linux-Neuling :)
Ich habe mir den LAMPP von apachefriends.org heruntergeladen und ihn in das Verzeichniss /opt/lampp/ entpackt.

Wenn ich nun auf der Konsole /opt/lampp/lampp start eingebe erhalte ich folgende Fehlermeldung.


[root@RedHat root]# /opt/lampp/lampp start
Starte LAMPP 0.9.8...
LAMPP: Starte Apache mit SSL...
LAMPP: Fehler 1 beim Starten vom Apache!
LAMPP: Starte MySQL...
LAMPP: Starte ProFTPD...
RedHat - Fatal: unable to determine IP address of 'RedHat'.
LAMPP: Fehler 1 beim Starten von ProFTPD!
LAMPP gestartet.


Wenn ich nun auf http://localhost gehe passiert nix; Netsacpe sagt 404 :(
Was mache ich falsch, oder was muss ich anstellen, damit es klappt.

Also, wie gesagt, ich nutze RedHat Linux 8.1 mit dem KDE 2.

Wenn da noch angaben fehlen, bitte sagen.

Vielen Dank schon im vorraus für Eure Hilfe,
Andreas
andreas49124
 

Postby Oswald » 21. March 2003 15:46

Hallo Andreas!

Trag bitte mal folgendes in Deine /etc/hosts ein:

127.0.0.1 redhat

(einfach ans Ende der Datei hängen)

Wenn es danach immer noch ein "Fehler 1" gibt, dann schau bitte mal in die LAMPP FAQ: http://www.apachefriends.org/faq-lampp.html

Viel Erfolg + Gruß,
Oswald ;)
User avatar
Oswald
Apache Friends
 
Posts: 2718
Joined: 26. December 2002 19:51
Location: Berlin, Germany
Operating System: Linux

Postby andreas49124 » 22. March 2003 16:18

Super, Danke!!!

Habe das Ding nun am Laufen, klappt auch super, aber wenn ich jetzt auf meine IP gehe (nicht die interne, sondern auf die "echte", aslo 212........) kommt nix.

Jetzt habe ich schon überlegt, ob es daran liegt, dass ich an einem Router bin (also mehr dahinter :-) ), aber ich habe den Port 80 bereits weitergeleitet.

Gibt es also noch ne Art Firewall oder so? Was muss ich da machen?

Ich bin ein absoluter Linux Neuling, es wäre super, wenn Ihr mir das ganze also relativ kleinschrittig erklären könntet :)

andy

PS: ach ja: Es macht schon Sinn, wenn ich noch sage, dass ich RedHat Linux 8.1 und KDE 2 benutze.
andreas49124
 

Postby Pc-dummy » 24. March 2003 00:19

Hi

Wenn du Bei der Installation von Redhat Sicherheitslevel Hoch angegeben hast und die option webserver nicht angeklickt hast gibt es probleme mit der Firewall..

tip mal in die console /etc/init.d/iptables stop und probier dann nochmal auf dein webseite zuzugreifen wenn es jetzt funktioniert dann liegt es an der firewall. WICHTIG auch wenn es jetzt funzt solltest du dir deine Firewall neukonfigurieren und wieder einschalten

Konfigureiren kannst se indem du im kde startmenü nach Sicherheitslevel suchst (Weis leider net genau wo das is :oops:) und dort den anweisungen folgst

sollte es dann immer noch nicht funktionieren liegt es sicher nicht an der Firewall vom Server und
du solltest deine Firewall mit /etc/init.d/iptables start wieder einschalten.

MFG
Pc-Dummy
--
a 13 year old Newbie
Pc-dummy
AF Moderator
 
Posts: 784
Joined: 29. December 2002 01:46
Location: AT-Vorarlberg-Feldkirch

Postby andreas49124 » 24. March 2003 15:51

hallo,

das verzeichnis /etc/init.d/iptables gibt es bei mir nicht!

Andreas49124
andreas49124
 

Postby Pc-dummy » 24. March 2003 17:44

das soll auch nicht ein verzeichnis sein!

das ist eine datei /etc/init.d/iptables stop ist der befehl unter Redhat 8.0 die Firewall zu stoppen

MFG

Pc-Dummy
--
a 13 year old Newbie
Pc-dummy
AF Moderator
 
Posts: 784
Joined: 29. December 2002 01:46
Location: AT-Vorarlberg-Feldkirch

Postby acid_tracer » 26. March 2003 22:30

hi

wobei ich hier auch die linuxconf für alle redhat systeme empfehlen kann,
dort kann man supi einfach die firewall konfigurieren und oder wenn nötig runterfahren.

andere sache wäre dann: ist es dir generell möglich eine verbindung als schleife herzustellen?

deine normale onlineconnection geht raus und die gleiche soll wieder auf deinen router zugreifen?

ich habe das mit ftp versucht und es geht nicht.. wenn du es hinbekommst --> mail an mich

cu
the acid_tracer

go on your way - thats the right
User avatar
acid_tracer
 
Posts: 20
Joined: 25. March 2003 23:23


Return to XAMPP für Linux

Who is online

Users browsing this forum: No registered users and 2 guests