SSL spielt verrückt

Irgendwelche Probleme mit XAMPP für Linux? Dann ist hier genau der richtige Ort um nachzufragen.

SSL spielt verrückt

Postby achim » 21. May 2004 10:13

Hallo, Apachefriends!

Ich habe auf meinem Webserver mehrere viruelle Domains jeweils in einem Unterverzeichnis von /opt/lampp/www/

Die httpd.conf hat einen entsprechenden Eintrag, der folgendermaßen aussieht:

<VirtualHost w.x.y.z:80>
ServerName www.myDomain.de
DocumentRoot /opt/lampp/htdocs/www/myDomain.de/
</VirtualHost>

(IP-Adr. und Domainname wurde geändert!)

Jedesmal, wenn ich diese Domain wie folgt mit SSL-Funktionalität aufrufe: https://www.MyDomain.de, dann wird eine SSL-Authetifizierungsdialog-Box geöffnet.Wenn ich dann die geforderten Passwörter eingebe, dann lande ich in der Verwaltungsdemo von XAMPP.

Je nach verwendetem Browser kommt auch die Meldung: Could not connect to host ...

Das ist doch nicht normal, oder? Meine Besucher haben deswegen keinen Zugang via SSL!

Gebe ich statt dessen einfach die URL ohne SSL-Anforderung ein, wird die Website normal und ohne Probleme gestartet.

Muss ich noch irgenwo eintragen, dass der virtuelle Host auch auf SSL horchen soll, vielleicht indem ich die Zeile
<VirtualHost w.x.y.z:80> durch
<VirtualHost w.x.y.z:443> ersetze?

Habe ich versucht, aber dann startet Apache nicht. Wer kann mir bitte einen Tipp geben wie ich das Problem lösen kann?

Vielen Dank!

Gruss, Achim
achim
 
Posts: 85
Joined: 27. March 2004 08:48
Location: Berlin

Return to XAMPP für Linux

Who is online

Users browsing this forum: No registered users and 3 guests