xampp 1.4.4 + php-4.3.6

Irgendwelche Probleme mit XAMPP für Linux? Dann ist hier genau der richtige Ort um nachzufragen.

xampp 1.4.4 + php-4.3.6

Postby cmichl » 22. April 2004 15:55

Hi,

ich möchte php-4.3.6 kompilieren und habe dazu xampp-linux-1.4.4 und xampp-linux-devel-1.4.4 installiert. Beim PHP-configure kommen die Parameter aus dem php-4.3.5 xampp Paket zum Einsatz (env ORACLE_HOME="/opt/oracle/OraHome1" CFLAGS="-O6 -I$ORACLE_HOME/network/public -I/opt/lampp/include/libpng -I/opt/lampp/include/ncurses -I/opt/lampp/include -L/opt/lampp/lib" ./configure --prefix=/opt/lampp ...)

Kann es nun sein, das im Devel-Paket die bzib2 lib fehlt (hab ich nachinstalliert) -OK? With-oci8 und with-interbase hab ich gelassen (OK - meine env-Aufruf hätte ich anpassen können).

Leider musste ich imap weglassen da sonst Fehler im ./configure auftraten (SSL irgendwas), was nun auch nicht geht ist ein make "/usr/local/src/php-4.3.6/ext/gd/libgd/gdft.c: In function `fontFetch': und weitere".
Gibt es nun für beide letztgenannten Probleme eine Lösung und ist das devel Paket auf dem neusten Stand?

Ich bin für jeden Tip dankbar....
Chris
cmichl
 
Posts: 2
Joined: 22. April 2004 15:39

Postby Kristian Marcroft » 22. April 2004 17:34

Hi,

genau das gleiche Prob hatte ich vor 2 Tagen auch...

Lösung:
Du musst dir die aktuelle FreeType Version 2.1.7 nach /opt/lampp installieren.

Sprich du brauchst die Sourcen, musst diese compilen und nach /opt/lampp installen. Dann kannst auch php 4.3.6 kompilen.

So long
KriS
User avatar
Kristian Marcroft
AF Moderator
 
Posts: 2962
Joined: 03. January 2003 12:08
Location: Diedorf


Return to XAMPP für Linux

Who is online

Users browsing this forum: No registered users and 4 guests