MySQL datenbank im ar*** - hilfe!

Irgendwelche Probleme mit XAMPP für Linux? Dann ist hier genau der richtige Ort um nachzufragen.

MySQL datenbank im ar*** - hilfe!

Postby spock » 01. April 2004 08:49

Bekomme wenn ich im xampp den Phpmyadmin starten will die meldung
#2002 - Can't connect to local MySQL server through socket '/opt/lampp/var/mysql/mysql.sock' (2)


Kann auch keine Foren mehr installieren da keine Datenbank findet.

MySQL Server läuft aber....


Wer kann helfen?!?
User avatar
spock
 
Posts: 6
Joined: 25. March 2004 08:26

Postby Oswald » 01. April 2004 09:16

Huhu Spock!

Sicher, dass MySQL läuft?

Was gibt der Befehl ps -aux | egrep mysql aus? Bitte mal die Ausgabe genau hier veröffentlichen!

Liebe Grüße
Oswald
User avatar
Oswald
Apache Friends
 
Posts: 2718
Joined: 26. December 2002 19:51
Location: Berlin, Germany
Operating System: Linux

Postby Pc-dummy » 01. April 2004 12:06

@ Kai (ot)

egrep is schneller als grep?

sry, für Ot :)

MFG
Pc-Dummy
Gentoo/X86_64, AMD Athlon 64 FX-53, 1,5 GB INFINEON Ram, Audigy 2 ZS Platinum Pro, 300 GB Platten, LG-DVD Brenner
Pc-dummy
AF Moderator
 
Posts: 784
Joined: 29. December 2002 01:46
Location: AT-Vorarlberg-Feldkirch

Postby Oswald » 01. April 2004 12:47

@ Pc-dummy

egrep kann mehr und deswegen verwende ich ihn immer lieber als grep. In diesem Fall spielt das natürlich keine Rolle. Es war auch tatsächlich mal so, dass egrep schneller war als grep. Aber heute ist das nicht mehr der Fall.
User avatar
Oswald
Apache Friends
 
Posts: 2718
Joined: 26. December 2002 19:51
Location: Berlin, Germany
Operating System: Linux

Postby spock » 01. April 2004 12:52

also beim ps -aux macht er mir ne richtig lange liste mit User/Command/Startseit.

ka was ich damit anfangen soll und egrep mysql röttelt er jetz 15min run und zeigt bis jetzt nichts weiter an.

Bin nicht so der freak für sowas
Last edited by spock on 01. April 2004 13:20, edited 1 time in total.
User avatar
spock
 
Posts: 6
Joined: 25. March 2004 08:26

Postby Pc-dummy » 01. April 2004 12:56

Hallo

spock wrote:egrep mysql röttelt er jetz 15min run und zeigt bis jetzt nichts weiter an.


Du hast schon "ps aux | egrep mysql" ausgeführt?

Wenn ja poste mal die ausgabe von folgendem cmd.

Code: Select all
tail -10 /opt/lampp/var/mysql/`hostname`.err


MFG
Pc-Dummy

P.s.: Bin bei der Arbeit hab also kein linux zum die cmd´s die ich hier angeben zu testen :(
Gentoo/X86_64, AMD Athlon 64 FX-53, 1,5 GB INFINEON Ram, Audigy 2 ZS Platinum Pro, 300 GB Platten, LG-DVD Brenner
Pc-dummy
AF Moderator
 
Posts: 784
Joined: 29. December 2002 01:46
Location: AT-Vorarlberg-Feldkirch

Postby spock » 01. April 2004 13:24

bei ps aux | egrep mysql sagt er
2849 0.0 0.2 1792 568 pts 3 5 14:52 0:00 /bin/grep -E mysql


Sagt dir das was?
User avatar
spock
 
Posts: 6
Joined: 25. March 2004 08:26

Postby Pc-dummy » 01. April 2004 13:27

Ja, das mysql nicht läuft

den obigen command "tail -10 /opt/lampp/var/mysql/`hostname`.err" ausführen und ausgabe posten.
Gentoo/X86_64, AMD Athlon 64 FX-53, 1,5 GB INFINEON Ram, Audigy 2 ZS Platinum Pro, 300 GB Platten, LG-DVD Brenner
Pc-dummy
AF Moderator
 
Posts: 784
Joined: 29. December 2002 01:46
Location: AT-Vorarlberg-Feldkirch

Postby spock » 01. April 2004 13:34

040401 09:36:21 mysqld started
040401 9:36:22 Fatal error: Can't open privilege
tables: Table 'mysql.host' doesn't exist
040401 9:36:22 Aborting

040401 9:36:22 /opt/lampp/sbin/mysqld: Shutdown
Complete

040401 09:36:22 mysqld ended


Ok läuft doch nicht...
was nun?!?!?
User avatar
spock
 
Posts: 6
Joined: 25. March 2004 08:26

Postby Realmaker » 01. April 2004 15:56

Ich hab ja das gleiche Problem
tail -10 /opt/lampp/var/mysql/max.err wrote:0x40223c4c
0x80a63e1
New value of fp=(nil) failed sanity check, terminating stack trace!
Please read http://www.mysql.com/doc/en/Using_stack_trace.html and follow instructions on how to resolve the stack trace. Resolved
stack trace is much more helpful in diagnosing the problem, so please do
resolve it
The manual page at http://www.mysql.com/doc/en/Crashing.html contains
information that should help you find out what is causing the crash.
040401 07:33:22 mysqld ended
Realmaker
 
Posts: 17
Joined: 28. March 2004 23:14

Postby Oswald » 01. April 2004 16:03

Hallo spock! Hallo Realmaker!

Zunächst an spock: MySQL findet seine host-Tabelle nicht. Kannst Du mal nachschauen und ls -l /opt/lampp/var/mysql/mysql aufrufen. Was wird dann angezeigt?

Realmaker: Was für eine Linux-Distribution hast Du? Tritt der Fehler beim Starten von XAMPP auf oder im Betrieb irgendwann?

Liebe Grüße
Oswald
User avatar
Oswald
Apache Friends
 
Posts: 2718
Joined: 26. December 2002 19:51
Location: Berlin, Germany
Operating System: Linux

Postby Realmaker » 01. April 2004 16:10

Gentoo 8)
Welchen fehler meinstu du jetzt? Der -->
#2002 - Can't connect to local MySQL server through socket '/opt/lampp/var/mysql/mysql.sock' (2)
tritt immer auf wenn ich den Phpmyadmin starten möchtte oder sonst auf die Datenbank zugreifen will.
Realmaker
 
Posts: 17
Joined: 28. March 2004 23:14

Postby Oswald » 01. April 2004 16:14

Huhu Real!

Sorry, ich war unpräzise! Ich meinte den Fehler den Du zitiert hast: »New value of fp=(nil) failed sanity check, terminating stack trace!« usw.

Gentoo ist natürlich schlecht zum gegentesten da jede Gentoo-Installation ja ganz individuell ist... Hm...

Gruß
Oswald
User avatar
Oswald
Apache Friends
 
Posts: 2718
Joined: 26. December 2002 19:51
Location: Berlin, Germany
Operating System: Linux

Postby Realmaker » 01. April 2004 16:22

Der Fehler ist mir so noch nicht über den weg gelaufen, bevor ich eben den Befehl ausgeführt habe. Was kann ich denn machen um den Fehler zu beheben?
Realmaker
 
Posts: 17
Joined: 28. March 2004 23:14

Postby Oswald » 01. April 2004 16:31

Huhu Real!

Wenn das nur so einfach wäre.

Laut der Fehlermeldung passierte der Fehler am 1. April 2004 um 07:33:22 Uhr. Meine Frage zielt nun darauf die Ursache für den Fehler zu finden. Wenn Du XAMPP noch mal startest und danach den obigen Befehl (tail...) eingibst. Was wird dann angezeigt?

Grundsätzlich sieht der Fehler leider so aus, als ob er nicht so ohne weiteres zu beheben sein wird. :(

Bei spock ist das was anders. Bei ihm scheint nur eine (oder mehr) Datei zu fehlen.

Liebe Grüße
Oswald
User avatar
Oswald
Apache Friends
 
Posts: 2718
Joined: 26. December 2002 19:51
Location: Berlin, Germany
Operating System: Linux

Next

Return to XAMPP für Linux

Who is online

Users browsing this forum: No registered users and 5 guests