Welche php.ini für mod_php, CGI, CLI?

Irgendwelche Probleme mit XAMPP für Linux? Dann ist hier genau der richtige Ort um nachzufragen.

Welche php.ini für mod_php, CGI, CLI?

Postby wim » 12. March 2003 19:43

Hallo Leute,

welche php.ini gehört zu mod_php, zum CGI bzw. zum CLI ??

./etc/php.ini
./local/etc/php.ini
./local/lib/php.ini

cu
-wim-
User avatar
wim
 
Posts: 8
Joined: 25. February 2003 14:55

Postby Oswald » 12. March 2003 19:50

Ahoi wim!

Beim LAMPP ist es die /opt/lampp/etc/php.ini.

Lieben Gruß,
Oswald

PS: Egal ob mod_php, CGI oder CLI.
User avatar
Oswald
Apache Friends
 
Posts: 2718
Joined: 26. December 2002 19:51
Location: Berlin, Germany
Operating System: Linux

Postby wim » 12. March 2003 19:53

Wozu dienen die anderen php.ini Dateien?
User avatar
wim
 
Posts: 8
Joined: 25. February 2003 14:55

Postby Oswald » 12. March 2003 19:57

Ich weiss ja nicht wo Du genau gesucht hast, aber beim LAMPP gibt es nur (diese) eine php.ini. Das local-Verzeichnis, das bei Dir in der Ausgabe erscheint, gibt es im LAMPP nicht.
User avatar
Oswald
Apache Friends
 
Posts: 2718
Joined: 26. December 2002 19:51
Location: Berlin, Germany
Operating System: Linux

Postby wim » 12. March 2003 20:05

Ich habe hier den lampp 0.9.8, von 0.9.7 upgedatet.
Die 0.9.7 war direkt installiert worden.

Die gezeigten php.ini Dateien befinden sich unter /opt/lampp.
User avatar
wim
 
Posts: 8
Joined: 25. February 2003 14:55

Postby Oswald » 12. March 2003 20:37

Hups.. das ist dann aber wirklich seltsam. Bist Du Dir sicher, dass Du die nicht irgendwie erstellt hast? Ich hab jetzt mal im 0.9.7 und 0.9.8 nachgeguckt und da gibt es diese Dateien nicht.

Alleine schon das "local" kommt mir total fremd vor und auch "lib/php.ini". Auf sowas würd ich im Leben nie kommen. Hmm..

Nunja. Jedenfalls die etc/php.ini ist es auf alle Fälle.

Trotzdem danke für die Frage, werd jetzt mal die Augen auf halten, vielleicht kommt das "local" ja doch irgendwo aus LAMPP her...

Liebe Grüße,
Oswald ;)
User avatar
Oswald
Apache Friends
 
Posts: 2718
Joined: 26. December 2002 19:51
Location: Berlin, Germany
Operating System: Linux

Postby wim » 17. March 2003 10:39

Hallo,

vielen Dank für die Hilfe, ich habe inzwischen den wirklichen Fehler für die zusätzlichen php.ini's gefunden.

cu
-wim-
User avatar
wim
 
Posts: 8
Joined: 25. February 2003 14:55


Return to XAMPP für Linux

Who is online

Users browsing this forum: No registered users and 3 guests