HLStats mit LAMPP

Irgendwelche Probleme mit XAMPP für Linux? Dann ist hier genau der richtige Ort um nachzufragen.

HLStats mit LAMPP

Postby Guest » 10. March 2003 18:00

Ich bin mir nicht ganz sicher, ob ich hier in dem richtigen Thread gelandet bin - aber ich versuchs halt einfach mal

Also, ich möchte gerne auf meinem redhat 7.2 für Counter-Strike 1.5 HLStats installieren. Alle infos könnt ihr euch unter http://www.hlstats.org ansehen! Hier gehts direkt zur readme:
http://www.hlstats.org/help.php/INSTALL.html

Als apache, php, mysql server verwende ich lampp von http://www.apachefriends.org - ich kann mir sehr gut vorstellen, dass der fehler irgendwie daran liegt

Das DBI-Perl Module von RH hab ich auch installiert (wuerde das aber gerne mal testen!)

Wenn ich dann hlstat starte mit dem befehl "./hlstats.pl" kommt folgender fehler:



quote:
--------------------------------------------------------------------------------
[root@Web-Server hlstats]# ./hlstats.pl
++ HLstats 1.02 starting...

-- Opening UDP listen socket on port 27500 ... opened OK
-- Connecting to MySQL database 'hlstats' on 'localhost' as user 'root' ... install_driver(mysql) failed: Can't locate DBD/mysql.pm in @INC (@INC contains: /usr/lib/perl5/5.6.0/i386-linux /usr/lib/perl5/5.6.0 /usr/lib/perl5/site_perl/5.6.0/i386-linux /usr/lib/perl5/site_perl/5.6.0 /usr/lib/perl5/site_perl .) at (eval 6) line 3.
Perhaps the DBD::mysql perl module hasn't been fully installed,
or perhaps the capitalisation of 'mysql' isn't right.
Available drivers: ADO, ExampleP, Multiplex, Proxy.
at ./hlstats.pl line 924
--------------------------------------------------------------------------------




irgendwas stimmt da nicht. wenn irgendjemand ne idee haette, was ich da nu machen kann, waere das super!
MfG
MiG
Guest
 

Postby Oswald » 10. March 2003 18:12

Hallo MiG!

Danke für den Link zur Anleitung. Da steht auch drin, was das Problem ist: Du benötigst noch für's Perl eine Erweiterung.

Ich kann's jetzt nicht selbst ausprobieren, aber eigentlich ist das Nachinstallieren von solchen Perl-Erweiterungen immer recht einfach. Mach bitte folgendes:

1. Aufrufen: /opt/lampp/bin/perl -MCPAN -e shell
2. Nun sollte ein Prompt "cpan>" erscheinen.
3. Jetzt install DBD::mysql eintippen.
4. Warten.
5. Eigentlich sollten keine Fehlermeldungen auftreten.
6. quit eintippen.

Und nun kannst Du es noch mal mit HLStats probieren.

Viele Erfolg,
Oswald ;)
Last edited by Oswald on 10. March 2003 18:34, edited 1 time in total.
User avatar
Oswald
Apache Friends
 
Posts: 2718
Joined: 26. December 2002 19:51
Location: Berlin, Germany
Operating System: Linux

Postby MiG » 10. March 2003 18:33

danke erstmal für die schnelle antwort!
Leider tritt immernoch folgender fehler auf :(

Code: Select all
CPAN.pm: Going to build J/JW/JWIED/DBD-mysql-2.1026.tar.gz

Can't exec "mysql_config": Datei oder Verzeichnis nicht gefunden at Makefile.PL line 169.
readline() on closed filehandle PIPE at Makefile.PL line 171.
Can't exec "mysql_config": Datei oder Verzeichnis nicht gefunden at Makefile.PL line 169.
readline() on closed filehandle PIPE at Makefile.PL line 171.
Can't exec "mysql_config": Datei oder Verzeichnis nicht gefunden at Makefile.PL line 169.
readline() on closed filehandle PIPE at Makefile.PL line 171.
Can't exec "mysql_config": Datei oder Verzeichnis nicht gefunden at Makefile.PL line 169.
readline() on closed filehandle PIPE at Makefile.PL line 171.
Can't exec "mysql_config": Datei oder Verzeichnis nicht gefunden at Makefile.PL line 169.
readline() on closed filehandle PIPE at Makefile.PL line 171.
Failed to determine directory of mysql.h. Use

  perl Makefile.PL --cflags=-I<dir>

to set this directory. For details see the INSTALL.html file,
section "C Compiler flags" or type

  perl Makefile.PL --help
Running make test
  Make had some problems, maybe interrupted? Won't test
Running make install
  Make had some problems, maybe interrupted? Won't install

cpan>
MiG
 

Postby Oswald » 10. March 2003 18:36

Ahh.. okay..

Probier mal folgendes: env PATH=/opt/lampp/bin:$PATH /opt/lampp/bin/perl -MCPAN -e shell und dann das install DBD::mysql

Weiterhin viel Erfolg,
Oswald ;)
User avatar
Oswald
Apache Friends
 
Posts: 2718
Joined: 26. December 2002 19:51
Location: Berlin, Germany
Operating System: Linux

Postby MiG » 10. March 2003 18:40

irgendwie is das leicht verwirrend :(

nun meint er folgendes:
Code: Select all
CPAN.pm: Going to build J/JW/JWIED/DBD-mysql-2.1026.tar.gz

I will use the following settings for compiling and testing:

  cflags        (mysql_config) = -I'/opt/lampp/include/mysql'
  libs          (mysql_config) = -L/opt/lampp/lib/mysql -lmysqlclient -lz -lcrypt -lnsl -lm
  nocatchstderr (default     ) = 0
  ssl           (guessed     ) = 0
  testdb        (default     ) = test
  testhost      (default     ) =
  testpassword  (default     ) =
  testuser      (default     ) =

To change these settings, see 'perl Makefile.PL --help' and
'perldoc INSTALL'.

Checking if your kit is complete...
Looks good
Using DBI 1.32 installed in /opt/lampp/lib/perl5/site_perl/5.8.0/i686-linux/auto/DBI
Writing Makefile for DBD::mysql
cp lib/DBD/mysql.pm blib/lib/DBD/mysql.pm
cp lib/DBD/mysql/INSTALL.pod blib/lib/DBD/mysql/INSTALL.pod
cp lib/Mysql.pm blib/lib/Mysql.pm
cp lib/Mysql/Statement.pm blib/lib/Mysql/Statement.pm
cp lib/DBD/mysql.pod blib/lib/DBD/mysql.pod
cp lib/Bundle/DBD/mysql.pm blib/lib/Bundle/DBD/mysql.pm
cc -c  -I/opt/lampp/lib/perl5/site_perl/5.8.0/i686-linux/auto/DBI -I'/opt/lampp/include/mysql' -fno-strict-aliasing -I/opt/lampp/include -D_LARGEFILE_SOURCE -D_FILE_OFFSET_BITS=64 -O3   -DVERSION=\"2.1026\" -DXS_VERSION=\"2.1026\" -fpic "-I/opt/lampp/lib/perl5/5.8.0/i686-linux/CORE"   dbdimp.c
/bin/sh: cc: command not found
make: *** [dbdimp.o] Fehler 127
  /usr/bin/make  -- NOT OK
Running make test
  Can't test without successful make
Running make install
  make had returned bad status, install seems impossible

cpan>


sieht recht erfolgreich aus, find ich doch... aber er sagt jetzt bei hlstats leider immernoch:

Code: Select all
[root@Web-Server hlstats]# ./hlstats.pl
++ HLstats 1.02 starting...

-- Opening UDP listen socket on port 27500 ... opened OK
-- Connecting to MySQL database 'hlstats' on 'localhost' as user '' ... install_driver(mysql) failed: Can't locate DBD/mysql.pm in @INC (@INC contains: /usr/lib/perl5/5.6.0/i386-linux /usr/lib/perl5/5.6.0 /usr/lib/perl5/site_perl/5.6.0/i386-linux /usr/lib/perl5/site_perl/5.6.0 /usr/lib/perl5/site_perl .) at (eval 6) line 3.
Perhaps the DBD::mysql perl module hasn't been fully installed,
or perhaps the capitalisation of 'mysql' isn't right.
Available drivers: ADO, ExampleP, Multiplex, Proxy.
 at ./hlstats.pl line 924
[root@Web-Server hlstats]#
MiG
 

Postby Oswald » 10. March 2003 18:44

Huhu MiG!

Okay, es sieht besser aus. Das was aber noch nicht gut aussieht ist folgende Meldung:

Code: Select all
/bin/sh: cc: command not found


D. h. Du musst auf alle Fälle bei Dir noch gcc installieren. Sollte aber in jeder Linux-Distribution dabei sein.

Dann kann ich mir schon denken, das es dann beim nächsten Versuch eine weitere Meldung gibt. Nämlich dass er mysql.h nicht findet. Wenn das auch noch kommt, dann musst Du noch das LAMPP-Entwicklungs-Paket nachinstallieren. (Findest Du auf der LAMPP-Seite, dort wo Du auch LAMPP heruntergeladen hast.)

Ich bin ab 19 Uhr erst mal nicht mehr online. Erst Morgen ab 10 wieder.

Mit lieben Gruß,
Oswald
User avatar
Oswald
Apache Friends
 
Posts: 2718
Joined: 26. December 2002 19:51
Location: Berlin, Germany
Operating System: Linux

Postby Guest » 10. March 2003 18:46

hm... ja ok. vielen dank schonmal...

ich werds weiter versuchen. vielleicht kommst du ja auch mal zur moeglichkeit das hlstats zu testen ;)

gcc werd ich dann mal installieren

und dankeschoen nochmal!
Guest
 

Postby MiG » 11. March 2003 16:24

Ich hab nun mal gcc und alle perl-optionen, die ich bei der redhat installation gefunden habe, installiert!

nun scheit DBI zu funktionieren... allerdings tritt ein anderer fehler auf, wenn ich hlstats.pl starten will :(
Code: Select all
++ HLstats 1.02 starting...

-- Opening UDP listen socket on port 27500 ... opened OK
-- Connecting to MySQL database 'hlstats' on 'localhost' as user 'root' ... DBI->connect(hlstats:localhost) failed: Can't connect to local MySQL server through socket '/var/lib/mysql/mysql.sock' (2) at ./hlstats.pl line 924

Can't connect to MySQL database 'hlstats' on 'localhost'
Server error: Can't connect to local MySQL server through socket '/var/lib/mysql/mysql.sock' (2)


eigentlich muesste ich ja nur den pfad '/var/lib/mysql/mysql.sock' mit '/opt/lampp/var/mysql/mysql.sock' austauschen. Aber ich weiss nicht wo. in hlstats.pl gibt es den parameter nicht :(
MiG
 

Postby MiG » 11. March 2003 17:11

nun hab ich jetzt auch nochmal das gemacht, was du mir gesagt hattest...


jetzt kommt das dabei raus:
Code: Select all
CPAN.pm: Going to build J/JW/JWIED/DBD-mysql-2.1026.tar.gz

I will use the following settings for compiling and testing:

  cflags        (mysql_config) = -I'/opt/lampp/include/mysql'
  libs          (mysql_config) = -L/opt/lampp/lib/mysql -lmysqlclient -lz -lcrypt -lnsl -lm
  nocatchstderr (default     ) = 0
  ssl           (guessed     ) = 0
  testdb        (default     ) = test
  testhost      (default     ) =
  testpassword  (default     ) =
  testuser      (default     ) =

To change these settings, see 'perl Makefile.PL --help' and
'perldoc INSTALL'.

Checking if your kit is complete...
Looks good
Using DBI 1.32 installed in /opt/lampp/lib/perl5/site_perl/5.8.0/i686-linux/auto/DBI
Writing Makefile for DBD::mysql
cp lib/DBD/mysql.pm blib/lib/DBD/mysql.pm
cp lib/DBD/mysql/INSTALL.pod blib/lib/DBD/mysql/INSTALL.pod
cp lib/Mysql.pm blib/lib/Mysql.pm
cp lib/Mysql/Statement.pm blib/lib/Mysql/Statement.pm
cp lib/DBD/mysql.pod blib/lib/DBD/mysql.pod
cp lib/Bundle/DBD/mysql.pm blib/lib/Bundle/DBD/mysql.pm
cc -c  -I/opt/lampp/lib/perl5/site_perl/5.8.0/i686-linux/auto/DBI -I'/opt/lampp/include/mysql' -fno-strict-aliasing -I/opt/lampp/include -D_LARGEFILE_SOURCE -D_FILE_OFFSET_BITS=64 -O3   -DVERSION=\"2.1026\" -DXS_VERSION=\"2.1026\" -fpic "-I/opt/lampp/lib/perl5/5.8.0/i686-linux/CORE"   dbdimp.c
In file included from /opt/lampp/lib/perl5/5.8.0/i686-linux/CORE/perl.h:3368,
                 from /opt/lampp/lib/perl5/site_perl/5.8.0/i686-linux/auto/DBI/DBIXS.h:19,
                 from dbdimp.h:30,
                 from dbdimp.c:29:
/opt/lampp/lib/perl5/5.8.0/i686-linux/CORE/proto.h:338: warning: `struct tm' declared inside parameter list
/opt/lampp/lib/perl5/5.8.0/i686-linux/CORE/proto.h:338: warning: its scope is only this definition or declaration, which is probably not what you want.
/opt/lampp/lib/perl5/5.8.0/i686-linux/CORE/proto.h:491: warning: `struct tm' declared inside parameter list
/opt/lampp/bin/perl -p -e "s/~DRIVER~/mysql/g" < /opt/lampp/lib/perl5/site_perl/5.8.0/i686-linux/auto/DBI/Driver.xst > mysql.xsi
/opt/lampp/bin/perl /opt/lampp/lib/perl5/5.8.0/ExtUtils/xsubpp  -typemap /opt/lampp/lib/perl5/5.8.0/ExtUtils/typemap  mysql.xs > mysql.xsc && mv mysql.xsc mysql.c
Warning: duplicate function definition 'rows' detected in mysql.xs, line 291
cc -c  -I/opt/lampp/lib/perl5/site_perl/5.8.0/i686-linux/auto/DBI -I'/opt/lampp/include/mysql' -fno-strict-aliasing -I/opt/lampp/include -D_LARGEFILE_SOURCE -D_FILE_OFFSET_BITS=64 -O3   -DVERSION=\"2.1026\" -DXS_VERSION=\"2.1026\" -fpic "-I/opt/lampp/lib/perl5/5.8.0/i686-linux/CORE"   mysql.c
In file included from /opt/lampp/lib/perl5/5.8.0/i686-linux/CORE/perl.h:3368,
                 from /opt/lampp/lib/perl5/site_perl/5.8.0/i686-linux/auto/DBI/DBIXS.h:19,
                 from dbdimp.h:30,
                 from mysql.xs:15:
/opt/lampp/lib/perl5/5.8.0/i686-linux/CORE/proto.h:338: warning: `struct tm' declared inside parameter list
/opt/lampp/lib/perl5/5.8.0/i686-linux/CORE/proto.h:338: warning: its scope is only this definition or declaration, which is probably not what you want.
/opt/lampp/lib/perl5/5.8.0/i686-linux/CORE/proto.h:491: warning: `struct tm' declared inside parameter list
Running Mkbootstrap for DBD::mysql ()
chmod 644 mysql.bs
rm -f blib/arch/auto/DBD/mysql/mysql.so
LD_RUN_PATH="/opt/lampp/lib/mysql:/opt/lampp/lib:/lib" /opt/lampp/bin/perl myld cc  -shared -L/opt/lampp/lib dbdimp.o mysql.o  -o blib/arch/auto/DBD/mysql/mysql.so   -L/opt/lampp/lib/mysql -lmysqlclient -lz -lcrypt -lnsl -lm
chmod 755 blib/arch/auto/DBD/mysql/mysql.so
cp mysql.bs blib/arch/auto/DBD/mysql/mysql.bs
chmod 644 blib/arch/auto/DBD/mysql/mysql.bs
Manifying blib/man3/Mysql.3
Manifying blib/man3/DBD::mysql::INSTALL.3
Manifying blib/man3/DBD::mysql.3
Manifying blib/man3/Bundle::DBD::mysql.3
  /usr/bin/make  -- OK
Running make test
PERL_DL_NONLAZY=1 /opt/lampp/bin/perl "-MExtUtils::Command::MM" "-e" "test_harness(0, 'blib/lib', 'blib/arch')" t/*.t
t/00base...........ok
t/10dsnlist........ok
t/20createdrop.....ok
t/30insertfetch....ok
t/40bindparam......ok
t/40blobs..........ok
t/40listfields.....ok
t/40nulls..........ok
t/40numrows........ok
t/50chopblanks.....ok
t/50commit.........ok
        14/30 skipped: No transactions
t/60leaks..........skipped
        all skipped: no reason given
t/ak-dbd...........ok
t/akmisc...........ok
t/dbdadmin.........ok
t/insertid.........ok
t/mysql............ok
t/mysql2...........ok
All tests successful, 1 test and 14 subtests skipped.
Files=18, Tests=765, 29 wallclock secs ( 6.34 cusr +  0.50 csys =  6.84 CPU)
  /usr/bin/make test -- OK
Running make install
Installing /opt/lampp/lib/perl5/site_perl/5.8.0/i686-linux/auto/DBD/mysql/mysql.so
Installing /opt/lampp/lib/perl5/site_perl/5.8.0/i686-linux/auto/DBD/mysql/mysql.bs
Files found in blib/arch: installing files in blib/lib into architecture dependent library tree
Installing /opt/lampp/lib/perl5/site_perl/5.8.0/i686-linux/Mysql.pm
Installing /opt/lampp/lib/perl5/site_perl/5.8.0/i686-linux/Bundle/DBD/mysql.pm
Installing /opt/lampp/lib/perl5/site_perl/5.8.0/i686-linux/Mysql/Statement.pm
Installing /opt/lampp/lib/perl5/site_perl/5.8.0/i686-linux/DBD/mysql.pm
Installing /opt/lampp/lib/perl5/site_perl/5.8.0/i686-linux/DBD/mysql.pod
Installing /opt/lampp/lib/perl5/site_perl/5.8.0/i686-linux/DBD/mysql/INSTALL.pod
Installing /opt/lampp/man/man3/Mysql.3
Installing /opt/lampp/man/man3/DBD::mysql::INSTALL.3
Installing /opt/lampp/man/man3/DBD::mysql.3
Installing /opt/lampp/man/man3/Bundle::DBD::mysql.3
Writing /opt/lampp/lib/perl5/site_perl/5.8.0/i686-linux/auto/DBD/mysql/.packlist
Appending installation info to /opt/lampp/lib/perl5/5.8.0/i686-linux/perllocal.pod
  /usr/bin/make install  -- OK
MiG
 

Postby Oswald » 11. March 2003 17:28

Huhu MiG!

Hm.. durch das RedHat-Perl installieren, hast Du nun einigest durchander gebracht. Aber das ist nicht so schlimm.

Am Anfang von Deiner hlstats.pl steht bisher wahrscheinlich sowas:

#!/usr/bin/perl

mach bitte mal sowas daraus machen:

#!/opt/lampp/bin/perl

Und dann einfach noch mal probieren.

Lieben Gruß,
Oswald
User avatar
Oswald
Apache Friends
 
Posts: 2718
Joined: 26. December 2002 19:51
Location: Berlin, Germany
Operating System: Linux

Postby MiG » 11. March 2003 20:42

danke Kai!
Du bist mein held!!!

Code: Select all
[root@Web-Server hlstats-1.02]# ./hlstats.pl
++ HLstats 1.02 starting...

-- Opening UDP listen socket on port 27500 ... opened OK
-- Connecting to MySQL database 'hlstats' on 'localhost' as user '' ... connected OK

++ HLstats is now running (Normal mode, debug level 1).




Yippiii!!! :)

scheint astrein zu laufen. ich will jetzt mal am wochenende mit n paar freunden austesten ob der rest auch geht. falls nochmal fehler auftreten melde ich mich.

Achja eins noch. is es vielleicht moeglich irgendwie einen fertig konfigurierten ftp-server downzuloaden, ohne den ganzen anderen schnickschnack mit mysql http etc....[/quote]
MiG
 

Hilfe - bei mir geht der MAKE nicht....

Postby Canada-Bear » 16. January 2004 21:40

Buhuuhhhh :cry:

Ich war so glücklich über diesen Threat, da ich auch HLStats mit Xampp installieren wollte (Linux von Suse 8.2)

Das DBD:mysql Modul hat auch wunderbar geklappt. Leider nicht die DBI Installtion. Bei mir kommt am Ende des Installs folgendes bei raus:

Code: Select all
cc -c  -I/opt/lampp/lib/perl5/site_perl/5.8.0/i686-linux/auto/DBI -I/opt/lampp/include/mysql -I/opt/lampp/include -L/opt/lampp/lib ,--rpath ,/opt/lampp/lib -DDBD_MYSQL_WITH_SSL -fno-strict-aliasing -I/opt/lampp/include -D_LARGEFILE_SOURCE -D_FILE_OFFSET_BITS=64 -O3   -DVERSION=\"2.9003\" -DXS_VERSION=\"2.9003\" -fpic "-I/opt/lampp/lib/perl5/5.8.0/i686-linux/CORE"   dbdimp.c
cc: ,--rpath: Datei oder Verzeichnis nicht gefunden
cc: ,/opt/lampp/lib: Datei oder Verzeichnis nicht gefunden
In file included from /opt/lampp/lib/perl5/5.8.0/i686-linux/CORE/perl.h:3368,
                 from /opt/lampp/lib/perl5/site_perl/5.8.0/i686-linux/auto/DBI/DBIXS.h:19,
                 from dbdimp.h:20,
                 from dbdimp.c:19:
/opt/lampp/lib/perl5/5.8.0/i686-linux/CORE/proto.h:338: warning: `struct tm' declared inside parameter list
/opt/lampp/lib/perl5/5.8.0/i686-linux/CORE/proto.h:338: warning: its scope is only this definition or declaration, which is probably not what you want.
/opt/lampp/lib/perl5/5.8.0/i686-linux/CORE/proto.h:491: warning: `struct tm' declared inside parameter list
make: *** [dbdimp.o] Fehler 1
  /usr/bin/make  -- NOT OK
Running make test
  Can't test without successful make
Running make install
  make had returned bad status, install seems impossible


Wisst Ihr da noch Rat???
Versteh leider nur Bahnhof... BITTE HILFE!! Ohne Statistiken macht das Leben doch nur halb so viel Spass :wink:
Bear Attacks : PLAY DEAD!
User avatar
Canada-Bear
 
Posts: 17
Joined: 27. March 2003 20:37
Location: Oldenburg

Postby ORiGiNAL-SiN » 06. June 2005 12:39

Please, please, please can someone translate the solution into english, I have exact same problem as MiG in his first post (not guest post)

What is "Du noch das LAMPP-Entwicklungs-Paket nachinstallieren. (Findest Du auf der LAMPP-Seite, dort wo Du auch LAMPP heruntergeladen hast.) "???

Where do I find this file?!

Thanks!!!
C:/>
ORiGiNAL-SiN
 
Posts: 4
Joined: 24. April 2005 02:07

Postby Komandar » 07. July 2005 22:55

Sorry das ich das Thema hier noch einmal aufgreife, doch ich habe folgendes Problem:

Code: Select all
2005-07-07 23:54:44:                       - HLSTATSX: HLstatsX V1.00 starting...
2005-07-07 23:54:44:                       - UDP: Opening UDP listen socket on 255.255.255.255:27500 ... ok
install_driver(mysql) failed: Can't locate DBD/mysql.pm in @INC (@INC contains: /etc/perl /usr/local/lib/perl/5.8.4 /usr/local/share/perl/5.8.4 /usr/lib/perl5 /usr/share/perl5 /usr/lib/perl/5.8 /usr/share/perl/5.8 /usr/local/lib/site_perl .) at (eval 4) line 3.
Perhaps the DBD::mysql perl module hasn't been fully installed,
or perhaps the capitalisation of 'mysql' isn't right.
Available drivers: DBM, ExampleP, File, Proxy, Sponge.
 at hlstats.pl line 1185


Habe oben genannte Hilfestellungen probiert, doch hat leider nicht mit den aktuellen Versionen und meinem OS->Sarge geklappt.

Kann mir dabei jemand helfen ?
Außerdem würde ich mich freuen wenn im kommenden LAMPP-Packet das DBI und DBD schon intigriert wäre.
Komandar
 
Posts: 33
Joined: 07. July 2005 22:15

Postby Wiedmann » 07. July 2005 23:07

Außerdem würde ich mich freuen wenn im kommenden LAMPP-Packet das DBI und DBD schon intigriert wäre.

DBI und DBD::mysql ist beim XAMPP bereits mit drin.

Allerdings:
install_driver(mysql) failed: Can't locate DBD/mysql.pm in @INC (@INC contains: /etc/perl /usr/local/lib/perl/5.8.4 /usr/local/share/perl/5.8.4 /usr/lib/perl5 /usr/share/perl5 /usr/lib/perl/5.8 /usr/share/perl/5.8 /usr/local/lib/site_perl .) at (eval 4) line 3.

Du benutzt hier ja das Perl von deinem System. Da musst du natürlich das erforderlichen Module selbst installieren. Aber bei einem Einzeiler solle das ja keinen überfordern ;-)
Code: Select all
perl -MCPAN -e 'install Bundle::DBD::mysql'
Wiedmann
AF Moderator
 
Posts: 17106
Joined: 01. February 2004 12:38
Location: Stuttgart / Germany

Next

Return to XAMPP für Linux

Who is online

Users browsing this forum: No registered users and 4 guests