Forbidden

Irgendwelche Probleme mit XAMPP für Linux? Dann ist hier genau der richtige Ort um nachzufragen.

Forbidden

Postby clony » 01. March 2004 21:20

hi

bin neu hier und hab gleich ne frage zu xampp, ich weiß es muss euch schon langsam ankotzen soviele forbidden probleme wurden hier bereits behandelt. was ich damit sagen wollte ist, dass ich die suchfunktion benutzt habe, aber keine antwort auf meine frage gefunden habe.

system: Red Hat Linux 9.0

hab installiert mit tar -xzf xampp-linux-1.4.2.tar.gz -C /opt

soweit so gut. wenn ich jetzt im browser http://localhost/ (es ist egal ob ich von localhost zugreifen will oder von nem neztwerkrechner) aufrufe kommt die meldung

Forbidden

You don't have permission to access / on this server.

Additionally, a 403 Forbidden error was encountered while trying to use an ErrorDocument to handle the request.
Apache/2.0.48 (Unix) mod_perl/1.99_08 Perl/v5.8.0 mod_ssl/2.0.48 OpenSSL/0.9.7c PHP/4.3.4 DAV/2 Server at 192.168.1.10 Port 80


hier zuerst mal die ausgabe der httpd.conf (ich weiß is ziemlich viel aber ich weiß nich was davon wichtig ist)

DocumentRoot "/opt/lampp/htdocs"

<Directory />
Options FollowSymLinks
AllowOverride None
</Directory>


<Directory "/opt/lampp/htdocs">

Options Indexes FollowSymLinks ExecCGI Includes

AllowOverride All

Order allow,deny
Allow from all

</Directory>

<Konfig gekürtzt 1.03.04 23:02 Pc-Dummy>


die rechte des ordners /opt/lampp/htdocs sind auf 555 gesetzt (hatte testweise auch mal 777)

was genau ist das problem ???

thanks an jeden der sich die mühe macht mir zu helfen
clony
 
Posts: 8
Joined: 01. March 2004 21:05

Postby Pc-dummy » 01. March 2004 23:06

clony wrote:Additionally, a 403 Forbidden error was encountered while trying to use an ErrorDocument to handle the request.


Hmm da stimmt was an der komplette install nicht

Bitte nicht die ganze httpd.conf posten :!:

Es reichen relevante teile, in deinem Fall DocumentRoot und Directory vom DouRoot.

Installiere bitte mal lampp neu:

Code: Select all
/opt/lampp/lampp stop
rm -rf /opt/lampp
tar -xfz xampp-linux-1.4.2.tar.gz -C /opt
/opt/lampp/lampp start


MFG
Pc-Dummy
Gentoo/X86_64, AMD Athlon 64 FX-53, 1,5 GB INFINEON Ram, Audigy 2 ZS Platinum Pro, 300 GB Platten, LG-DVD Brenner
Pc-dummy
AF Moderator
 
Posts: 784
Joined: 29. December 2002 01:46
Location: AT-Vorarlberg-Feldkirch

Postby DJ DHG » 01. March 2004 23:41

Moin Moin

Pc-dummy wrote:
Code: Select all
/opt/lampp/lampp stop
rm -rf /opt/lampp
tar -xfz xampp-linux-1.4.2.tar.gz -C /opt
/opt/lampp/lampp start


du meinst doch sicherlich?

tar -xvfz xampp-linux-1.4.2.tar.gz -C /opt

mfg DJ DHG
User avatar
DJ DHG
AF Moderator
 
Posts: 2455
Joined: 27. December 2002 13:50
Location: Kiel

Postby Ceelight » 02. March 2004 09:24

Clony, ich bin mir nicht sicher, ob Du lampp denn nach dem installieren auch gestartet hast (/opt/lampp/lampp start). Bist Du es? ;)

edit: ach ja, und das "v" im tar-Aufruf muss schon sein... Aber dann sollte es klappen...
User avatar
Ceelight
 
Posts: 295
Joined: 31. January 2004 19:57
Location: Pfälzer im niedersächsischen Exil ;-)

Postby Pc-dummy » 02. March 2004 14:29

Hallo

Warum sollte das v sein müssen?

v == Verbose :)

MFG
Pc-Dummy
Gentoo/X86_64, AMD Athlon 64 FX-53, 1,5 GB INFINEON Ram, Audigy 2 ZS Platinum Pro, 300 GB Platten, LG-DVD Brenner
Pc-dummy
AF Moderator
 
Posts: 784
Joined: 29. December 2002 01:46
Location: AT-Vorarlberg-Feldkirch

Postby clony » 02. March 2004 15:49

also hab jetzt nochma neuinstalliert (was ich aber vorher auch schon n paar mal probiert hab) und geht troztdem nich, gleicher fehler wieder.

@ Ceelight natürlich hab ich ihn gestartet, wenn der nicht gestartet ist dann äußert sich das in cannot found localhost. Da ich mit dem satz "Bist du es?" nichts anfangen kann bin ich es wohl nicht, wüsste auch nicht woher ich dich kennen sollte. :) , wieso denn gibts noch nen clony ??

aber back to the topic: was mir aufgefallen ist, wenn ich den dienst starte mit /opt/lampp/lampp start (er bringt keine fehlermeldung, lediglich dass bereits ein anderer ftpdaemon lauft) und wieder beende mittels /opt/lampp/lampp stop, bringt er die meldung dass MySQL gar nicht läuft. liegt das vielleicht daran ???
clony
 
Posts: 8
Joined: 01. March 2004 21:05

Postby Oswald » 02. March 2004 18:11

Hallo Clony!

Bitte probier noch mal folgendes:

1. XAMPP starten
2. Zugriff auf http://localhost (von der gleichen Maschine aus)
3. Aufruf von tail /opt/lampp/logs/error_log in der Shell, in der Du auch XAMPP gestartet hast.
4. Was zeigt er nun an?

Das MySQL nicht läuft ist natürlich auch nicht richtig. Hat aber mit diesem Problem nichts zu tun.

Liebe Grüße
Oswald
User avatar
Oswald
Apache Friends
 
Posts: 2718
Joined: 26. December 2002 19:51
Location: Berlin, Germany
Operating System: Linux

Postby clony » 02. March 2004 21:29

jo hallo Kai Seidler

hier mal die ausgabe von tail

[Tue Mar 02 15:40:41 2004] [error] [client 192.168.1.20] (13)Keine Berechtigung: access to / denied
[Tue Mar 02 15:43:30 2004] [error] [client 127.0.0.1] (13)Keine Berechtigung: access to / denied
[Tue Mar 02 15:43:30 2004] [error] [client 127.0.0.1] (13)Keine Berechtigung: access to /favicon.ico denied, referer: http://localhost/
[Tue Mar 02 15:43:38 2004] [notice] caught SIGTERM, shutting down
[Tue Mar 02 21:24:23 2004] [notice] suEXEC mechanism enabled (wrapper: /opt/lampp/bin/suexec)
[Tue Mar 02 21:24:24 2004] [notice] Digest: generating secret for digest authentication ...
[Tue Mar 02 21:24:24 2004] [notice] Digest: done
[Tue Mar 02 21:24:25 2004] [notice] Apache/2.0.48 (Unix) mod_perl/1.99_08 Perl/v5.8.0 mod_ssl/2.0.48 OpenSSL/0.9.7c PHP/4.3.4 DAV/2 configured -- resuming normal operations
[Tue Mar 02 21:24:30 2004] [error] [client 127.0.0.1] (13)Keine Berechtigung: access to / denied
[Tue Mar 02 21:24:30 2004] [error] [client 127.0.0.1] (13)Keine Berechtigung: access to /favicon.ico denied, referer: http://localhost/



hoffe du kannst damit was anfangen
clony
 
Posts: 8
Joined: 01. March 2004 21:05

Postby Ceelight » 03. March 2004 14:35

clony wrote:Da ich mit dem satz "Bist du es?" nichts anfangen kann bin ich es wohl nicht, wüsste auch nicht woher ich dich kennen sollte. :) , wieso denn gibts noch nen clony ??



Damit meinte ich: Da ich nicht sicher bin... bist Du es denn - also sicher...

Ich kenne Dich nicht, aber nett Dich kennenzulernen... ;)

Ich schreib oftmals so wirres Zeug - sorry 8) Dachte das wäre klar.... Kann passieren.

Und natürlich hast Du recht. Forbidden gäbs sonst nicht. Hab nicht genau genug gelesen... Da sich Kai ja jetzt Deiner annimmt, denke ich wird Dir kompetent geholfen werden...

Grüße
Cee, der von tail (noch) keine Ahnung hat ;)
User avatar
Ceelight
 
Posts: 295
Joined: 31. January 2004 19:57
Location: Pfälzer im niedersächsischen Exil ;-)

Postby Oswald » 03. March 2004 15:05

Huhu Clony!

Wow! Sowas (Keine Berechtigung: access to / denied) hab ich noch nie gesehen. Ruf mal bitte ein:

ls -ld /

auf. Was zeigt er an?

Wenn ich richtig liege, dann wir ein

chmod a+rx /

Dein Problem lösen.

Probier's bitte mal aus.

Liebe Grüße
Oswald
User avatar
Oswald
Apache Friends
 
Posts: 2718
Joined: 26. December 2002 19:51
Location: Berlin, Germany
Operating System: Linux

Postby clony » 03. March 2004 18:14

hi kai

also ls -ld / gibt folgendes aus

drwxr-xr-x 20 root root 4096 29. Feb 19:02 /


der aufruf von chmod a+rx hat nichts geändert.
immer noch der gleiche fehler

hab auch die brechtigung des ordners /opt/lampp/htdocs/ überprüft.

drwxrwxrwx 5 root root 4096 2. Mär 15:39 /opt/lampp/htdocs/


kann das daran liegen dass noch der standard apache installiert ist ???
nach dem systemstart bevor ich xampp starte kill ich den mit kill pid
clony
 
Posts: 8
Joined: 01. March 2004 21:05

Postby clony » 07. March 2004 15:26

so ich musste jetzt aus einem anderen grund mein linux neu aufsetzten (ja ich habs geschafft und ein Linux geschrottet), is also ganz frisch installiert, und es ist nichts anders als vorher. is echt rätselhaft. verträgt sich xampp irgendwie nicht mit Red Hat 9.0 (Shrike)??
clony
 
Posts: 8
Joined: 01. March 2004 21:05

Postby Oswald » 07. March 2004 16:26

Ist mir echt ein Rätzel.

An RedHat 9 kann es nicht liegen. XAMPP läuft da prima.

Hmm... *weiter nachdenk*
Oswald
User avatar
Oswald
Apache Friends
 
Posts: 2718
Joined: 26. December 2002 19:51
Location: Berlin, Germany
Operating System: Linux

Postby clony » 10. March 2004 20:13

shit happens, sorry für den ausdruck is aber so

man das ist doch echt zum totlachen!!!

ich hab mir nochmal die config datei angeschaut. zeile für zeile. und da ist mir was ins auge gesprungen

User nobody (steht in zeile 319)
Group nobody (steht in zeile 322)


da hab ich mir überlegt ich hab doch gar keinen user nobody.
hab ihn zuerst auskommentiert, ging garnix mehr.
dann hab ich nen gültigen user/group eingetragen und, siehe da, es funzt.

also erstmal ein fettes +lööööl+
und ein dankeschön an die leute die versucht haben mir zu helfen.

cya


edit// deswegen hatte ich wohl auch keine berechtigung auf / zuzugreifen
clony
 
Posts: 8
Joined: 01. March 2004 21:05


Return to XAMPP für Linux

Who is online

Users browsing this forum: No registered users and 2 guests