Findet kein localhost

Irgendwelche Probleme mit XAMPP für Linux? Dann ist hier genau der richtige Ort um nachzufragen.

Findet kein localhost

Postby Linuxloser » 25. February 2004 17:51

Nachdem ich alles installiert hatte, und mit /opt/lampp/lampp start den Server und Co. zum laufen gebracht habe, konnte ich keine Verbindung zum localhost aufbauen. Fehlermeldung: Datei oder Verzeichnis nicht vorhanden.

Habe in der config die Raute vor dem Scoreboard weggemacht, ging auch nicht.
Linuxloser
 
Posts: 3
Joined: 25. February 2004 17:40

Postby DJ DHG » 26. February 2004 01:17

Moin Moin

wie hast du lampp installiert?

mit

Code: Select all
tar xvfz xampp-linux-1.X.tar -C /opt

oder?

mfg DJ DHG
User avatar
DJ DHG
AF Moderator
 
Posts: 2455
Joined: 27. December 2002 13:50
Location: Kiel

Postby Linuxloser » 26. February 2004 14:46

Ja. Unter Win98 ging alles wie von alleine.

Unter http://localhost/xampp komm ich jetzt ins Menü rein. Aber die Willkommenstartseite wird nicht angezeigt. Oder kommt da erst was wenn ich eine Seite eingebunden habe?
Linuxloser
 
Posts: 3
Joined: 25. February 2004 17:40

Postby DJ DHG » 26. February 2004 14:54

hmm

einbinden must du nix, das sollte so gehn.

du hast xampp als root installiert und das archiv ist nicht defekt?

mfg DJ DHG
User avatar
DJ DHG
AF Moderator
 
Posts: 2455
Joined: 27. December 2002 13:50
Location: Kiel

Postby Oswald » 26. February 2004 15:51

Hallo Linuxloser!

Ruf bitte mal http://localhost auf. Was bekommst Du dann genau angezeigt?

Lieben Gruß
Oswald
User avatar
Oswald
Apache Friends
 
Posts: 2718
Joined: 26. December 2002 19:51
Location: Berlin, Germany
Operating System: Linux

Postby Linuxloser » 26. February 2004 17:43

Als root installiert, das Paket war in Ordnung. Xampp startet auch wie in der FAQ angegeben.

Aber wenn ich http://localhost eingebe, dann zeigt er gar nichts an. Also nur weiß. Keine Fehlermeldung
Linuxloser
 
Posts: 3
Joined: 25. February 2004 17:40

Postby max » 28. February 2004 15:17

Hallo,
Ich habe das gleiche Problem,
Das Packet heruntergeladen (alle durchprobiert) und installiert, er gibt auch aus:
Starte XAMPP für Linux 1.4.2...
XAMPP: Starte Apache mit SSL...
XAMPP: Starte MySQL...
XAMPP: Starte ProFTPD...
XAMPP für Linux gestartet.

aber wenn ich http://localhost aufrufe sagt er nur:
Beim Laden von http://localhost ist folgender Fehler aufgetreten:
Keine Verbindung zu Rechner localhost

Wisst ihr vielleicht was da fehl läuft?

Max
max
 
Posts: 2
Joined: 28. February 2004 15:12

Postby Pc-dummy » 28. February 2004 15:22

"cat /opt/lampp/log/error_log" <-- in die konsole eingeben und ausgabe hier posten

"netstat -an | grep 80" <-- kommt was raus?

MFG
Pc-Dummy
Gentoo/X86_64, AMD Athlon 64 FX-53, 1,5 GB INFINEON Ram, Audigy 2 ZS Platinum Pro, 300 GB Platten, LG-DVD Brenner
Pc-dummy
AF Moderator
 
Posts: 784
Joined: 29. December 2002 01:46
Location: AT-Vorarlberg-Feldkirch

Postby max » 28. February 2004 15:47

error_log:
cat error_log
[Sat Feb 28 15:10:22 2004] [notice] suEXEC mechanism enabled (wrapper: /opt/lamp
p/bin/suexec)
[Sat Feb 28 15:10:22 2004] [notice] Digest: generating secret for digest authent
ication ...
[Sat Feb 28 15:10:22 2004] [notice] Digest: done
[Sat Feb 28 15:10:23 2004] [emerg] (13)Keine Berechtigung: couldn't grab the acc
ept mutex
[Sat Feb 28 15:10:23 2004] [emerg] (13)Keine Berechtigung: couldn't grab the acc
ept mutex
[Sat Feb 28 15:10:23 2004] [emerg] (13)Keine Berechtigung: couldn't grab the acc
ept mutex
[Sat Feb 28 15:10:23 2004] [emerg] (13)Keine Berechtigung: couldn't grab the acc
ept mutex
[Sat Feb 28 15:10:23 2004] [emerg] (13)Keine Berechtigung: couldn't grab the acc
ept mutex
[Sat Feb 28 15:10:23 2004] [notice] Apache/2.0.48 (Unix) mod_perl/1.99_08 Perl/v
5.8.0 mod_ssl/2.0.48 OpenSSL/0.9.7c PHP/4.3.4 DAV/2 configured -- resuming norma
l operations
[Sat Feb 28 15:10:23 2004] [alert] Child 3079 returned a Fatal error...
Apache is exiting!
[Sat Feb 28 15:44:29 2004] [notice] suEXEC mechanism enabled (wrapper: /opt/lamp p/bin/suexec)
[Sat Feb 28 15:44:29 2004] [notice] Digest: generating secret for digest authent ication ...
[Sat Feb 28 15:44:29 2004] [notice] Digest: done
[Sat Feb 28 15:44:30 2004] [emerg] (13)Keine Berechtigung: couldn't grab the acc ept mutex
[Sat Feb 28 15:44:30 2004] [emerg] (13)Keine Berechtigung: couldn't grab the acc ept mutex
[Sat Feb 28 15:44:30 2004] [emerg] (13)Keine Berechtigung: couldn't grab the acc ept mutex
[Sat Feb 28 15:44:30 2004] [notice] Apache/2.0.48 (Unix) mod_perl/1.99_08 Perl/v 5.8.0 mod_ssl/2.0.48 OpenSSL/0.9.7c PHP/4.3.4 DAV/2 configured -- resuming norma l operations
[Sat Feb 28 15:44:30 2004] [alert] Child 5259 returned a Fatal error...
Apache is exiting!
[Sat Feb 28 15:44:30 2004] [emerg] (22)Das Argument ist ungültig: couldn't grab the accept mutex
[Sat Feb 28 15:44:30 2004] [emerg] (13)Keine Berechtigung: couldn't grab the acc ept mutex

netstat:
unix 2 [ ACC ] STREAM HÖRT 47805 /opt/lampp/var/mysql/mysql.sock
unix 2 [ ] DGRAM 180419
unix 3 [ ] STREAM VERBUNDEN 180369 /tmp/.ICE-unix/5139
unix 3 [ ] STREAM VERBUNDEN 180368
unix 3 [ ] STREAM VERBUNDEN 180367 /tmp/.X11-unix/X0
unix 3 [ ] STREAM VERBUNDEN 180366
unix 3 [ ] STREAM VERBUNDEN 180328 /tmp/.ICE-unix/dcop5115-1077979004
unix 3 [ ] STREAM VERBUNDEN 180327
unix 3 [ ] STREAM VERBUNDEN 180318 /tmp/.ICE-unix/dcop5115-1077979004
unix 3 [ ] STREAM VERBUNDEN 180317
unix 3 [ ] STREAM VERBUNDEN 180308 /tmp/.ICE-unix/dcop5115-1077979004
unix 3 [ ] STREAM VERBUNDEN 180307
unix 3 [ ] STREAM VERBUNDEN 180306 /tmp/.ICE-unix/dcop5115-1077979004
unix 3 [ ] STREAM VERBUNDEN 180305
unix 3 [ ] STREAM VERBUNDEN 180303 /tmp/ksocket-max/konquerorcHznlb.slave-socket
unix 3 [ ] STREAM VERBUNDEN 180302
unix 3 [ ] STREAM VERBUNDEN 180299 /tmp/.ICE-unix/dcop5115-1077979004
unix 3 [ ] STREAM VERBUNDEN 180298
unix 3 [ ] STREAM VERBUNDEN 180301 /tmp/ksocket-max/konquerorCmTJ4b.slave-socket
unix 3 [ ] STREAM VERBUNDEN 180296
unix 3 [ ] STREAM VERBUNDEN 180291 /tmp/.ICE-unix/dcop5115-1077979004
unix 3 [ ] STREAM VERBUNDEN 180290
unix 3 [ ] STREAM VERBUNDEN 180300 /tmp/ksocket-max/konquerorY7nafc.slave-socket
unix 3 [ ] STREAM VERBUNDEN 180288
unix 3 [ ] STREAM VERBUNDEN 180272 /tmp/.ICE-unix/dcop5115-1077979004
unix 3 [ ] STREAM VERBUNDEN 180271
unix 3 [ ] STREAM VERBUNDEN 180270 /tmp/.ICE-unix/dcop5115-1077979004
unix 3 [ ] STREAM VERBUNDEN 180269
unix 3 [ ] STREAM VERBUNDEN 180267 /tmp/.ICE-unix/dcop5115-1077979004
unix 3 [ ] STREAM VERBUNDEN 180266
unix 3 [ ] STREAM VERBUNDEN 180268 /tmp/ksocket-max/konquerorwtSNza.slave-socket
unix 3 [ ] STREAM VERBUNDEN 180264
unix 3 [ ] STREAM VERBUNDEN 179802 /tmp/.ICE-unix/dcop5115-1077979004
unix 3 [ ] STREAM VERBUNDEN 179801
unix 3 [ ] STREAM VERBUNDEN 179680
max
 
Posts: 2
Joined: 28. February 2004 15:12

Postby Oliver » 06. April 2004 13:01

Also jetzt mal so ein keine Ahnung Tipp, aber bei mir funktionierts mit "http://linux".

KA, warum, hab nichts derartiges an der Config geändert

Benutze SuSE 9.0
Oliver
 
Posts: 8
Joined: 19. March 2004 17:52

lampp startet beim ersten mal immer mit ssl

Postby berndeckstein » 12. April 2004 20:09

habe auch lange gesucht warum es nicht geht.
Nach der Installation startet Apache mit ssl !!! und da stimmt eben http://localhost nicht

Zuerst /opt/lampp/lampp stopssl ausführen...dann klappt es.

Bernd
berndeckstein
 
Posts: 57
Joined: 02. May 2003 22:38


Return to XAMPP für Linux

Who is online

Users browsing this forum: No registered users and 3 guests