Xampp 1.7.4 / Imagemagick / Ghostscript / Typo3

Irgendwelche Probleme mit XAMPP für Linux? Dann ist hier genau der richtige Ort um nachzufragen.

Xampp 1.7.4 / Imagemagick / Ghostscript / Typo3

Postby pr89 » 23. March 2011 17:57

Hallo Forum,
komme folgendem Fehler/Verhalten einfach nicht auf die Spur...

Ich habe einen neuen Server mit Debian Squeeze (32Bit) installiert und darauf xampp 1.7.4,
sowie Imagemagick 6.6.0 und Ghostscript 9.01 (beide über apt-get).
Nach der Installation von Typo3 4.5.2 und dem Überprüfen des Image Processings tritt
der Fehler auf, dass PDF und AI Dateien nicht erstellt werden.

Ein manuelles Ausführen des identify/convert über die Console funktioniert einwandfrei.

Nach der Installation der Xampp Version 1.7.2, gleiches Typo3, funktioniert alles einwandfrei,
also auch die Erstellung der PDF/AI Dateien. Dasgleiche bei Xampp 1.7.1. Ab Version 1.7.3
tritt dieses Verhalten auf.

Ich wäre dankbar, wenn mir jemand weiterhelfen könnte, da ich inzwischen drei Tage mit
stöbern in Foren oder Google verbrachte habe und den Eindruck gewinne, dass offensichtlich
nur ich dieses Verhalten bisher habe...

Danke schon mal
pr89
 
Posts: 4
Joined: 23. March 2011 17:32

Re: Xampp 1.7.4 / Imagemagick / Ghostscript / Typo3

Postby Nobbie » 23. March 2011 18:07

Und was steht im Error Log?
Nobbie
 
Posts: 6652
Joined: 09. March 2008 13:04

Re: Xampp 1.7.4 / Imagemagick / Ghostscript / Typo3

Postby pr89 » 23. March 2011 18:17

Hallo,
danke schon mal für die schnelle Reaktion.

Im Error-Log steht:

gs: /opt/lampp/lib/libjpeg.so.62: no version information available (required by /usr/lib/libgs.so.9)
gs: /opt/lampp/lib/libjpeg.so.62: no version information available (required by /usr/lib/libjasper.so.1)
gs: /opt/lampp/lib/libjpeg.so.62: no version information available (required by /usr/lib/libtiff.so.4)
gs: /opt/lampp/lib/libjpeg.so.62: no version information available (required by /usr/lib/libcupsimage.so.2)
gs: /opt/lampp/lib/libgcc_s.so.1: version `GCC_4.2.0' not found (required by /usr/lib/libstdc++.so.6)
identify: Postscript delegate failed `/opt/lampp/htdocs/www.testdomain.de/typo3/sysext/install/imgs/pdf_from_imagemagick.pdf': 5MrP.cache @ error/pdf.c/ReadPDFImage/638.
/usr/bin/identify: /opt/lampp/lib/libjpeg.so.62: no version information available (required by /usr/lib/libtiff.so.4)
gs: /opt/lampp/lib/libjpeg.so.62: no version information available (required by /usr/lib/libgs.so.9)
gs: /opt/lampp/lib/libjpeg.so.62: no version information available (required by /usr/lib/libjasper.so.1)
gs: /opt/lampp/lib/libjpeg.so.62: no version information available (required by /usr/lib/libtiff.so.4)
gs: /opt/lampp/lib/libjpeg.so.62: no version information available (required by /usr/lib/libcupsimage.so.2)
gs: /opt/lampp/lib/libgcc_s.so.1: version `GCC_4.2.0' not found (required by /usr/lib/libstdc++.so.6)
identify: Postscript delegate failed `/opt/lampp/htdocs/www.testdomain.de/typo3/sysext/install/imgs/typo3logotype.ai': bBnQ.cache @ error/pdf.c/ReadPDFImage/638.


Das komische ist ja nur, dass es funktioniert, wenn eine andere Xampp-Version (<1.7.3) eingespielt ist.


Gruß
PR
pr89
 
Posts: 4
Joined: 23. March 2011 17:32

Re: Xampp 1.7.4 / Imagemagick / Ghostscript / Typo3

Postby Nobbie » 24. March 2011 00:27

pr89 wrote:Das komische ist ja nur, dass es funktioniert, wenn eine andere Xampp-Version (<1.7.3) eingespielt ist


Wieso "komisch"? Es ist doch offensichtlich, dass die neueren Xampp Versionen mit neueren (oder älteren) C-Compilern compiliert wurden (anscheinend GCC 4.2.0) und dass auf Deinem Rechner die entsprechenden Laufzeitbibliotheken fehlen.

Das ist ein Standardproblem, welches auftreten kann, wenn man NICHT die Software der Linux Distributionen aus den entsprechenden Archiven benutzt. Womit ich die abschließende Frage stelle, wieso benutzt Du nicht die Apache/PHP/MySQL Versionen von Debian Squeeze? Wieso Xampp? Das ist die Ursache und mit Sicherheit auch die Lösung des Problems - benutze die Debian Repositories anstatt Xampp (apt-get ....).
Nobbie
 
Posts: 6652
Joined: 09. March 2008 13:04

Re: Xampp 1.7.4 / Imagemagick / Ghostscript / Typo3

Postby pr89 » 24. March 2011 10:39

Danke für den Hinweis...

nachdem die "älteren" Versionen funktionierten, hätte ich den Hinweis im Log wahrscheinlich nicht mal
bemerkt, wenn er in fett-rot geschrieben wäre...

PR
pr89
 
Posts: 4
Joined: 23. March 2011 17:32

Re: Xampp 1.7.4 / Imagemagick / Ghostscript / Typo3

Postby pr89 » 25. March 2011 13:05

...wieso benutzt Du nicht die Apache/PHP/MySQL Versionen von Debian Squeeze?


So ... um den Forumsbeitrag auch ordentlich abzuschliessen ...
mit der "manuellen" Installation der Apache/MySQL/PHP usw. -Versionen aus dem Sequeeze-Repository funktioniert nun
alles wie gewünscht.

Danke für die Tipps
PR
pr89
 
Posts: 4
Joined: 23. March 2011 17:32

buying advertising

Postby freejmx » 01. April 2011 18:49

Do you sell context ads here?
If yes, CPM or clicks?
freejmx
 
Posts: 1
Joined: 01. April 2011 18:47
Location: US


Return to XAMPP für Linux

Who is online

Users browsing this forum: No registered users and 3 guests