Eigene Seite im Home Verzeichniss

Irgendwelche Probleme mit XAMPP für Linux? Dann ist hier genau der richtige Ort um nachzufragen.

Eigene Seite im Home Verzeichniss

Postby darkviruz » 24. February 2004 09:20

Hallo!!
Ich hab es nicht hinbekommen das jeder User im Home Verzeichniss seine eigenen Seiten haben kann... Die dann per /~username aufgerufen werden...

Code: Select all
#
# UserDir: The name of the directory that is appended onto a user's home
# directory if a ~user request is received.
#
UserDir html

#
# Control access to UserDir directories.  The following is an example
# for a site where these directories are restricted to read-only.
#
#<Directory /home/*/html>
#    AllowOverride FileInfo AuthConfig Limit
#    Options MultiViews Indexes SymLinksIfOwnerMatch IncludesNoExec
#   <Limit GET POST OPTIONS PROPFIND>
#        Order allow,deny
#        Allow from all
#    </Limit>
#    <LimitExcept GET POST OPTIONS PROPFIND>
#        Order deny,allow
#        Deny from all
#    </LimitExcept>
#</Directory>


Ergebniss:
Forbidden
You don't have permission to access /~darkviruz on this server.

Additionally, a 403 Forbidden error was encountered while trying to use an ErrorDocument to handle the request.


Ich hoffe ihr könnt mir helfen!!!
darkviruz
 
Posts: 20
Joined: 24. February 2004 09:16

Postby Pc-dummy » 24. February 2004 10:07

Hallo liegt wahrscheinlich an den userrechten

chmod -R 755 /home/*/html weitere infos zu chmod

MFG
Pc-Dummy
Gentoo/X86_64, AMD Athlon 64 FX-53, 1,5 GB INFINEON Ram, Audigy 2 ZS Platinum Pro, 300 GB Platten, LG-DVD Brenner
Pc-dummy
AF Moderator
 
Posts: 784
Joined: 29. December 2002 01:46
Location: AT-Vorarlberg-Feldkirch

Postby Stefan » 24. February 2004 10:09

Helau!

Hast Du schon versucht die KommtarStarter(#) vor den Zeilen wegzunehmen?

Kommentare werden mit "#" eingeleitet. D.h das diese Zeilen beim abarbeiten der conf überlesen werden.


Gruß
Stefan
User avatar
Stefan
 
Posts: 475
Joined: 26. December 2002 22:36
Location: Mitten in der sonnigen Südpfalz

Postby Pc-dummy » 24. February 2004 10:39

Hallo Stefan

Das muss normalerweise nicht sein....

Das sind nur die Einstellungen für diesen Ordner (Access usw.)

MFG
Pc-Dummy aka Jochum René
Gentoo/X86_64, AMD Athlon 64 FX-53, 1,5 GB INFINEON Ram, Audigy 2 ZS Platinum Pro, 300 GB Platten, LG-DVD Brenner
Pc-dummy
AF Moderator
 
Posts: 784
Joined: 29. December 2002 01:46
Location: AT-Vorarlberg-Feldkirch

Postby Stefan » 24. February 2004 10:58

Morsche René,

Du hast Recht!

Es gilt halt doch: Mund halten wenn man keinen Plan hat! :-)



machs gut
Stefan
User avatar
Stefan
 
Posts: 475
Joined: 26. December 2002 22:36
Location: Mitten in der sonnigen Südpfalz

Postby darkviruz » 24. February 2004 11:36

funktioniert trozdem nicht :(
hoffe ihr könnt mir trozdem weiterhelfen...
das "chmod -R 755 /home/*/html" hab ich schon probiert... ändert aber nichts an der meldung...
die # hab ich auch schon mal weggenommen... hat auch nichts beracht...
vielen dank :)
darkviruz
 
Posts: 20
Joined: 24. February 2004 09:16

Postby Stefan » 24. February 2004 11:53

drei mal Helau DarkViruz,

leider kann ich Dir nicht mehr helfen, das einzige was mir einfällt ist, das es keine Index in dem Verzeichnis gibt.

Sorry.

Mach Dir trotzdem noch ne schönen Tag!

beste Grüße
Stefan
User avatar
Stefan
 
Posts: 475
Joined: 26. December 2002 22:36
Location: Mitten in der sonnigen Südpfalz

Postby darkviruz » 24. February 2004 11:56

also ne index hab ich im verzeichniss :)
danke trozdem stefan :)

ich hoff mir kann jemand helfen *verzweifeltschau*
liebe grüße
darkviruz
 
Posts: 20
Joined: 24. February 2004 09:16

Postby Oswald » 24. February 2004 12:19

Huhu darkviruz!

Probier bitte auch noch mal folgenden chmod:

chmod a+x /home/darkviruz

Das wäre auch noch eine Möglichkeit. Bei den meisten Linux-Distributionen sind die Homeverzeichnisse der Benutzer generell für die anderen Benutzern gesperrt.

Liebe Grüße und viel Erfolg
Oswald
User avatar
Oswald
Apache Friends
 
Posts: 2718
Joined: 26. December 2002 19:51
Location: Berlin, Germany
Operating System: Linux

Postby darkviruz » 24. February 2004 12:25

oke, das hab ich auch versucht *gg*
meldung:
Forbidden
You don't have permission to access /~darkviruz/ on this server.


ich bin schon ur verzweifelt *gg*

vielen dank,
lg :)
darkviruz
 
Posts: 20
Joined: 24. February 2004 09:16

Postby Oswald » 24. February 2004 12:32

Hmm.. okay! :)

Kannst Du bitte mal in die error_log im logs-Verzeichnis von XAMPP gucken. Da sollte eine genauere Fehlemeldung stehen.

Lieben Gruß
Oswald
User avatar
Oswald
Apache Friends
 
Posts: 2718
Joined: 26. December 2002 19:51
Location: Berlin, Germany
Operating System: Linux

Postby darkviruz » 24. February 2004 12:37

heyyyyy jetzt gehts *gg*
hab dann noch im verzeichniss nachgeschaut und die index seite hatte kein html dran, warum weiss ich leider nicht...*grml*

weiters habe ich noch eine frage *gg*
wie kann ich wenn es einen neuen user gibt automatisch eine tabelle in der datenbank erzeugen?

dh ein user wurde erschaffen - mysql ~> neue db mit namen: userdb_$username

also so auf die art *gg*
hoffe ihr könnt mir helfen :)
lg
darkviruz
 
Posts: 20
Joined: 24. February 2004 09:16

Postby Kristian Marcroft » 24. February 2004 12:46

Hi,

du bastelst dir nen Shellscript, mit dem du User erzeugst.
Ich habe ähnliches unter Windows NT :)
DA jeder User der angelegt wird ein 2 Serverbasierte Profile erhält, auf die auch nur der User und die Admins zugreifen dürfen.

Normallerweise wären das ca. 20 klickst pro User so mach ich das mit einem Aufruf.
Ähnlich könntest das mit einem shellscript auf deinem Linux tun.

Du kannst User über die console anlegen in dem du dem shellscript einen Parameter übergibst. Der Parameter ist der Username. Dieser Parameter/Username wird dann in einer var gespeichert und wird innerhalb des shellscriptes so eingesetzt, das du eine Verbindung über die console zu mysql aufbaust, und eine neue DB für diesen User anlegst.

Viel Spass beim nachlesen :)

So long
KriS
User avatar
Kristian Marcroft
AF Moderator
 
Posts: 2962
Joined: 03. January 2003 12:08
Location: Diedorf

Postby darkviruz » 24. February 2004 12:49

danke ;) ich hoff ich krieg das hin *gg*

lg
darkviruz
 
Posts: 20
Joined: 24. February 2004 09:16


Return to XAMPP für Linux

Who is online

Users browsing this forum: No registered users and 1 guest