[Gelöst] Unter XAMPP 1.7.4 kein Backup möglich

Irgendwelche Probleme mit XAMPP für Linux? Dann ist hier genau der richtige Ort um nachzufragen.

[Gelöst] Unter XAMPP 1.7.4 kein Backup möglich

Postby lausbouwen » 29. January 2011 14:13

Hallo

Wie schon in meinem folgenden Thema beschriebenen und gelöstem Problem http://community.apachefriends.org/f/viewtopic.php?f=3&t=38628&hilit=xampp+1.7.3+backup so möchte ich auch heute mit der neuen Version ein Backupbug melden.

Letztes Mal war es die "information_schema" Datenbank, dieses Mal scheint die "performance_schema" Datenbank Probleme zu bereiten.

Code: Select all
walli:/home/rob # /opt/lampp/lampp backup passwort
Backing up databases...
performance_schema: FAILED


Womöglich kann man die folgende Datei "/opt/lampp/share/lampp/backup" so ändern wie letztes Mal sofern diese "performance_schema" Datenbank keinen Einfluss auf die Backups hat.

Sollte jemand das gleiche Problem haben mit einer Lösung, bitte melden.

Nachtrag: Testweise habe ich die Datenbank "performance_schema" gelöscht (vorher gesichert) mit dem Ergebnis, dass das Backup ohne Probleme funktionierte.
Also wenn bis auf weiteres kein Bugfix zur Verfügung steht und sollte diese Datenbank unwichtig sein so kann man sie ohne Bedenken löschen (mit vorheriger Sicherung!).

So, dass ist nun vorläufig meine Lösung für dieses Backupproblem. Ob dieser Fehler reproduzierbar ist könnt ihr mir ja hier mitteilen.


Schöne Grüsse

lausbouwen


openSUSE 11.3 64bit
Last edited by lausbouwen on 21. March 2011 09:05, edited 1 time in total.
User avatar
lausbouwen
 
Posts: 10
Joined: 27. December 2009 11:21
Location: Luxemburg

Re: Unter XAMPP 1.7.4 kein Backup möglich

Postby wkraemer » 03. February 2011 08:41

Hallo,

ich hatte das gleiche Problem.

Ich habe in dem Backup-Script folgende Zeile angepasst:

Code: Select all
# Don't backup information_schema. - Oswald, 7jan9
if test "$i" = "Database" -o "$i" = "information_schema" -o "$i" = "performance_schema"


Meine Befürchtung ist aber, dass bei einem Restore, wenn diese Datenbank fehlt, Fehler auftreten.

Gruß
Wolfgang
wkraemer
 
Posts: 26
Joined: 16. November 2003 11:36
Location: Simmern

Re: Unter XAMPP 1.7.4 kein Backup möglich

Postby lausbouwen » 03. February 2011 17:53

Hallo Wolfgang

Ich habe deine Backupskriptzeile eingefügt, (vorher natürlich die Datenbank "performance_schema" wieder hergestellt), mit dem Resultat, dass weder beim sichern noch nachher beim wiederherstellen ein Fehler entstand.

Somit kann man ruhigen Gewissens sagen, dass sich wie schon letztes Mal diese vermeintliche Zeile

Code: Select all
if test "$i" = "Database" -o "$i" = "information_schema" -o "$i" = "performance_schema"


ein Muss für jedes XAMPP 1.7.4 Backup ist.

Vielen Dank für deine Hilfe, nächstes Mal wird es wieder ein anderes "xxxxxxxxx_schema" sein :roll:


Schönen Gruss

lausbouwen
User avatar
lausbouwen
 
Posts: 10
Joined: 27. December 2009 11:21
Location: Luxemburg

Re: Unter XAMPP 1.7.4 kein Backup möglich

Postby wkraemer » 03. February 2011 18:28

Hallo lausbouwen,

lausbouwen wrote:Ich habe deine Backupskriptzeile eingefügt, (vorher natürlich die Datenbank "performance_schema" wieder hergestellt), mit dem Resultat, dass weder beim sichern noch nachher beim wiederherstellen ein Fehler entstand.

Dass kein Fehler angezeigt wurde ist klar, ABER...

Du hast ja die Datenbank "performance_schema" vorher wiederhergestellt. Im Ernstfall ist sie aber nicht mehr verfügbar.

Beim Starten von MySQL OHNE die Datenbank "performance_schema" werden folgende Fehler protokolliert:

110203 18:19:07 [ERROR] Native table 'performance_schema'.'events_waits_current' has the wrong structure
110203 18:19:07 [ERROR] Native table 'performance_schema'.'events_waits_history' has the wrong structure
110203 18:19:07 [ERROR] Native table 'performance_schema'.'events_waits_history_long' has the wrong structure
110203 18:19:07 [ERROR] Native table 'performance_schema'.'setup_consumers' has the wrong structure
110203 18:19:07 [ERROR] Native table 'performance_schema'.'setup_instruments' has the wrong structure
110203 18:19:07 [ERROR] Native table 'performance_schema'.'setup_timers' has the wrong structure
110203 18:19:07 [ERROR] Native table 'performance_schema'.'performance_timers' has the wrong structure
110203 18:19:07 [ERROR] Native table 'performance_schema'.'threads' has the wrong structure
110203 18:19:07 [ERROR] Native table 'performance_schema'.'events_waits_summary_by_thread_by_event_name' has the wrong structure
110203 18:19:07 [ERROR] Native table 'performance_schema'.'events_waits_summary_by_instance' has the wrong structure
110203 18:19:07 [ERROR] Native table 'performance_schema'.'events_waits_summary_global_by_event_name' has the wrong structure
110203 18:19:07 [ERROR] Native table 'performance_schema'.'file_summary_by_event_name' has the wrong structure
110203 18:19:07 [ERROR] Native table 'performance_schema'.'file_summary_by_instance' has the wrong structure
110203 18:19:07 [ERROR] Native table 'performance_schema'.'mutex_instances' has the wrong structure
110203 18:19:07 [ERROR] Native table 'performance_schema'.'rwlock_instances' has the wrong structure
110203 18:19:07 [ERROR] Native table 'performance_schema'.'cond_instances' has the wrong structure
110203 18:19:07 [ERROR] Native table 'performance_schema'.'file_instances' has the wrong structure

Welche Folgen das im Ernstfall hat, kann ich nicht abschätzen.

Gruß
Wolfgang
Last edited by wkraemer on 24. February 2011 22:34, edited 1 time in total.
wkraemer
 
Posts: 26
Joined: 16. November 2003 11:36
Location: Simmern

Re: Unter XAMPP 1.7.4 kein Backup möglich

Postby lausbouwen » 03. February 2011 18:35

Hallo Wolfgang

Vielen Dank für deine Bestandsaufnahme.

Möglicherweise kann uns Oswald von Xampp weiterhelfen...

Schönen Gruss

lausbouwen
User avatar
lausbouwen
 
Posts: 10
Joined: 27. December 2009 11:21
Location: Luxemburg

Re: Unter XAMPP 1.7.4 kein Backup möglich

Postby wkraemer » 04. February 2011 06:06

Hallo lausbouwen,
lausbouwen wrote:Möglicherweise kann uns Oswald von Xampp weiterhelfen...

Das wäre natürlich super! :D

1. Lösungsansatz für das Restore-Script wäre:
Es wird geprüft, ob eine MySQL-Version 5.5.x installiert ist. Wenn ja, wird die Datenbank "performance_schema" mit der richtigen Tabellenstruktur neu angelegt. Danach muss MySQL nochmal neu gestartet werden.

2. Lösungsansatz wäre:
- Nach dem Beenden von MySQL werden die Dateien in /opt/lampp/var/mysql/performance_schema im Backup gesichert.
- Im Restore-Script werden nach dem Anhalten von MySQL diese Dateien zurückgesichert und MySQL dann für das 'normale' Restore neu gestartet.

Besser wäre aber auf jeden Fall, wenn es eine Lösung gäbe, die mit MySQL-Mitteln dieses Problem lösen würde.

Gruß
Wolfgang
wkraemer
 
Posts: 26
Joined: 16. November 2003 11:36
Location: Simmern

Re: Unter XAMPP 1.7.4 kein Backup möglich

Postby wkraemer » 25. February 2011 10:50

Hallo leeyn,

leeyn wrote:Testweise habe ich die Datenbank "performance_schema" gelöscht (vorher gesichert) mit dem Ergebnis, dass das Backup ohne Probleme funktionierte.

natürlich, das funktioniert. Wie hast du sie gesichert und wie willst du sie zurückspielen? Mit dem Backup-Script von XAMPP und dem generierten Restore-Script funktioniert das nicht.

Die Fehler treten dann auf,
- wenn die Datenbank "performance_schema" mit dem Backup-Script gesichert werden soll,
oder
- wenn MySQL nach einem Restore gestartet wird und die Datenbank "performance_schema" nicht vorhanden ist.

Gruß
Wolfgang
wkraemer
 
Posts: 26
Joined: 16. November 2003 11:36
Location: Simmern

Re: Unter XAMPP 1.7.4 kein Backup möglich

Postby lausbouwen » 25. February 2011 17:55

Hallo Wolfgang

Testweise habe ich die Datenbank "performance_schema" gelöscht (vorher gesichert) mit dem Ergebnis, dass das Backup ohne Probleme funktionierte.


Mit "vorher gesichert" meinte ich natürlich die Datenbank "performance_schema" vorübergehend in ein anderes Verzeichnis (z.B. Desktop) kopiert, so dass sie für das Backupskript nicht mehr vorhanden ist.

Die Fehler treten dann auf,
- wenn die Datenbank "performance_schema" mit dem Backup-Script gesichert werden soll,


Ja genau so.


Schönen Gruss

lausbouwen
User avatar
lausbouwen
 
Posts: 10
Joined: 27. December 2009 11:21
Location: Luxemburg

Re: Unter XAMPP 1.7.4 kein Backup möglich

Postby Oswald » 19. March 2011 15:30

Huhu lausbouwen, Wolfgang!

Da die performance_schema keine originären Daten enthält und ihre Inhalte von MySQL zur Laufzeit selbst erhoben und berechnet werden, braucht man natürlich kein Backup von dieser Datenbank. Daher ist es auch nur richtig von MySQL, das die Sicherung dieser Datenbank durch XAMPPs Backup-Skript abgelehnt wird. Wolfgangs Lösung im zweiten Post dieses Threads scheint mir plausibel. Letztendlich ist es ja genau das gleiche Problem, wie bei der information_schema.

Habe gerade die Änderung in die kommende Beta der Linux-Version eingebaut. Damit sollte das zukünftig gefixt sein. ;)

Liebe Grüße
Oswald
User avatar
Oswald
Apache Friends
 
Posts: 2718
Joined: 26. December 2002 19:51
Location: Berlin, Germany
XAMPP Version: 5.5.19
Operating System: Linux

Re:[Gelöst]Unter XAMPP 1.7.4 kein Backup möglich

Postby lausbouwen » 21. March 2011 09:04

Hallo Oswald

Letztendlich ist es ja genau das gleiche Problem, wie bei der information_schema.

Und genau deshalb machte ich mir wegen des Problems auch keinen Kopf, wollte aber es nur wieder einmal hier im Forum zur Schau stellen.
Habe gerade die Änderung in die kommende Beta der Linux-Version eingebaut. Damit sollte das zukünftig gefixt sein.

So können vielleicht weniger vertraute Xamppnutzer nicht so erschrecken wenn sie dein Backup starten. :)

Vielen Dank für den Bugfix, Oswald.

Schöne Grüsse
lausbouwen
User avatar
lausbouwen
 
Posts: 10
Joined: 27. December 2009 11:21
Location: Luxemburg

Re: Re:[Gelöst]Unter XAMPP 1.7.4 kein Backup möglich

Postby Oswald » 21. March 2011 09:15

Hallo lausbouwen!

lausbouwen wrote:Hallo Oswald

Letztendlich ist es ja genau das gleiche Problem, wie bei der information_schema.

Und genau deshalb machte ich mir wegen des Problems auch keinen Kopf, wollte aber es nur wieder einmal hier im Forum zur Schau stellen.


Und das war richtig so, sonst hätte ich es ja auch gar nicht mitbekommen. Ich muss zugeben, dass genau die Backup-Funktion noch gar nicht in unserem Test-Szenarios enthalten ist und diese Funktion nicht automatisch getestet wird. Das hab ich mir aber nun auf die Todoliste geschrieben.

lausbouwen wrote:
Habe gerade die Änderung in die kommende Beta der Linux-Version eingebaut. Damit sollte das zukünftig gefixt sein.

So können vielleicht weniger vertraute Xamppnutzer nicht so erschrecken wenn sie dein Backup starten. :)

Vielen Dank für den Bugfix, Oswald.


Dank an wkraemer, von dem hab ich's ja nun letztendlich abgeschrieben. ;)

Liebe Grüße aus einem sonnigen Berlin
Oswald
User avatar
Oswald
Apache Friends
 
Posts: 2718
Joined: 26. December 2002 19:51
Location: Berlin, Germany
XAMPP Version: 5.5.19
Operating System: Linux

Re: Re:[Gelöst]Unter XAMPP 1.7.4 kein Backup möglich

Postby Altrea » 21. March 2011 10:01

Oswald wrote:Dank an wkraemer, von dem hab ich's ja nun letztendlich abgeschrieben. ;)


Da ist dann jetzt doch mindestens ein Doktortitel für drin, oder? ;-)
We don't provide any support via personal channels like PM, email, Skype, TeamViewer!

It's like porn for programmers 8)
User avatar
Altrea
AF Moderator
 
Posts: 6691
Joined: 17. August 2009 13:05
XAMPP Version: 5.5.19
Operating System: W7Ux64


Return to XAMPP für Linux

Who is online

Users browsing this forum: No registered users and 5 guests