welche benutzer anlegen?

Irgendwelche Probleme mit XAMPP für Linux? Dann ist hier genau der richtige Ort um nachzufragen.

welche benutzer anlegen?

Postby moscher » 16. February 2004 18:10

Hallo leute

ich habe Lampp Installiert und er startet auch die Server.
Doch wenn ich auf mein Apache zugreifen (egal ob localhost oder übers Lan) will bekomme ich folgende Meldung:

Warning: file_get_contents(lang.tmp): failed to open stream: Keine Berechtigung in /opt/lampp/htdocs/xampp/index.php on line 2
Warning: Cannot modify header information - headers already sent by (output started at /opt/lampp/htdocs/xampp/index.php:2) in /opt/lampp/htdocs/xampp/index.php on line 4

Die Datei hat bei diese Rechte:
-rw-r--r-- 1 root root 0 2004-02-16 15:51 lang.tmp

/opt/lampp/lampp security habe ich schon gemacht.


Ich habe irgendwo hier im Forum gelesen das lampp automatisch die passenden User anlegt, 3 oder 4 an der Zahl.
--Doch weder in der /etc/passwd noch in /etc/shadow sind neue Einträge hinzugekommen.

Welche Benutzer muss ich anlegen damit ich Apache, Php und mysql sicher nutzen Kann?
Und wie müssen die dazugehörigen Ordnerberechtigungen aussehen?


greetz moscher
moscher
 
Posts: 3
Joined: 16. February 2004 17:49

Postby Oswald » 16. February 2004 19:07

Hallo Moscher!

Du musst keine weitern Benutzer anlegen und XAMPP macht das auch nicht automatisch.

Die lang.tmp sollte eigentlich so aussehen:

-rw------- 1 nobody root 2 Jan 15 10:23 lang.tmp

Warum sie bei Dir anders aussieht kann ich mir nicht erklären. Hast Du die Installation so durchgeführt, wie in der Anleitung beschrieben? Oder hast Du XAMPP selbst irgendwie kopiert?

Gruß
Oswald
User avatar
Oswald
Apache Friends
 
Posts: 2718
Joined: 26. December 2002 19:51
Location: Berlin, Germany
Operating System: Linux

Postby moscher » 16. February 2004 19:10

^^
mmh also das Problem mit der lang.tmp hat sich irgendwie behoben :?:

http://localhost/xampp/splash.php kann jetzt geladen werden.
Doch sobald ich auf englich oder deutsch klicke habe ich wieder keine rechte mehr:

Warning: fopen(lang.tmp): failed to open stream: Keine Berechtigung in /opt/lampp/htdocs/xampp/lang.php on line 2

Warning: fwrite(): supplied argument is not a valid stream resource in /opt/lampp/htdocs/xampp/lang.php on line 3

Warning: fclose(): supplied argument is not a valid stream resource in /opt/lampp/htdocs/xampp/lang.php on line 4

Warning: Cannot modify header information - headers already sent by (output started at /opt/lampp/htdocs/xampp/lang.php:2) in /opt/lampp/htdocs/xampp/lang.php on line 5

doch die lang.php Datei hat die selben rechte wie die splash.php:
-rw-r--r--1 root root 119 2004-02-16 15:51 /opt/lampp/htdocs/xampp/lang.php
-rw-r--r--1 root root 868 2004-02-16 15:51 /opt/lampp/htdocs/xampp/splash.php

Axo ich benutze Suse9.0
moscher
 
Posts: 3
Joined: 16. February 2004 17:49

Postby Oswald » 16. February 2004 19:17

Jepp. lang.php und splash.php sind richtig so.

Kannst Du einfach noch mal das ganze /opt/lampp löschen und noch mal mit dem tar-Befehl installieren?

Irgendwoher hast Du dieses falsche lang.tmp bekommen. Du könntest es einfach löschen und damit das Problem lösen. Aber ich denke Neuinstall ist sicherer. Irgendwas läuft bei Dir schief.

SuSE9.0 ist okay. Damit hat XAMPP keine Probleme.

Liebe Grüße
Oswald
User avatar
Oswald
Apache Friends
 
Posts: 2718
Joined: 26. December 2002 19:51
Location: Berlin, Germany
Operating System: Linux

Postby moscher » 16. February 2004 20:44

jo thx das problem war echt das entpacken.:oops:
Ich habs ohne das -C gemacht, da ich die Installationsanleitung verzeifelt unter "hilfe" gesucht habe und sie nicht unter "Download" vermutet hätte.
Aber jetzt läuft fast alles (gelöscht+neuinstalliert) bis auf die eine CD-Verwaltungs-Demo:

Warning: mysql_connect(): Access denied for user: 'root@localhost' (Using password: NO) in /opt/lampp/htdocs/xampp/cds.php on line 4
... die Errormeldung geht noch weiter wird aber kryptisch...


Als ich neulich mysql installieren wollte habe ich in der Readme gelesen das ich einen mysql user mit mysql Password in einer mysql Gruppe anlegen muss :).
Und für den Apache doch eigendlich auch (mail und news User gibts ja) oder wie kommt diese Meldung zustande?
moscher
 
Posts: 3
Joined: 16. February 2004 17:49


Return to XAMPP für Linux

Who is online

Users browsing this forum: No registered users and 1 guest