Apache und ProFTPD auf FAT Dateisystem

Irgendwelche Probleme mit XAMPP für Linux? Dann ist hier genau der richtige Ort um nachzufragen.

Apache und ProFTPD auf FAT Dateisystem

Postby bapf » 23. August 2010 22:19

Hi,
ich suche eine Lösung und fasse mich mal kurz ohne lange Begründungen sonst könnte das ein ziemlich langer Text werden:

- Habe unter Ubuntu 10.04 den XAMPP installiert
- Nutzdaten befinden sich in einem 500GB großen FAT Container
- Der Container ist über Truecrypt verschlüsselt
- Es muss leider FAT verwendet werden da mir diese Vorgabe gemacht wird(!)

In dem Container befindet sich nun auch ein htdocs Verzechnis auf das Apache und ProFTPD zugreifen sollen. Leider funktioniert das nicht was wohl an daran liegt, dass unter FAT keine Rechte vergeben werden können. Ist das so?
Wenn ich ein anderes, lokales EXT3 Verzeichnis in den Konfigurationsdateien einstelle funktioniert XAMPP einwandfrei.

Bitte teilt mir eure Lösungsvorschläge mit!

Noch ein weiterer Schwerpunkt:
- Apache muss nur auf das htdocs Verzeichnis des Containers zugeifen
- ProFTPD auf alle Verzeichnisse des Containers(!)

(Die Platte mit dem FAT Container wird auch unter Windows genutzt und die Nutzer sind nicht damit einverstanden wenn der Container als EXT3 partentioniert wird und man unter Windows ein Tool zum mounten von Linux partentionen installiert.)
bapf
 
Posts: 5
Joined: 23. August 2010 21:49

Re: Apache und ProFTPD auf FAT Dateisystem

Postby Nobbie » 23. August 2010 22:56

bapf wrote:Leider funktioniert das nicht was wohl an daran liegt, dass unter FAT keine Rechte vergeben werden können. Ist das so?


Ne, daran liegt es ganz sicher nicht.

Aber mit "funktioniert nicht" fängt niemand etwas an. Du mußt schon deutlich besser beschreiben, was Du machst, welcher Fehler wann wo auftritt und welche Fehlermeldungen Du bekommst.
Nobbie
 
Posts: 7001
Joined: 09. March 2008 13:04

Re: Apache und ProFTPD auf FAT Dateisystem

Postby bapf » 24. August 2010 05:52

Es klingt schonmal gut, dass es eine Lösung zu geben scheint :D

Nobbie wrote:Aber mit "funktioniert nicht" fängt niemand etwas an. Du mußt schon deutlich besser beschreiben, was Du machst, welcher Fehler wann wo auftritt und welche Fehlermeldungen Du bekommst.


ftp://localhost --> 503 Login Incorrect (habe mit dem user, mit nobody und root versucht)

http://localhost -->
Code: Select all
Zugriff verweigert!
Der Zugriff auf das angeforderte Verzeichnis ist nicht möglich. Entweder ist kein Index-Dokument vorhanden oder das Verzeichnis ist zugriffsgeschützt.
Sofern Sie dies für eine Fehlfunktion des Servers halten, informieren Sie bitte den Webmaster hierüber.
Error 403
localhost
Di 24 Aug 2010 06:40:13 CEST
Apache/2.2.14 (Unix) DAV/2 mod_ssl/2.2.14 OpenSSL/0.9.8l PHP/5.3.1 mod_apreq2-20090110/2.7.1 mod_perl/2.0.4 Perl/v5.10.1


Ändere ich in den Konfigurationsdateien /opt/lampp/etc/httpd.conf und /opt/lampp/etc/proftpd.conf den Pfad auf einen lokalen Ordner dann funktioniert beides jeweils.

Die Konfigurationsdateien sind bis auf Passwort (durch den Aufruf von /opt/lampp/lampp security) und dem geändertem Verzeichnis im Originalzustand.
bapf
 
Posts: 5
Joined: 23. August 2010 21:49

Re: Apache und ProFTPD auf FAT Dateisystem

Postby Nobbie » 24. August 2010 09:54

bapf wrote:Es klingt schonmal gut, dass es eine Lösung zu geben scheint :D


Vielleicht. Hängt auch von Deiner Mitteilungsfreudigkeit ab, die noch sehr verbesserungsfähig ist.

bapf wrote:ftp://localhost --> 503 Login Incorrect (habe mit dem user, mit nobody und root versucht)


Was offensichtlich bedeutet, Dein FTP Server kennt weder nobody noch root (oder Du kennst die richtigen Passwörter nicht). Einen Zusammenhang zum TrueCrypt Container sehe ich nicht ansatzweise.

bapf wrote:http://localhost -->
Code: Select all
Zugriff verweigert!
Der Zugriff auf das angeforderte Verzeichnis ist nicht möglich. Entweder ist kein Index-Dokument vorhanden oder das Verzeichnis ist zugriffsgeschützt.
Sofern Sie dies für eine Fehlfunktion des Servers halten, informieren Sie bitte den Webmaster hierüber.
Error 403
localhost
Di 24 Aug 2010 06:40:13 CEST
Apache/2.2.14 (Unix) DAV/2 mod_ssl/2.2.14 OpenSSL/0.9.8l PHP/5.3.1 mod_apreq2-20090110/2.7.1 mod_perl/2.0.4 Perl/v5.10.1



Jetzt wäre es an der Zeit, uns zu erklären, wie Du httpd.conf eingestellt hast (insbesondere den DocumentRoot), und wie das ganze mit dem TrueCrypt Container zusammenhängt. Davon steht immer noch nicht auch nur ein Sterbenswörtchen hier. Du hast noch nicht einmal beschrieben, wie Du den Container in das Linux Umfeld eingebunden hast.
Nobbie
 
Posts: 7001
Joined: 09. March 2008 13:04

Re: Apache und ProFTPD auf FAT Dateisystem

Postby bapf » 24. August 2010 19:13

Mehr Details sind kein Problem, ich möchte nur niemand mit langen Beiträgen verschrecken...
Also der Truecrypt Container nennt sich "content" als 500GB FAT und wird in /Atom eingehängt. Das zuvor als htdocs bezeichnete Verzeichnis ist bei mir in Wirklichkeit als www benahmt. Darauf soll man übers http Protokoll gelangen. Übers ftp Protokoll soll es in das übergeordnete /Atom Verzechnis gehen. Ich weis auch nicht warum da "Login incorrect" kommt, aber wenn ich das Verzeichnis umstelle funktioniert es mit dem gleichen Zugangsdaten. Ich habe auch schon root, nobody und bapf versucht und auch beide gruppen nogroup und users.

Die Änderungen sind in rot.

gedit /opt/lampp/etc/proftpd.conf
...

# Set the user and group that the server normally runs at.
User root
#Group users


# Normally, we want files to be overwriteable.
<Directory /Atom/*>
AllowOverwrite on
</Directory>

# only for the web servers content
DefaultRoot /Atom

# nobody gets the password "lampp"
# commented out by lampp security
#UserPassword nobody wRPBu8u4YP0CY
UserPassword nobody wRPBu8u4YP0CY
UserPassword root wRPBu8u4YP0CY


...


gedit /opt/lampp/etc/httpd.conf

...

#
# DocumentRoot: The directory out of which you will serve your
# documents. By default, all requests are taken from this directory, but
# symbolic links and aliases may be used to point to other locations.
#
DocumentRoot "/Atom/www"

...

#
# This should be changed to whatever you set DocumentRoot to.
#
<Directory "/Atom/www">
#
# Possible values for the Options directive are "None", "All",
# or any combination of:
# Indexes Includes FollowSymLinks SymLinksifOwnerMatch ExecCGI MultiViews
#
# Note that "MultiViews" must be named *explicitly* --- "Options All"
# doesn't give it to you.
#
# The Options directive is both complicated and important. Please see
# http://httpd.apache.org/docs/2.2/mod/core.html#options
# for more information.
#
#Options Indexes FollowSymLinks
# XAMPP
Options Indexes FollowSymLinks ExecCGI Includes


#
# AllowOverride controls what directives may be placed in .htaccess files.
# It can be "All", "None", or any combination of the keywords:
# Options FileInfo AuthConfig Limit
#
#AllowOverride None
# since XAMPP 1.4:
AllowOverride All


#
# Controls who can get stuff from this server.
#
Order allow,deny
Allow from all

</Directory>
...

Last edited by bapf on 25. August 2010 05:34, edited 2 times in total.
bapf
 
Posts: 5
Joined: 23. August 2010 21:49

Re: Apache und ProFTPD auf FAT Dateisystem

Postby Nobbie » 24. August 2010 20:17

bapf wrote:Mehr Details sind kein Problem


Ich sehe immer noch nicht, wie der Container eingebunden ist (außer dem Namen - das ist das unwichtigste). Wie sind die Berechtigungen gesetzt?

bapf wrote:, ich möchte nur niemand mit langen Beiträgen verschrecken...


Schon geschehen. Was soll ich mit den sinnlosen Listings der Konfigurationsdateien - zeig uns doch bitte NUR DIE ÄNDERUNGEN. Ich habe keine Lust, mich dadurch zu wühlen.

bapf wrote:ftp Protokoll soll es in das übergeordnete /Atom Verzechnis gehen. Ich weis auch nicht warum da "Login incorrect" kommt,


Weil Du wahrscheinlich zu viel geändert hast. Aber ich schau mir das nicht an (s.o.), Du zeigst uns gezielt, was Du geändert hast.
Nobbie
 
Posts: 7001
Joined: 09. March 2008 13:04

Re: Apache und ProFTPD auf FAT Dateisystem

Postby bapf » 25. August 2010 05:27

Guten Morgen Nobbie,

Nobbie wrote:Ich sehe immer noch nicht, wie der Container eingebunden ist (außer dem Namen - das ist das unwichtigste). Wie sind die Berechtigungen gesetzt?


Hier ein Auszug aus dem root Verzeichnis. Hänge ich es auf Atom kommen die oben beschriebenen Fehleer, hänge ich es auf TEST funktioniert der XAMPP vollständig:
drwx------ 7 atom users 65536 2010-08-20 21:58 Atom/
drwxr-xr-x 4 root root 4096 2010-08-20 20:52 opt/
drwxrwxrwx 4 root root 4096 2010-08-20 21:53 TEST/

Ich hänge den Container ein indem ich die Benutzeroberfläche von Truecrypt öffne, den Container auswähle, das Ziel /Atom wähle, Containerpasswort und Root Passwort eingebe. Alles andere lasse ich auf Truecrypt Default.

Nobbie wrote:
bapf wrote:ftp Protokoll soll es in das übergeordnete /Atom Verzechnis gehen. Ich weis auch nicht warum da "Login incorrect" kommt,

Weil Du wahrscheinlich zu viel geändert hast. Aber ich schau mir das nicht an (s.o.), Du zeigst uns gezielt, was Du geändert hast.

Ich hatte eigentlich in dem letzten Satz des zweiten Beitrags schon geschrieben was ich an den Files geändert hatte. Nun habe ich die Files obendrüber auf die Änderungen abgespeckt. Du musst auch mitteilungsfreudiger werden damit ich weis was ich posten soll ...
bapf
 
Posts: 5
Joined: 23. August 2010 21:49

Re: Apache und ProFTPD auf FAT Dateisystem

Postby Nobbie » 25. August 2010 09:42

bapf wrote:drwx------ 7 atom users 65536 2010-08-20 21:58 Atom/


Siehst, den ganzen Kladderaraddatsch hätte man sich sparen können, wenn Du vernünftig mit dieser allesentscheidenden Info angefangen hättest. Wie Du siehst, ist /Atom so eingehängt, dass nur der User "atom" dort lesen und schreiben und zugreifen darf - und sonst darf NIEMAND irgendetwas. Da kann weder Apache noch FTP zugreifen, weil die mit anderen UserID als "atom" laufen. Das ist die Erklärung für das ganze Scenario.
Nobbie
 
Posts: 7001
Joined: 09. March 2008 13:04

Re: Apache und ProFTPD auf FAT Dateisystem

Postby bapf » 25. August 2010 12:00

Wie kann ich das Problem lösen?
Kann ich den FAT Truecrypt Container auch anders einhängen?
Oder kann ich FTP und Apache als user forcen / umleiten so dass es geht?
Ich benötige jetzt noch eine Lösung damit die Fehlermeldungen weg gehen...
bapf
 
Posts: 5
Joined: 23. August 2010 21:49

Re: Apache und ProFTPD auf FAT Dateisystem

Postby Nobbie » 25. August 2010 12:42

bapf wrote:Kann ich den FAT Truecrypt Container auch anders einhängen?


Selbstverständlich. Das bekommst Du aber selbst heraus, Google mal ein wenig herum und suche nach "Truecrypt Container Linux mount".

bapf wrote:Oder kann ich FTP und Apache als user forcen / umleiten so dass es geht?


Bei Apache könnte das möglicherweise dadurch gehen, dass Du als User "atom" in httdp.conf einsetzt. Aber sauberer ist in jedem Fall, den Container mit den notwendigen Rechten zu mounten.

Bei FTP liegt das Problem noch tiefer - wenn sich ein User einlogged, wird ein Prozess abgespalten und der bekommt die Rechte des eingeloggeden Users - d.h. es genügt nicht, den Serverprozess mit allen möglichen Rechten auszustatten. Es müssen die (oder das) Zielverzeichnis(se) richtig konfiguriert sein.

Beim FTP fällt mir noch auf, dass Du da Passwörter in die Conf geschrieben hast. Das ist unnötig und finde ich auch nicht gut. ProFFPD greift für das Login normalerweise auf die System Anwender zurück (mit deren Passwörtern).

Wenn ich die Aufgabe zu lösen hätte, würde ich im System einen User "xampp" anlegen, das Homeverzeichnis in /Atom/www legen (das geht alles mit Linux Boardmitteln), die Berechtigungen der Ordner entsprechend vergeben und den Anwendern nur diesen User und dessen Passwort mitteilen.

Weiterhin würde auch auch Apache dann mit dem User xampp laufen lassen und (wie schon teilweise für FTP geschehen) die ganzen notwendigen Verzeichnisse an xampp übergeben. Bei dem gemounteten Truecrypt Container kannst Du NICHT unterhalb des Startverzeichnisses /Atom andere Berechtigungen und UserIds vergeben als für /Atom selbst (das ist nun die Folge davon, dass das ein FAT Container ist - Linux hat dann nicht die Möglichkeit, einzelne Ordner oder Dateien anderen Usern zuzuordnen, das geht mit FAT einfach nicht). Deswegen wird beim mounten schon definiert, wem der Container (und damit auch alle Dateien darunter) gehören und welche Rechte gelten. Du müßtest also /Atom mit der UserID von xampp mounten - oder Du läßt das sein mit dem "xampp" User und nimmst den vorhandenen "atom" User. Dann teilst Du den Anwendern eben dessen Passwort mit und konfigurierst für den atom User das Homeverzeichnis auf /Atom/www (damit beim FTP Login das richtige Startverzeichnis da ist).

bapf wrote:Ich benötige jetzt noch eine Lösung damit die Fehlermeldungen weg gehen...


Ich werde Dir keine fertige Lösung vorkauen. Das ist offensichtlich Deine Praktikumsaufgabe und ich habe Dir jetzt viel entscheidende Hinweise gegeben, mit deren Hilfe Du das Problem lösen kannst. Aber machen mußt Du es immer noch selbst, das nehme ich Dir nicht auch noch ab.
Nobbie
 
Posts: 7001
Joined: 09. March 2008 13:04


Return to XAMPP für Linux

Who is online

Users browsing this forum: No registered users and 5 guests