Neues Backup

Irgendwelche Probleme mit XAMPP für Linux? Dann ist hier genau der richtige Ort um nachzufragen.

Neues Backup

Postby norikuus » 27. January 2004 14:47

Habe das neue Backup getestet, das einpacken läuft ohne Probleme auf Debian.

Das Auspacken nicht so gut, es kommt folgende Fehlermeldung:
Checking integrity of files...
grep: md5sums: Datei oder Verzeichnis nicht gefunden
*: Datei oder Verzeichnis nicht gefunden
Restoring configuration, log and htdocs files...
tar (Kind): data.tar.gz: Kann open nicht ausführen.: Datei oder Verzeichnis nicht gefunden
tar (Kind): Nicht behebbarer Fehler: Programmabbruch.
tar: Kindprozeß gab Status 2 zurück.
tar: Fehler beim Beenden, verursacht durch vorhergehende Fehler.
Checking versions...
cat: VERSION: Datei oder Verzeichnis nicht gefunden
Installed: XAMPP 1.4.2
Backup from: XAMPP
The backup sofware is not able to handle different XAMPP versions.
Your backuped configuration from may not work with 1.4.2 and may need manually corrections.
XAMPP: Do you want to continue [nein]
Good choice.


Man sollte vieleicht in der FAQ noch dazu schreiben das der Befehl "sh xampp-backup-27-01-04.sh" im Backupverzeichnis ausgeführt werden muss. Ums DAU-Sicher zu machen.:wink:

Gruß

norikuus

PS. Wie viele Silvester muss man studiert haben um auf ein solches Backupscript zu kommen :lol:
norikuus
 
Posts: 9
Joined: 24. July 2003 23:43

Postby Oswald » 27. January 2004 15:43

Huhu norikuus!

Ui... da läuft ja richtig was schief. Hmm.. :(

Eigentlich sollte "sh xampp-backup-..." auch nicht ausschliesslich im backup-Verzseichnis funktionieren sondern in jedem Verzeichnis.

Was passiert wenn Du es nicht im backup-Verzeichnis aufrufst?

Liebe Grüße
Oswald
User avatar
Oswald
Apache Friends
 
Posts: 2718
Joined: 26. December 2002 19:51
Location: Berlin, Germany
Operating System: Linux

Postby Oswald » 27. January 2004 15:47

Kannst Du mal

head -40 xampp-backup-...

aufrufen und mir das mailen was Du da angezeigt bekommst?

An oswald@apachefriends.org

Das wär klasse!

Liebe Grüße
Oswald
User avatar
Oswald
Apache Friends
 
Posts: 2718
Joined: 26. December 2002 19:51
Location: Berlin, Germany
Operating System: Linux

Postby Oswald » 28. January 2004 14:57

Huhu norikuus!

Danke für's zusenden der Ausgabe.

Bin immer noch ein bisschen ratlos. Welche Distribution benutzt Du?

Liebe Grüße
Oswald
User avatar
Oswald
Apache Friends
 
Posts: 2718
Joined: 26. December 2002 19:51
Location: Berlin, Germany
Operating System: Linux

Postby norikuus » 28. January 2004 18:33

Schreibe mal einfach alles auf was mir einfällt.

Debian SID, Kernel 2.6.2-rc2-mm1, Xfree 4.4.

Gruß

norikuus
norikuus
 
Posts: 9
Joined: 24. July 2003 23:43

Postby Oswald » 29. January 2004 13:58

Huhu norikuus!

Werd mir heut abend mal so ein System installieren. Bisher steh ich da ziemelich ratlos da... :(

Melde mich dann heute abend irgendwann... ;)

Liebe Grüße
Oswald
User avatar
Oswald
Apache Friends
 
Posts: 2718
Joined: 26. December 2002 19:51
Location: Berlin, Germany
Operating System: Linux

Postby Oswald » 30. January 2004 02:09

Huhu norikuus!

Puh... Fehler gefunden! :)

Ich gehe in dem Restore-Skript davon aus das gawk installiert ist. Das darf ich eigentlich nicht so machen und muss ich bis zur nächsten Version noch korrigieren.

Um den Fehler zu umgehen kannst Du einfach gawk installieren. Zum Beispiel mit: apt-get install gawk (geht schnell)

Danach klappt dann auch der Restore!

Norikuss, danke für den schönen Fehler! :)

Liebe Grüße & gute Nacht
Oswald
User avatar
Oswald
Apache Friends
 
Posts: 2718
Joined: 26. December 2002 19:51
Location: Berlin, Germany
Operating System: Linux

Postby norikuus » 30. January 2004 03:04

Stimmt ich habe mawk. Habe gerade nachgeschaut, was der Unterschiede ist. Mawk ist die Light-Version.

Es geht nichts über einen schönen Fehler :lol: .

Und dafür hast Du jetzt noch ein schönes SID. :wink:

Gruß

norikuus
norikuus
 
Posts: 9
Joined: 24. July 2003 23:43

Postby sunny » 23. February 2004 12:01

huhu :)

also ich habe auch probleme mit dem backup.. brauch aber die alten daten dringend :(

auch wenn ich gawk installiere geht es nicht.. genauso wenn ich den backup in /opt/lampp/backup/ aufrufe :/

zum testen habe ich ein heute ein backup erstellt und versuch es zu restoren

fehlermeldung ist die gleiche (alte backups und das von heute):

sh xampp-backup-23-02-04.sh ***
Checking integrity of files...
egrep: md5sums: No such file or directory
*: No such file or directory
Restoring configuration, log and htdocs files...
tar (child): data.tar.gz: Cannot open: No such file or directory
tar (child): Error is not recoverable: exiting now
tar: Child returned status 2
tar: Error exit delayed from previous errors
Checking versions...
cat: VERSION: No such file or directory
Installed: XAMPP 1.4.2
Backup from: XAMPP
The backup sofware is not able to handle different XAMPP versions.
Your backuped configuration from may not work with 1.4.2 and may need manually corrections.
XAMPP: Do you want to continue [no] no
Good choice.

das ganze läuft auf debian.
für eure hilfe wäre ich sehr dankbar :)
sunny
 
Posts: 7
Joined: 23. February 2004 11:52

Postby Oswald » 23. February 2004 12:12

Huhu Sunny!

Sicher, dass gawk installiert ist? Ruf bitte einfach mal gawk in einer Shell auf.

Liebe Grüße
Oswald
User avatar
Oswald
Apache Friends
 
Posts: 2718
Joined: 26. December 2002 19:51
Location: Berlin, Germany
Operating System: Linux

Postby sunny » 23. February 2004 12:23

Kai Seidler wrote:Huhu Sunny!

Sicher, dass gawk installiert ist? Ruf bitte einfach mal gawk in einer Shell auf.

Liebe Grüße
Oswald


huhu! :)

nachdem ich diesen thread gesehen habe versuchte ich erst aus dem backup verzeichniss zu restoren was nicht ging und dann habe ich gawk installiert.. wieder backup zu restoren versucht was leider auch nicht ging dann habe ich die msg oben gepostet :)..

dies bekomme ich wenn ich gawk eingebe:

gawk
Usage: gawk [POSIX or GNU style options] -f progfile [--] file ...
Usage: gawk [POSIX or GNU style options] [--] 'program' file ...
POSIX options: GNU long options:
-f progfile --file=progfile
-F fs --field-separator=fs
-v var=val --assign=var=val
-m[fr] val
-W compat --compat
-W copyleft --copyleft
-W copyright --copyright

.... usw .. die ganzen optionen dann

gruss :)
sunny
 
Posts: 7
Joined: 23. February 2004 11:52

Postby Oswald » 23. February 2004 12:44

Huhu Sunny!

Danke. Ich wollte nur sicher gehen. Okay. Nächster Test: Kannst Du bitte mal awk aufrufen. Ohne g. Was gibt er dann aus?

Grüße
Oswald
User avatar
Oswald
Apache Friends
 
Posts: 2718
Joined: 26. December 2002 19:51
Location: Berlin, Germany
Operating System: Linux

Postby sunny » 23. February 2004 13:09

Kai Seidler wrote:Huhu Sunny!

Danke. Ich wollte nur sicher gehen. Okay. Nächster Test: Kannst Du bitte mal awk aufrufen. Ohne g. Was gibt er dann aus?

Grüße
Oswald


huhu :)

er gibt nichts aus :s nehme an original-awk? habe es jetzt auf jeden fall installiert aber restore funktioniert trotzdem noch nicht :/

gruss
sunny
sunny
 
Posts: 7
Joined: 23. February 2004 11:52

Postby Oswald » 23. February 2004 13:17

Ahh.. alles klar! ;)

Bitte deinstallier mal mawk. Das brauchst weder Du noch Dein System wenn gawk installiert ist:

apt-get remove mawk

Danach sollte der Aufruf von awk auch die Meldung von gawk geben und dann sollte der Restore funktionieren.

Liebe Grüße
Oswald


PS: In der nächsten Version des Backup-Programms verzichte ich übrigends auf awk. So vermeiden wir dann die ganzen Probleme...
User avatar
Oswald
Apache Friends
 
Posts: 2718
Joined: 26. December 2002 19:51
Location: Berlin, Germany
Operating System: Linux

Postby sunny » 23. February 2004 15:20

huhu!

also erstmal vielen vielen dank für den tollen support!!! :)

mawk habe ich deinstalliert und die dateien wurden wieder hergestellt.. aber leider klappt der mysql restore nicht.. ein tip was es sein könnte? :)

sh xampp-backup-23-02-04.sh ***
Checking integrity of files...
Restoring configuration, log and htdocs files...
Checking versions...
Installed: XAMPP 1.4.2
Backup from: XAMPP 1.4.2
Restoring MySQL databases...
cdcol FAILED: ERROR 3 at line 20: Error writing file './cdcol/cds.frm' (Errcode: 28)
phpmyadmin FAILED: ERROR 3 at line 20: Error writing file './phpmyadmin/PMA_bookmark.frm' (Errcode: 28)
test FAILED: ERROR 3 at line 20: Error writing file './test/testac.frm' (Errcode: 28)
usr_1 FAILED: ERROR 1006 at line 11: Can't create database 'usr_1'. (errno: 28)
usr_2 FAILED: ERROR 1006 at line 11: Can't create database 'usr_2'. (errno: 28)
Restoring MySQL user databases...
MySQL user FAILED: ERROR 3 at line 20: Error writing file './mysql/columns_priv.frm' (Errcode: 28)
Backup complete. Have fun!
You may need to restart XAMPP to complete the restore.



gruss
sunny
sunny
 
Posts: 7
Joined: 23. February 2004 11:52

Next

Return to XAMPP für Linux

Who is online

Users browsing this forum: No registered users and 3 guests