php.ini

Irgendwelche Probleme mit XAMPP für Linux? Dann ist hier genau der richtige Ort um nachzufragen.

php.ini

Postby JET » 23. June 2010 08:41

Hallo,

jedes mal wenn ich den Eintrag session.use_trans_sid = 0 in meiner php.ini (die ini auf die natürlich verwiesen wird) ändere bleibt trotzdem die session.use_trans_sid auf 1 auch wenn ich logischer weise lampp neu gestartet habe.

Hat jemand eine Idee wie ich das auf "0" ändern kann?

Viele Grüße
JET
 
Posts: 2
Joined: 23. June 2010 08:26

Re: php.ini

Postby Nobbie » 23. June 2010 10:29

a) Wie überprüfst Du den Wert?

b) Stelle sicher, dass Du die richtige php.ini bearbeitest (es kann verschiedene geben). Vergleiche dazu die Angaben aus phpinfo() mit dem physikalischen Pfadnamen.

c) Der Paramater session.use_trans_sid kann nicht nur in der php.ini, sondern auch innerhalb eines Ordners mit Hilfe der Datei .htaccess überschrieben werden. Überprüfe das ggf.

d) Der Parameter session.usr_trans_sid kann außerdem auch innerhalb der Apache Konfiguration (httpd.conf beispielsweise, oder auch eine darunter includierte Konfigurationsdatei) überschrieben werden. Beispielsweise bei VirtualHost oder Directory Einstellungen. Auch das solltest Du ggf. überprüfen

e) Der Parameter session.use_trans_sid kann außerdem auch noch zur Laufzeit von jedem Script überschrieben werden (mit Hilfe der Funktion ini_set()). Überprüfe auch das ggf.
Nobbie
 
Posts: 7025
Joined: 09. March 2008 13:04

Re: php.ini

Postby JET » 23. June 2010 15:34

Hallo Nobbie,

erstmal danke für die Antwort.

a) ich überprüfe das an Hand der xampp phpinfo

b) dort steht auch der Konfigpfad der ini die ich bearbeitet habe

c) ich habe an der Standardinstallation nichts verändert wenn also irgendwo ein ein include ist dann weiss ich es nicht

d) in den VirtuellenHost habe ich auch kein include gemacht und wie es scheint ist auch keiner in der httpd.conf

e) so weit komme ich nicht weil ich das direkt nach einem Neustart in der xampp phpinfo kontroliere

Viele Grüße
JET
 
Posts: 2
Joined: 23. June 2010 08:26

Re: php.ini

Postby Nobbie » 23. June 2010 15:50

Dann ist Dein PHP kaputt.

P.S.: Wie hast es überhaupt geschafft, den Wert auf 1 zu setzen? Standardmäßig wird Xampp mit Wert 0 ausgeliefert.
Nobbie
 
Posts: 7025
Joined: 09. March 2008 13:04


Return to XAMPP für Linux

Who is online

Users browsing this forum: No registered users and 2 guests