Probleme bei einrichtung der Homepage

Irgendwelche Probleme mit XAMPP für Linux? Dann ist hier genau der richtige Ort um nachzufragen.

Probleme bei einrichtung der Homepage

Postby Marv94 » 01. April 2010 22:32

Hallo an alle. Ich hoffe es gibt einen der mir weiterhelfen kann.
Ich habe folgendes problem. Ich benutze jetzt zum ersten mal xampp
(lampp). Die ersten hürden habe ich bewältigt z.B. Die neue sicherheit mit dieser sch*** httpd-xampp.confg (oder wie die heißt).
Doch jetzt möchte ich meine homepage installieren (webspell) doch nun ist mein problem ich erstelle im ordner htdocs ein ordner erstellt wo ich
alle dateien reingeladen habe. Doch wenn ich den pfad öffnen möchte dann komm ich immer wieder automatisch auf das xampp interface.
Ich habe schon alles probiert (denke es zumindestens) doch nichts klappt.
Ich hoffe ihr könnt mir helfen.
Liebe grüße Marv

email : marv@smz-gaming.de
icq : 235868463
msn : marvin_holz@hotmail.de
Marv94
 
Posts: 1
Joined: 01. April 2010 22:23

Re: Probleme bei einrichtung der Homepage

Postby rod » 12. April 2010 13:24

Hi Marv,
deine index.php im htdocs folder (normalerweise /opt/lampp/htdocs) verweist noch auf die lampp Startseite. Hier ein Beispiel wie sie aussehen kann. Bei mir ist z.B. default das Directory in dem die Eingangs- bzw. Startseite des Servers liegt, falls keine spezielle URL gerufen wird. Ersetze default duch das Directory bzw. die Directory-Struktur in dem/der deine Startseite liegt, und es sollte klappen.Bitte darauf achten, dass sie z.B. index.htm oder index.php heißt (ref. auch httpd.conf unter DirectoryIndex für weitere Möglichkeiten).
<?php
if (!empty($_SERVER['HTTPS']) && ('on' == $_SERVER['HTTPS'])) {
$uri = 'https://';
} else {
$uri = 'http://';
}
$uri .= $_SERVER['HTTP_HOST'];
header('Location: '.$uri.'/default/');
exit;
?>
Oops, something went wrong. :-( Please contact the Webmaster.
rod
 
Posts: 5
Joined: 06. April 2010 15:51


Return to XAMPP für Linux

Who is online

Users browsing this forum: No registered users and 5 guests